Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Server allowing send by nonexistent user

  1. #1
    eniomarconcini is offline Intermediate Member
    Join Date
    May 2011
    Posts
    17
    Rep Power
    4

    Default Server allowing send by nonexistent user

    Hello all,

    Today I do a test.

    I have set up a account in Outlook with all correct informations about original zimbra account, but I typed like this "test@testdomain.com" in E-Mail field.

    So when I send a email, I see that my gmail receive a mail from test@testdomain.com

    My dns server has the spf configured to my true domain

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,567
    Rep Power
    57

    Default

    That would be because your account is configured to allow that, the feature is called "Persona". Did you search the forums first (there is information about this)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    eniomarconcini is offline Intermediate Member
    Join Date
    May 2011
    Posts
    17
    Rep Power
    4

    Default

    No I did not searched the forum first because I dont know the name of this kind of configuration, and I'm brazilian and my english is not so good.

    But, thanks... I will search now.

  4. #4
    tonnuchimse is offline Member
    Join Date
    Aug 2011
    Posts
    13
    Rep Power
    4

    Default

    Hi, I have the same question too. My case is similar to eniomarconcini.
    I have set up a account in Outlook (aacount name: test) with all correct informations about original zimbra account with domain.com, but I typed like this "test1@domain.com" in E-Mail field.
    I also disable Persona feature in Account test via Web, but the result is still the same.
    So please help me how to resolve this issue.
    Thank you

  5. #5
    eniomarconcini is offline Intermediate Member
    Join Date
    May 2011
    Posts
    17
    Rep Power
    4

    Default

    Right tonnuchimse, the feature Persona like phoenix says does not work too.

    the issue continues

  6. #6
    tonnuchimse is offline Member
    Join Date
    Aug 2011
    Posts
    13
    Rep Power
    4

    Default

    Dear eniomarconcini,
    Yesterday I found a solution that can resolve this problem.
    RestrictPostfixSenders - Zimbra :: Wiki
    After apply this, I can resolve my problem and hope you can do it.
    One note about this solution:
    In zmmta.cf file, there are 2 lines with the same value
    POSTCONF smtpd_sender_restrictions LOCAL postfix_sender_restrictions
    POSTCONF smtpd_sender_restrictions FILE postfix_sender_restrictions
    In my case, I delete the first line (line with "LOCAL") and it works.
    Hope this help and good luck!

  7. #7
    dipeshmehta is offline Special Member
    Join Date
    Jun 2010
    Location
    Rajkot, India
    Posts
    160
    Rep Power
    5

    Default

    Quote Originally Posted by tonnuchimse View Post
    Hi, I have the same question too. My case is similar to eniomarconcini.
    I have set up a account in Outlook (aacount name: test) with all correct informations about original zimbra account with domain.com, but I typed like this "test1@domain.com" in E-Mail field.
    I also disable Persona feature in Account test via Web, but the result is still the same.
    So please help me how to resolve this issue.
    Thank you
    In my test environment, as long as user gets authenticated or local network is in 'mynetworks' (which should not be), the user can have anything written in email field. Persona works only with ZWC or ZD. I might be wrong, but these are my observations.

    Dipesh

  8. #8
    tonnuchimse is offline Member
    Join Date
    Aug 2011
    Posts
    13
    Rep Power
    4

    Default

    Dear dipeshmehta,
    I think that Persona is not a suitable solution for this case.
    So, I have change 2 conditions to not allow sending mail with fake user or fake domain
    1. I restrict trusted zone is only 1 host (my Zimbra server only).
    2. I change the PostfixSender as guide above.
    Afterall, I can resolve my problems. All fake user or fake domain can not send email, they receive 553 server error

  9. #9
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    Hello, I followed all the instructions of the page RestrictPostfixSenders - Zimbra:: Wiki. In the final step, test the SMTP via Telnet, the server gives me the following error:

    zimbra @ zimbra: ~ $ telnet 10.24.0.22 25
    Trying 10.24.0.22 ...
    Connected to 10.24.0.22.
    Escape character is'^]'.
    220 ESMTP Postfix zimbra.radiorebelde.icrt.cu
    ehlo zimbra.radiorebelde.icrt.cu
    250-zimbra.radiorebelde.icrt.cu
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    DSN 250
    AUTH = PLAIN AGFkbWluQHRlc3RlemltYnJhLmNvbS5icgAxMjM0NTY
    503 5.5.1 Error: authentication not enabled

    What am I missing?

    regards

  10. #10
    dalmate is offline Elite Member
    Join Date
    Jan 2009
    Posts
    368
    Rep Power
    6

    Default

    @eniomarconcini: I think your server is an open relay server now.
    You can reconfigure your server by doing these works:
    - In zimbraAdmin --> go to the Global Configure --> choose MTA tab --> please uncheck TLS authenticate only and see some configuries in this tab.
    - After that, please restart postfix and recheck.
    And finally reporting for me and other know if you fixed it.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  2. Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 4
    Last Post: 09-22-2006, 06:19 PM
  3. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •