Results 1 to 8 of 8

Thread: emailing myself -› SPAM

  1. #1
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default emailing myself -› SPAM

    On a newly installed system when I send a mail to myself it goes straight to spam. I have checked that my server/ip is not blacklisted anywhere. Tailed the mailbox.log and zimbra.log... Where else should I look?

  2. #2
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default

    Adding server IP to spamassassin whitelist fixed it, here is how it is done:
    Code:
    [root@zimbra /]# su zimbra
    [zimbra@zimbra /]$ cd /opt/zimbra/conf/spamassassin
    [zimbra@zimbra spamassassin]$ nano local.cf 
    [Add line trusted_networks XX.XX.XX.XX , Ctrl+O: Save] 
    [zimbra@zimbra spamassassin]$ zmmtactl restart && zmamavisdctl restart
    Easy-peasy. I would still like to know WHY my mail went to spam, as it is quite possible that other servers might flag my messages as spam, which is undesirable. Someone please help: where do I find the spamfilter logs?
    Last edited by jerryboi; 07-22-2011 at 01:48 AM.

  3. #3
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    Check the raw message headers of the email you receieve from yourself. It should show every spamassassin rule and score that triggered the spam flagging.
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  4. #4
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default

    Thank you. The mail had this in the header:
    Code:
    X-Spam-Flag: YES
    X-Spam-Score: 6.83
    X-Spam-Level: ******
    X-Spam-Status: Yes, score=6.83 tagged_above=-10 required=6.6
    	tests=[BAYES_00=-1.9, HELO_NO_DOMAIN=0.001, HTML_FONT_FACE_BAD=0.981,
    	HTML_IMAGE_ONLY_16=1.092, HTML_MESSAGE=0.001, RCVD_IN_PBL=3.335,
    	RCVD_IN_SORBS_DUL=0.001, RDNS_NONE=0.793,
    	SHORT_HELO_AND_INLINE_IMAGE=1.39, TO_EQ_FM_DIRECT_MX=1.136]
    	autolearn=no
    RCVD_IN_PBL does the most damage, so I went to spamhaus and found that my IP is not listed. What can I do now?

    EDIT : Mz server IP is not listed, but the "X-Originating-IP" is. i don't see why sa checks that, should be a misconfig, surely?
    Last edited by jerryboi; 07-24-2011 at 06:12 AM.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by jerryboi View Post
    RCVD_IN_PBL does the most damage, so I went to spamhaus and found that my IP is not listed.
    It will be listed somewhere otherwise it wouldn't have failed the test. Which IP did you check?

    Quote Originally Posted by jerryboi View Post
    What can I do now?
    Do you have the x-originating-ip setting enabled in the Admin UI? If you do then disable it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    Are you on a home network connection, like cable or DSL, or is this server located on a business grade network connection or datacenter?
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by jerryboi View Post
    EDIT : Mz server IP is not listed, but the "X-Originating-IP" is. i don't see why sa checks that, should be a misconfig, surely?
    No, it's not.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default

    Krishopper, Phoenix, 10Q for your help, problem is solved by unticking "Add X-Originating IP to messages" on the admin interface under Configuration > Global Settings > MTA > Messages.

    @Krishopper The server is at a datacenter, but I logged on with dynamic IP from my isp's residential ip pool and this ip was in fact listed. (I put this in addendum to my previous post when I found out but you guys were lightning fast.)

    Thanks again, this is SOLVED.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. spam: how to block by sender alias
    By sangamc in forum Administrators
    Replies: 3
    Last Post: 05-10-2011, 06:29 AM
  2. Help mail server broadcast spam
    By sh1n_b3 in forum Administrators
    Replies: 0
    Last Post: 01-19-2011, 07:44 PM
  3. Spam being scored with BAYES_00
    By flyerguybham in forum Administrators
    Replies: 6
    Last Post: 04-24-2007, 12:07 PM
  4. Training spam and ham
    By Justin in forum Developers
    Replies: 2
    Last Post: 10-31-2006, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •