Results 1 to 6 of 6

Thread: Problem with disabling "Add X-Originating IP to messages"

  1. #1
    Mindaugas is offline Active Member
    Join Date
    Aug 2010
    Posts
    29
    Rep Power
    5

    Default Problem with disabling "Add X-Originating IP to messages"

    Hello,
    some of our customers connects to Zimbra server over POP3 from Outlook.
    When they send message to particular domain messages are rejected with this text:
    <xxxx@xxx.xx>: host mail.xxx.xx[xxx.xxx.xxx.xxx] said: 554
    Service unavailable; Client host [our zimbra server name] blocked using
    Barracuda Reputation;
    http://bbl.barracudacentral.com/q.cgi?ip=<public customer IP address> (in reply to end of
    DATA command)

    I realized that problem is with showing "Originating IP address".
    I disabled "Add X-Originating IP to messages" in Admin Console, but problem persist. When I send message from Web Console x-Originating IP is not added, but when I send from Outlook it appears again.

    I configured Outlook to submit messages over 465 port with enabled SSL encryption - the same problem.

    Please help me solve this problem.
    Thank You.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,569
    Rep Power
    57

    Default

    Quote Originally Posted by Mindaugas View Post
    Hello,
    some of our customers connects to Zimbra server over POP3 from Outlook.
    When they send message to particular domain messages are rejected with this text:
    <xxxx@xxx.xx>: host mail.xxx.xx[xxx.xxx.xxx.xxx] said: 554
    Service unavailable; Client host [our zimbra server name] blocked using
    Barracuda Reputation;
    http://bbl.barracudacentral.com/q.cgi?ip=<public customer IP address> (in reply to end of
    DATA command)
    Then you should go to the Barracuda site and get yourself removed from the list (or whitelisted).

    Quote Originally Posted by Mindaugas View Post
    I configured Outlook to submit messages over 465 port with enabled SSL encryption - the same problem.
    Port 587 (requires authentication) is the correct Submission port.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Mindaugas is offline Active Member
    Join Date
    Aug 2010
    Posts
    29
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Then you should go to the Barracuda site and get yourself removed from the list (or whitelisted).
    Our Zimbra server public IP address is not blacklisted, our customers public IP address is blacklisted which appears as X-Originating IP address.
    But anyway I filled tthe removal form.

    Quote Originally Posted by phoenix View Post
    Port 587 (requires authentication) is the correct Submission port.
    I've changed to 587 port. The same behavior.

    But main question is is it possible to disable adding of "X-Originating IP address" totally?

  4. #4
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default

    Configuration > Global Settings > MTA > Messages:
    [] Add X-Originating IP to messages

  5. #5
    Mindaugas is offline Active Member
    Join Date
    Aug 2010
    Posts
    29
    Rep Power
    5

    Default

    Quote Originally Posted by jerryboi View Post
    Configuration > Global Settings > MTA > Messages:
    [] Add X-Originating IP to messages
    Yes, this option is unchecked. But this option not working when mail is sent over SMTP (Outlook - POP3).

  6. #6
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    I know I am coming to this late, but the setting in Zimbra only applies to messages sent via ZCO or ZWC. If you have Outlook sending via SMTP, the X-Originating-IP header won't appear anyway. You'll see exactly the same result if your customer uses Thunderbird or any other POP/SMTP client (or IMAP/SMTP).

    The real issue here is that the receiving mail server is looking at the Received: headers and deciding to block the mail because a blacklisted ip address appears somewhere in there. This is a pretty bad practice--generally, you only want to block, if at all, based on the final hop before delivery.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 05-02-2011, 05:43 AM
  2. [SOLVED] How to change originating IP
    By epikos in forum Administrators
    Replies: 0
    Last Post: 03-31-2008, 04:39 PM
  3. Replies: 7
    Last Post: 03-12-2008, 05:25 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  5. multi domain / multi IP / SMTP HELO problem
    By fisch09 in forum Administrators
    Replies: 3
    Last Post: 04-04-2007, 05:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •