Results 1 to 6 of 6

Thread: Enabling SpamAssassin

  1. #1
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default Enabling SpamAssassin

    When we initially installed ZCS we did not enable the spam or virus features as we had an external device doing this. We've recently thought about spamassassin only in Zimbra, so I thought I'd try it out in our test environment.

    Like our production environment, our test environment is a multi-server setup.

    Via the admin web interface, I enabled the spamassassin service for both mta's. I then had to run zmspamctl start on each of the mta's.

    When I attempt to send an email from one internal account to another internal account it's being deferred and I'm finding this in the logs:

    Jun 22 12:29:20 mta1 amavis[1931]: (!)DENIED ACCESS from IP 192.168.1.234, policy bank ''

    Any idea what could be causing this?

  2. #2
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default

    Solution:

    On our mta's we have postfix bound to their internal ip's:

    smtp_bind_address = 192.168.1.234

    In amavisd.conf.in we had to add the bolded line below:

    $policy_bank{'MYNETS'} = {
    originating => 1,
    allow_disclaimers => %%binary VAR:zimbraDomainMandatoryMailSignatureEnabled%%,
    log_level => 1,
    @inet_acl = qw( 127.0.0.1 192.168.1.0/24 ),
    };

  3. #3
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default

    And how does one mark posts solved? I swear I did it once but can't see where.

  4. #4
    Jose12 is offline Starter Member
    Join Date
    Jul 2011
    Posts
    1
    Rep Power
    3

    Default Help me with the first steps you used to enable it.

    Do you need to create an account for it.

  5. #5
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default

    To enable spamassassin?

    In the web admin interface, I went to Configuration-->Services. Selected my mta's and under the Services tab selected Anti-Spam.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by ekmeek View Post
    And how does one mark posts solved? I swear I did it once but can't see where.
    It's a minor hiccup with a recent forum software upgrade, it will magically reappear.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem Install Zimbra ver 5.0.4_GA_2101.F7
    By maman in forum Installation
    Replies: 5
    Last Post: 04-14-2008, 12:50 PM
  2. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  3. Fedora 8 install
    By ahuman in forum Installation
    Replies: 31
    Last Post: 02-15-2008, 08:37 AM
  4. Fedora - latest versions?
    By sternfan in forum Installation
    Replies: 8
    Last Post: 01-09-2008, 05:53 AM
  5. Spamassassin Server
    By carnold in forum Administrators
    Replies: 0
    Last Post: 07-21-2007, 06:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •