Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: zmmailbox hostname

  1. #1
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default zmmailbox hostname

    In our multi-server ZCS setup, domains have a public service hostname that is different than the actual mail store they are on.

    This causes zmmailbox REST commands to fail with:

    ERROR: zclient.IO_ERROR (Unable to get REST resource from http://ourpublicdomain.com/home/user....com/?fmt=tgz: ourpublicdomain.com) (cause: java.net.UnknownHostException ourpublicdomain.com)

    Is there a way to get zmmailbox REST commands to use the internal store hostname instead of the public service hostname?

  2. #2
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    Did you try using zmmailbox with the "-u" (url) flag?
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  3. #3
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default

    Yes, I did try using the url flag. It still returns the error with the public service hostname.

    When I first started learning to use the zmmailbox command I thought I read somewhere about either a domain or server config option for cases such as this. That might just be wishful thinking as I've been searching and couldn't find any reference to one.

  4. #4
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

  5. #5
    sunil padelkar is offline Junior Member
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    3

    Unhappy getRestURL "//?fmt=tgz" doesnt work

    ERROR: zclient.IO_ERROR (Unable to get REST resource from http://severname/home/id/?fmt=tgz: mail server hostname) (cause: java.net.UnknownHostException mail server hostname)

    I am getting above error when trying to run getRestURL "//?fmt=tgz" in zmmailbox .I also have tried with -u option but it doesnt work.I have multi mailserver enviornment.

    Kindly reply.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by sunil padelkar View Post
    I am getting above error when trying to run getRestURL "//?fmt=tgz" in zmmailbox .I also have tried with -u option but it doesnt work.I have multi mailserver enviornment.
    Did you read the solution, and try it, in the post above yours?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    sunil padelkar is offline Junior Member
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    3

    Unhappy

    Quote Originally Posted by phoenix View Post
    Did you read the solution, and try it, in the post above yours?
    Actually at our site, we have multi mailsolution architecture.
    In zimbra we have ( a LDAP server, a MTA(Hub) server & 3 mailservers )
    Also we have few Lotus domino's server

    DNS is not configure for zimbra instead we forword all dns lookup to lotus hub server.
    In /etc/hosts file we have made all required entries of all internal server IP & related Public IP ( as suggested you in the solution). But when we tried to export mailbox using zmmailbox getRestURL ,we are getting error mention above.

    awaiting for reply.

    Regards,
    Sunil Padelkar
    Last edited by sunil padelkar; 11-09-2011 at 02:56 AM.

  8. #8
    sunil padelkar is offline Junior Member
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    3

    Default Help me

    can anyone please help me to resolved this issue?? If you want any information let me know.

    TIA,
    Regards,
    Sunil

  9. #9
    ekmeek is offline Active Member
    Join Date
    May 2010
    Posts
    35
    Rep Power
    4

    Default

    Could you post the full command you're using?
    Also, are you using a proxy?
    Do you have a public service hostname set on the domain of the mailbox you're running the command on?

  10. #10
    sunil padelkar is offline Junior Member
    Join Date
    Nov 2011
    Posts
    5
    Rep Power
    3

    Default

    Quote Originally Posted by ekmeek View Post
    Could you post the full command you're using?
    Also, are you using a proxy?
    Do you have a public service hostname set on the domain of the mailbox you're running the command on?
    Complete command :
    for restoration
    $zmmailbox -z -m testid@domain.com postRestURL "//?fmt=tgz&resolve=reset" /opt/zimbra/backup/testid.tgz

    for backup
    $zmmailbox -z -m testid@domain.com getRestURL "//?fmt=tgz" > /opt/zimbra/backup/testid.tgz


    No we havn't configured proxy yet

    Yes , we are using public service hostname set on domain

    Thanks in advance

    Regards,
    Sunil Padelkar

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. message-id headers contain unqualified hostname
    By wryfi in forum Administrators
    Replies: 26
    Last Post: 07-12-2011, 12:45 PM
  2. Changing Your Hostname
    By manthrax3 in forum Administrators
    Replies: 2
    Last Post: 12-27-2007, 06:15 PM
  3. Change hostname and IP Address!
    By celeron in forum Administrators
    Replies: 6
    Last Post: 07-15-2007, 09:27 PM
  4. Web mail MTA Hostname
    By melody in forum Administrators
    Replies: 16
    Last Post: 04-19-2007, 10:11 AM
  5. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •