Results 1 to 5 of 5

Thread: Export filter rules

  1. #1
    armitage318 is offline Intermediate Member
    Join Date
    May 2011
    Posts
    24
    Rep Power
    4

    Default Export filter rules

    Hi,

    how can I export filter rules for every user?
    I'm using Zimbra 5.0.10
    Thankyou

  2. #2
    vmahajan is offline Zimbra Employee
    Join Date
    Jan 2010
    Posts
    138
    Rep Power
    5

    Default

    Export the zimbraMailSieveScript account attribute.

  3. #3
    jerryboi is offline Special Member
    Join Date
    Apr 2006
    Posts
    111
    Rep Power
    9

    Default

    If you were to transfer filter rules from account a.geezer to b.geezer here is what you do:

    [zimbra@zimber tmp]$ zmprov ga a.geezer@yourdomain.eu zimbraMailSieveScript > /tmp/geezer.filter_rules.sieve
    [zimbra@zimber tmp]$ nano /tmp/geezer.filter_rules.sieve
    [zimbra@zimber tmp]$ chmod +x /tmp/geezer.filter_rules.sieve
    [zimbra@zimber tmp]$ ./geezer.filter_rules.sieve
    [zimbra@zimber tmp]$


    in nano you change the first characters from #name a. to zmprov ma b. and put the part beginning with require till EOF into single quotes.

    I realise this is not what the OP wanted, but I suppose he figured it out by now

  4. #4
    krishnaprasad is offline Starter Member
    Join Date
    Feb 2013
    Posts
    2
    Rep Power
    2

    Default Export filters from one user to all users in ZCS 8

    Dear All,

    We are using ZCS 8 , in that we want maintain global filters for all mail accounts.i have read a post how to transfer filters from one account to another account using 'zimbraMailSieveScript ' , can any one give the script to apply all accounts.

    Regards,
    krishnaprasad

  5. #5
    unc0nnected is offline Intermediate Member
    Join Date
    May 2014
    Posts
    23
    Rep Power
    1

    Default

    Above solution no longer works verbatim, you need to change the end .sieve file up just a little bit. Solution here

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speed up the net
    By mcesari in forum Administrators
    Replies: 10
    Last Post: 04-25-2008, 11:24 AM
  2. installation error during ldap setup
    By ljramos in forum Installation
    Replies: 23
    Last Post: 08-10-2007, 10:48 PM
  3. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 02:33 PM
  4. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  5. After Succesfull Install, Cannot Start mta
    By bsimzer in forum Installation
    Replies: 26
    Last Post: 12-16-2005, 05:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •