Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: unexpected slapd shutdown

  1. #1
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    348
    Rep Power
    8

    Default unexpected slapd shutdown

    This is
    Code:
    Release 7.1.0_GA_3140.RHEL5_20110329150824 CentOS5 FOSS edition.
    It was zimbra 5 upgraded to 6 and then to 7, running smoothly by 2 years, without ever a single issue.

    This morning at 9:45 o'clock it decided to do karakiri, sadly;

    Code:
    May 10 09:45:49 zimbra slapd[4396]: daemon: shutdown requested and initiated. 
    May 10 09:45:57 zimbra slapd[4396]: slapd shutdown: waiting for 0 operations/tasks to finish 
    May 10 09:45:59 zimbra slapd[4396]: slapd stopped. 
    May 10 09:46:07 zimbra postfix/smtpd[1437]: connect from localhost.localdomain[127.0.0.1]
    May 10 09:46:07 zimbra postfix/proxymap[30845]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server
    nothing more, nothing less.
    The Geotrust ssl cert was installed one week ago, without any issue.
    IMHO i need a more verbose logging level to do a diagnose.
    Which is the right level of log to diagnose this kind of problem?
    Is 256 like wiki suggest
    HTML Code:
    http://wiki.zimbra.com/index.php?title=Change_OpenLDAP_slapd_Logging
    the proper value?
    What do you suggest to set?

  2. #2
    resol is offline New Member
    Join Date
    Sep 2007
    Posts
    4
    Rep Power
    7

    Default

    Hi maumar,

    I have exactly the same problem, happened now already 3 times during the last month. Have you found out what might be the problem here already?

    After I stop and start the services everything is fine again until this happens again.

    I have the latest zimbra version running on ubuntu LTS.

    Thanks a lot!
    Stephan

  3. #3
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    348
    Rep Power
    8

    Default

    No, i have not solved.
    I have to increase ldap logging verbosity, but until now I was too busy.
    With default verbosity there is no chance to diagnose anything useful

  4. #4
    resol is offline New Member
    Join Date
    Sep 2007
    Posts
    4
    Rep Power
    7

    Default

    Anyway thanks for your reply!

    For me it maybe seems like sldapd got the message from somebody to shutdown, so if it didn't crash will there still be something to see if you increase the loglevel?

    Please keep me updated if you find out something.

    Thanks a lot,
    Stephan

  5. #5
    cvidal is offline Project Contributor
    Join Date
    Dec 2005
    Posts
    150
    Rep Power
    9

    Default Again

    Quote Originally Posted by maumar View Post
    Code:
    May 10 09:45:49 zimbra slapd[4396]: daemon: shutdown requested and initiated. 
    May 10 09:45:57 zimbra slapd[4396]: slapd shutdown: waiting for 0 operations/tasks to finish 
    May 10 09:45:59 zimbra slapd[4396]: slapd stopped. 
    May 10 09:46:07 zimbra postfix/smtpd[1437]: connect from localhost.localdomain[127.0.0.1]
    May 10 09:46:07 zimbra postfix/proxymap[30845]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server
    The same here, version 7.1.1, happened yesterday at 19:26 after more than a month of flawless uptime.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by cvidal View Post
    The same here, version 7.1.1, happened yesterday at 19:26 after more than a month of flawless uptime.
    Have you checked if you're certificates have expired? You could also check some of the solutions in these threads: site:zimbra.com +"dict_ldap_connect: Unable to set STARTTLS" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    nedm is offline New Member
    Join Date
    Aug 2011
    Posts
    3
    Rep Power
    3

    Default Same issue -- slapd: daemon: shutdown requested and initiated

    We're on 7.1.2_GA_3268/Ubuntu 10.04.3 and I see the same thing in zimbra.log before everything goes haywire. A simple
    Code:
    zmcontrol start
    starts up the affected services and everything runs smoothly, but the random nature and timing of the problem and the inability to see any root cause after combing the logs in /var/log and opt/zimbra/log makes me worried.

    Anyone else with any input would be greatly appreciated.

  8. #8
    vinzenz is offline Junior Member
    Join Date
    Nov 2010
    Posts
    7
    Rep Power
    4

    Default

    I have exactly the same problem: sldapd just stops and the whole mail system follows soon after.
    I had increased log verbosity of ldap to 512, but still all it says is
    Code:
    Dec  8 05:38:05 www slapd[22100]: daemon: shutdown requested and initiated.
    Dec  8 05:38:06 www slapd[22100]: slapd shutdown: waiting for 0 operations/tasks to finish
    Dec  8 05:38:07 www slapd[22100]: slapd stopped.
    I have no idea who initiated the shutdown and it seem to be unpredictable.
    Is this issue being investigated? I'd be happy to help if I can.

  9. #9
    sinmrki is offline Starter Member
    Join Date
    Dec 2011
    Posts
    1
    Rep Power
    3

    Default

    The same problem here, have anyone some solution or idea please? thank you.

  10. #10
    fseaton is offline Trained Alumni
    Join Date
    Mar 2007
    Posts
    27
    Rep Power
    8

    Default

    Same here, too. Zimbra master ldap server has been running flawlessly since last upgrade (in January to 7.1.3_GA_3346) and at 8 am this morning it just shut itself down:

    Mar 21 08:04:09 zcs1 slapd[19983]: daemon: shutdown requested and initiated.
    Mar 21 08:04:09 zcs1 slapd[19983]: slapd shutdown: waiting for 0 operations/tasks to finish
    Mar 21 08:04:11 zcs1 slapd[19983]: slapd stopped.


    Any ideas out there?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra won't start: slapd loglevel wildness
    By blackpuma in forum Administrators
    Replies: 6
    Last Post: 03-23-2009, 08:07 PM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Unexpected shutdown
    By geoffDeGeoffGeoff in forum Installation
    Replies: 9
    Last Post: 04-15-2008, 08:40 PM
  4. [SOLVED] Major slapd problem
    By sbutterfield in forum Administrators
    Replies: 14
    Last Post: 01-15-2008, 03:27 AM
  5. Replies: 5
    Last Post: 12-04-2007, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •