Results 1 to 10 of 10

Thread: [SOLVED] I broke my server trying to optimize... HELP!

  1. #1
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default [SOLVED] I broke my server trying to optimize... HELP!

    I stupidly tried to optimize my server using this how to:
    Zimbra OCS on a OpenVZ VPS Server « Le Pig
    Now my mailbox and my zmmailboxdctl are not running how can I fix it? I re-upgraded but the problem still exists and I don't quite know where to start.

    antispam Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Running
    snmp Running
    stats Running
    zmconfigd Running

    Help!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    I presume you reset the changes you made? Saying 'it's not working' doesn't actually tell us much, how about looking in the log files for the errors then searching the forums for a solution?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default

    I don't know how to reset the changes. How do you reset zmlocalconfig to defaults? I feel like such an idiot! I have been going through each of those setting trying to find out what the default is for each one with little success. I see that just replacing "zmlocalconfig" from a backup won't work because it doesn't actually contain any settings (in a text file). Which log files should I start with??

  4. #4
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default

    Lots of java errors in mailbox.log:

    2011-04-29 13:22:36,465 INFO [main] [] soap - Servlet SoapServlet starting up
    2011-04-29 13:22:36,498 INFO [main] [] soap - Adding service AccountService to SoapServlet
    2011-04-29 13:22:36,569 INFO [main] [] soap - Adding service MailService to SoapServlet
    2011-04-29 13:22:36,693 INFO [main] [] soap - Adding service IMService to SoapServlet
    2011-04-29 13:22:36,701 INFO [main] [] misc - version=7.1.0_GA_3140 release=20110329151347 builddate=20110329-1518 buildhost=zre-ubuntu10-64
    2011-04-29 13:22:36,703 INFO [main] [] misc - LANG environment is set to: null
    2011-04-29 13:22:36,703 INFO [main] [] misc - System property java.home=/opt/zimbra/jdk1.6.0_24/jre
    2011-04-29 13:22:36,703 INFO [main] [] misc - System property java.runtime.version=1.6.0_24-b07
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property java.version=1.6.0_24
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property java.vm.info=mixed mode
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property java.vm.name=Java HotSpot(TM) 64-Bit Server VM
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property java.vm.version=19.1-b02
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property os.arch=amd64
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property os.name=Linux
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property os.version=2.6.38-x86_64-linode17
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property sun.arch.data.model=64
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property sun.cpu.endian=little
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property sun.cpu.isalist=
    2011-04-29 13:22:36,704 INFO [main] [] misc - System property sun.os.patch.level=unknown
    2011-04-29 13:22:36,725 INFO [main] [] system - Setting mysql connector property: maxActive=100
    2011-04-29 13:22:36,740 INFO [main] [] system - Setting mysql connector property: maxActive=100
    2011-04-29 13:22:37,110 FATAL [main] [] system - Config initialization failed
    com.zimbra.common.service.ServiceException: system failure: getting all config entries
    ExceptionId:main:1304097757108:d06cc1d9a5c4804f
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:248)
    at com.zimbra.cs.db.DbConfig.getAll(DbConfig.java:170 )
    at com.zimbra.cs.util.Config.init(Config.java:67)
    at com.zimbra.cs.util.Config.initConfig(Config.java:9 3)
    at com.zimbra.cs.util.Config.getString(Config.java:10 5)
    at com.zimbra.cs.db.Versions.checkDBVersion(Versions. java:66)
    at com.zimbra.cs.db.Versions.checkVersions(Versions.j ava:62)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:163)
    at com.zimbra.cs.util.Zimbra.startup(Zimbra.java:123)
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 128)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:241)
    at org.mortbay.jetty.servlet.ServletHolder.initServle t(ServletHolder.java:440)
    at org.mortbay.jetty.servlet.ServletHolder.doStart(Se rvletHolder.java:263)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.servlet.ServletHandler.initializ e(ServletHandler.java:685)
    at org.mortbay.jetty.servlet.Context.startContext(Con text.java:140)
    at org.mortbay.jetty.webapp.WebAppContext.startContex t(WebAppContext.java:1254)
    at org.mortbay.jetty.handler.ContextHandler.doStart(C ontextHandler.java:517)
    at org.mortbay.jetty.webapp.WebAppContext.doStart(Web AppContext.java:471)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(HandlerCollection.java:152)
    at org.mortbay.jetty.handler.ContextHandlerCollection .doStart(ContextHandlerCollection.java:156)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerCollection.doStar t(HandlerCollection.java:152)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H andlerWrapper.java:130)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H andlerWrapper.java:130)
    at org.mortbay.jetty.handler.DebugHandler.doStart(Deb ugHandler.java:127)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(H andlerWrapper.java:130)
    at org.mortbay.jetty.Server.doStart(Server.java:224)
    at org.mortbay.setuid.SetUIDServer.doStart(SetUIDServ er.java:158)
    at org.mortbay.component.AbstractLifeCycle.start(Abst ractLifeCycle.java:50)
    at org.mortbay.xml.XmlConfiguration.main(XmlConfigura tion.java:985)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.mortbay.start.Main.invokeMain(Main.java:194)
    at org.mortbay.start.Main.start(Main.java:534)
    at org.mortbay.start.Main.start(Main.java:441)
    at org.mortbay.start.Main.main(Main.java:119)
    Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorEx ception: Unknown table engine 'InnoDB'

    Query being executed when exception was thrown:
    SELECT * FROM config


    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
    at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
    at java.lang.reflect.Constructor.newInstance(Construc tor.java:513)
    at com.mysql.jdbc.Util.handleNewInstance(Util.java:40 9)
    at com.mysql.jdbc.Util.getInstance(Util.java:384)
    at com.mysql.jdbc.SQLError.createSQLException(SQLErro r.java:1054)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:3566)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:3498)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:19 59)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java :2113)
    at com.mysql.jdbc.ConnectionImpl.execSQL(ConnectionIm pl.java:2568)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P reparedStatement.java:2113)
    at com.mysql.jdbc.PreparedStatement.executeQuery(Prep aredStatement.java:2275)
    at com.zimbra.cs.db.DebugPreparedStatement.executeQue ry(DebugPreparedStatement.java:156)
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeQuery(DelegatingPreparedStatement.java:96 )
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeQuery(DelegatingPreparedStatement.java:96 )
    at com.zimbra.cs.db.DbConfig.getAll(DbConfig.java:164 )
    ... 41 more

  5. #5
    jorge_s is offline Active Member
    Join Date
    Apr 2011
    Posts
    28
    Rep Power
    4

    Default

    Quote Originally Posted by myriad View Post
    Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorEx ception: Unknown table engine 'InnoDB'
    Something is wrong with your MySQL config .

    This what I would try:

    1. BACKUP ALL ZIMBRA DIRECTORY , just in case you screw things up worse. Back it up using rsync and first check that there are no processes being run by zimbra.
    2. Edit /opt/zimbra/conf/my.cnf and REVERT all the changes shown in the how-to you followed.
    3. If it works, backup it all again and schedule a re-install, it will reset most of the configuration changes.

    Hope this helps, good luck!

  6. #6
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default

    I did what you suggested but the mailbox, postfix and zmmailboxdctl is not running. So I tried an upgrade:

    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.imap_folder
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.imap_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.mail_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.mail_item_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.open_conversation
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.pop3_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.revision
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.revision_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup5.tombstone
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.appointment
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.appointment_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.data_source_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.imap_folder
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.imap_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.mail_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.mail_item_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.open_conversation
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.pop3_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.revision
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.revision_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup6.tombstone
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.appointment
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.appointment_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.data_source_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.imap_folder
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.imap_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.mail_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.mail_item_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.open_conversation
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.pop3_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.revision
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.revision_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup7.tombstone
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.appointment
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.appointment_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.data_source_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.imap_folder
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.imap_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.mail_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.mail_item_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.open_conversation
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.pop3_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.revision
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.revision_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup8.tombstone
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.appointment
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.appointment_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.data_source_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.imap_folder
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.imap_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.mail_item
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.mail_item_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.open_conversation
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.pop3_message
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.revision
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.revision_dumpster
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    mboxgroup9.tombstone
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.config
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.current_volumes
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.deleted_account
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.mailbox
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.mailbox_metadata
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.mobile_devices
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.out_of_office
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.scheduled_task
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.table_maintenance
    Error : Unknown table engine 'InnoDB'
    error : Corrupt
    zimbra.volume
    Error : Unknown table engine 'InnoDB'
    error : Corrupt

    We will see if the re-install will fix it, or not.

  7. #7
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default

    Didn't work! Still get the following:

    antispam Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Stopped
    postfix is not running
    snmp Running
    stats Running
    zmconfigd Running

  8. #8
    firemike is offline Active Member
    Join Date
    Apr 2010
    Location
    Germany
    Posts
    28
    Rep Power
    5

    Default

    You asked for zmlocalconfig "default-settings".

    Did you try zmlocalconfig --default
    (-d show default values for keys listed in [args] ) ?

    look at http://wiki.zimbra.com/wiki/CLI_zmlo...nfiguration%29

  9. #9
    myriad's Avatar
    myriad is offline Active Member
    Join Date
    Oct 2008
    Location
    Toronto
    Posts
    46
    Rep Power
    6

    Default

    Thanks, but I've restored from a backup and moved on! Though that command might come in useful for somebody else in the future.

  10. #10
    undersys is offline Active Member
    Join Date
    Jun 2010
    Posts
    30
    Rep Power
    4

    Default

    I am the author of that...

    I used it to get my zimbra servers running on an OpenVZ server.
    I take some concern that it broke your install.

    After all I wrote each step for what I did and used it as reference when my OpenVZ host crashed.

    I would of been glad to help if you contacted me.
    Also given that it seems to be a MYSQL error I don't think it was my guide.

    I am more then happy to fix an errors.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra cannot access via Web Interface
    By troya in forum Administrators
    Replies: 8
    Last Post: 03-21-2012, 11:54 PM
  2. Keeping a backup server synced with live server
    By Q-Mike in forum Administrators
    Replies: 5
    Last Post: 04-11-2008, 01:40 PM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM
  4. Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 4
    Last Post: 09-22-2006, 06:19 PM
  5. Replies: 18
    Last Post: 03-20-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •