Results 1 to 5 of 5

Thread: [SOLVED] MTA service restart failure (saslauthd problem)

  1. #1
    beli.sk is offline Intermediate Member
    Join Date
    Apr 2011
    Location
    Slovakia
    Posts
    18
    Rep Power
    4

    Default [SOLVED] MTA service restart failure (saslauthd problem)

    Hi fellow Zimbra admins,
    I noticed that the MTA service on my ZCS is down after every night.
    In the /var/log/zimbra.log I see:
    Code:
    Apr 26 23:18:22 nl01 postfix/smtpd[20115]: table hash:/etc/aliases(0,lock|fold_fix) has changed -- restarting
    Apr 26 23:18:22 nl01 postfix/postfix-script[20247]: refreshing the Postfix mail system
    Apr 26 23:18:22 nl01 postfix/master[30962]: reload -- version 2.7.2, configuration /opt/zimbra/postfix-2.7.2.2z/conf
    Apr 26 23:18:23 nl01 saslauthd[30970]: server_exit     : master exited: 30970
    Apr 26 23:18:24 nl01 saslauthd[20344]: set_auth_mech   : failed to initialize mechanism zimbra
    ... and after that the last message about the auth_mech is repeated every 30 seconds.
    Seems that saslauthd failed to start on MTA restart.
    Also when I try zmmtactl restart, I get the same error: "failed to initialize mechanism zimbra".
    I investigated further and found that I'm missing URL in the saslauthd.conf:
    Code:
    $ cat saslauthd.conf
    zimbra_url:
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off
    And the file modification time is at 23:18, so it was rewritten at the time of the automatic MTA restart.

    But in saslauthd.conf.in, there is a line (among others):
    Code:
    zimbra_url: %%getAllMtaAuthURLs%%
    so I suppose that this URL should be filled in automatically. And it really is, but only after I do a full restart of Zimbra with "zmcontrol restart", restart of MTA is not sufficient.

    Please advise why my saslauthd.conf is rewritten without the URL or how could I debug this issue further.

    Using ZCS Release 7.1.0_GA_3140.UBUNTU10_64 UBUNTU10_64 FOSS edition,
    some variables I checked but didn't find any discrepancies:
    Code:
    $ zmprov getServer nl01.coders.sk | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: nl01.coders.sk
    zimbraMtaAuthTarget: TRUE
    zimbraMtaAuthURL: https://nl01.coders.sk:443/service/soap/
    zimbraMtaSaslAuthEnable: yes
    zimbraMtaTlsAuthOnly: TRUE
    
    $ zmprov getServer nl01.coders.sk | grep Mode
    zimbraBackupMode: Standard
    zimbraIPMode: ipv4
    zimbraMailMode: redirect
    zimbraMailReferMode: wronghost
    zimbraMailSSLClientCertMode: Disabled
    zimbraOpenidConsumerStatelessModeEnabled: TRUE
    zimbraReverseProxyImapStartTlsMode: only
    zimbraReverseProxyPop3StartTlsMode: only
    Any help would be appreciated. Thank you very much.

    --
    Michal Belica - IT consultant

  2. #2
    beli.sk is offline Intermediate Member
    Join Date
    Apr 2011
    Location
    Slovakia
    Posts
    18
    Rep Power
    4

    Default

    Hm, no replies
    This problem disappeared when I did a clean install on a different hardware.
    Thanks anyway.

  3. #3
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    Don't know why this is marked [SOLVED], as the poster didn't resolve it, he just reinstalled. I'm encountering this same problem repeatedly on 7.1.3_P1

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by justdave View Post
    Don't know why this is marked [SOLVED], as the poster didn't resolve it, he just reinstalled.
    For the o/p that was the resolution.

    Quote Originally Posted by justdave View Post
    I'm encountering this same problem repeatedly on 7.1.3_P1
    What does the output of the following show:

    Code:
    zmprov gs `zmhostname`  | grep zimbraMtaAuthHost
    If that's not the FQDN of your Zimbra server then set it to that and restart Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    justdave is offline Trained Alumni
    Join Date
    Nov 2008
    Location
    Grand Rapids, MI
    Posts
    123
    Rep Power
    6

    Default

    It does return the fqdn of that host. And like the original poster, the zimbra_url field in sslauthd.conf is blank, and restarting the entirety of zimbra fixes it, just not restarting only the mta or saslauthd. So something is causing it to screw up that file periodically.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Saslauthd strat up failure
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:32 AM
  2. problem with mta and port 25
    By pepe27 in forum Installation
    Replies: 2
    Last Post: 04-03-2006, 11:48 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  4. Replies: 14
    Last Post: 12-22-2005, 04:59 PM
  5. MTA Service Stopped
    By Ryan Frantz in forum Administrators
    Replies: 7
    Last Post: 11-23-2005, 02:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •