Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: smtp port

  1. #1
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default smtp port

    Hi,

    I wonder what port is used for sending emails out when logged in at web client, and which one is used when sending emails from within Zimbra Desktop? How can I force port 587 usage for both send outs?

    Thanks!

  2. #2
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    This is kinda related to this thread started by me. I'm not sure about the concept behind this, but I'd like to have all outbound emails to be dk signed, and am not sure if they will when using the howto from the link I've posted in my other thread.

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    When using the Web UI & ZD (connected to a Zimbra server) you use port 80 (or preferably the more secure port 443) to compose an email and send it to the server, when mail is sent from the server to the outside world it uses Port 25 - the same as every other MTA.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    Thanks for responding.
    Sure, right, that's understandable. But what I want to achieve is to have all emails signed, no matter from where they were sent (ZD/web) and all guides say I should use port 587 for that.
    Can this be changed somehow and how? Is there any other way of signing emails when using DKIMProxy that I'm not aware about?

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by kaosmonk View Post
    Thanks for responding.
    Sure, right, that's understandable. But what I want to achieve is to have all emails signed, no matter from where they were sent (ZD/web) and all guides say I should use port 587 for that.
    Can this be changed somehow and how? Is there any other way of signing emails when using DKIMProxy that I'm not aware about?
    Use this instead (I use it and it works well): How to get DKIM (DomainKeys Identified Mail) working with Postfix on RHEL 5 / CentOS 5 using OpenDKIM – Steve Jenkins' Blog
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    Awesome! Will try that and get back to you if it helps!
    One more thing - I'm using MailArchiva thus having some options already set:

    Code:
    smtpd_milters = inet:mailarchiva_IP:chosen_port
    milter_default_action = tempfail
    and I have changed default milter port to chosen_port (same one from above) with

    Code:
    zmprov ms mail.server.com zimbraMilterBindPort chosen_port
    and that setup works. Now, what needs to be done in order to leave MailArchiva working? Would it be enough if I manually change and add a line like this:

    Code:
    smtpd_milters = inet:mailarchiva_IP:chosen_port, inet:127.0.0.1:20209
    Or should I perform something else? Will I need to switch zimbraMilterBindPort to something else in that case? Should I leave milter_default_action to tempfail or change it to accept (as shown in that howto of yours)?

    I'd appreciate any advice in regards to this, as it seems to me that I'm circling around...

    You already helped me alot!
    Last edited by kaosmonk; 04-26-2011 at 12:13 PM.

  7. #7
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    Ok, just to check if I'm moving to the right direction... judging by this link, non_smtpd_milters are used for signing only, but I believe that in my case, it wont hurt to have them included in smtpd_milters line too, right? The page also says that milter_default_action shouldn't be set to 'tempfail' as non_smtpd_milters will report a config error; but later on, text says that shouldn't be the problem for mail filters that digitally sign emails...
    So... I my case, I suppose I should have something like this:
    Code:
    smtpd_milters = inet:mailarchiva_ip:portnumber, inet:localhost:dkim_port
    non_smtpd_milters = inet:localhost:dkim_port
    milter_default_action = tempfail
    If I understood it right, I may leave the last parameter at 'tempfail' as it wont affect filter for digitally signing mails, right?

    If all this make sense, what I should set for zimbraMilterBindPort at the end?

  8. #8
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    Hi phoenix, can you please shed some light up to this matter? Would really appreciate it! Thanks!

  9. #9
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    I have tried to setup this by changing main.cf file and adding
    Code:
    smtpd_milters = inet:192.168.6.109:8092, inet:127.0.0.1:20209
    non_smtpd_milters = inet:127.0.0.1:20209
    milter_default_action = accept
    milter_protocol = 2
    but as soon as I run 'zmmtactl restart', main.cf file gets rewritten. 192.168.6.109 is an IP address of MailArchiva server.

    If I try to add another IP address from within Zimbra Admin panel: Server Settings > MTA > Milter Server > MilterServerBindAddress> 127.0.0.1, in main.cf I can see the line
    Code:
    smtpd_milters = inet:192.168.6.109 127.0.0.1:8092
    which I believe is not what I need, as only one port is shown...
    and if afterwards I try to set non_smtpd_milters as
    Code:
    non_smtpd_milters = inet:127.0.0.1:20209
    and after running 'zmmtactl restart' I get
    /opt/zimbra/conf/mta_milter_options: line 2: 127.0.0.1: command not found
    What am I doing wrong here? How can I setup both smtpd_milters and non_smtpd_milters to values I want them to have?

  10. #10
    kaosmonk is offline Intermediate Member
    Join Date
    Apr 2011
    Posts
    19
    Rep Power
    4

    Default

    bumping this thread - any idea on how to resolve this?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 03-30-2011, 10:32 PM
  2. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •