Results 1 to 8 of 8

Thread: zmlocalconfig troubleshooting

  1. #1
    leo de punk is offline Member
    Join Date
    Apr 2011
    Posts
    13
    Rep Power
    3

    Default zmlocalconfig troubleshooting

    Hi all,
    I am working with zimbra 6.0.12 and I have done a little mistake when I was configuring my zimbra box for black list users. I have used the command 'zmlocalconfig' and by a mistake I put some incorrect values to the main.cf file. Now main.cf file is edited with some incorrect values and I couldn't send or receive emails. please tell me how to change the values back to normal in main.cf file.
    my config was,

    zmlocalconfig -u 'postfix_smtpd_recipient_restrictions = check_recipient_access hash:/opt/zimbra/postfix/conf/protected_recipients, reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit'

    output of main.cf once postfix reloaded,

    main.cf
    queue_run_delay = 300spostfix_recipient_restrictions = check_recipient_access hash:/opt/zimbra/postfix/conf/protected_recipients, reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit

    I actually wanted to edit the 'smtpd_recipient_restrictions'. But it changed the value in 'queue_run_delay'

    error message when postfix reloading

    [zimbra@mail2 conf]$ postfix reload
    /opt/zimbra/bin/zmshutil: line 39: export: `=300s': not a valid identifier
    /opt/zimbra/bin/zmshutil: line 39: export: `=check_recipient_access hash:/opt/zimbra/postfix/conf/protected_recipients, reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit': not a valid identifier
    /opt/zimbra/bin/zmshutil: line 39: export: `=': not a valid identifier
    postfix/postfix-script: refreshing the Postfix mail system


    please tell me how to get rid of this problem, I have checked zmlocalconfig with '-u'. But it doesn't give any sense.

    thanks in advance
    regards
    leo

  2. #2
    Saturdays is offline Advanced Member
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    4

    Default

    you can use zmlocalconfig -e <args> to edit the configuration.

  3. #3
    leo de punk is offline Member
    Join Date
    Apr 2011
    Posts
    13
    Rep Power
    3

    Default

    Quote Originally Posted by Saturdays View Post
    you can use zmlocalconfig -e <args> to edit the configuration.
    Hi Satudays,
    thanks for your reply.
    I wanted to edit values in 'smtpd_recipient_restrictions' and my very first configuration was
    zmlocalconfig -e 'postfix_smtpd_recipient_restrictions = check_recipient_access hash:/opt/zimbra/postfix/conf/protected_recipients, reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit'

    it was added to the 'queue_run_delay' attribute instead of editing the 'smtpd_recipient_restrictions' in main.cf. thats why i mentioned that I made a mistake in my configuration. then I tried to recover that by using zmlocalconfig with -u option to unset the values.

    zmlocalconfig -u 'postfix_smtpd_recipient_restrictions = check_recipient_access hash:/opt/zimbra/postfix/conf/protected_recipients, reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, permit'

    But it doesn't give any positive solution. I tried it again with zmlocalconfig -e with default values of above attributes. But when I reload postfix, above mentioned (postfix reload error in my previous post) error is appearing.
    any idea???

    regards
    leo

  4. #4
    jorge_s is offline Active Member
    Join Date
    Apr 2011
    Posts
    28
    Rep Power
    3

    Default

    I think the correct sintax is:

    zmlocalconfig -e postfix_smtpd_recipient_restrictions = "VALUES"

    At least that's how they do it in the examples on the wiki.

  5. #5
    leo de punk is offline Member
    Join Date
    Apr 2011
    Posts
    13
    Rep Power
    3

    Default

    Quote Originally Posted by jorge_s View Post
    I think the correct sintax is:

    zmlocalconfig -e postfix_smtpd_recipient_restrictions = "VALUES"

    At least that's how they do it in the examples on the wiki.
    thanks jorge,

    the output of the above command as follows,
    [zimbra@testpc conf]$ zmlocalconfig -e postfix_smtpd_recipient_restrictions = "VALUES"
    Error: argument 'postfix_smtpd_recipient_restrictions' not in key=value form
    Is there any other way to define the values in postfix??
    let me know if you find anything..
    thanks

  6. #6
    FritzBrause is offline Partner (VAR/HSP)
    Join Date
    Jan 2008
    Location
    Berlin, Germany
    Posts
    201
    Rep Power
    7

    Default

    there must be no whitespaces. The exact syntax is e.g.

    Code:
    zmlocalconfig -e postfix_smtpd_recipient_restrictions="reject_unverified_recipient"
    Best regards

    Andreas Wolske

    managedhosting.de GmbH

    Zimbra Cloud Hosting, Consulting & Support
    VMware vCloud Powered Serviceprovider

  7. #7
    leo de punk is offline Member
    Join Date
    Apr 2011
    Posts
    13
    Rep Power
    3

    Default

    Quote Originally Posted by FritzBrause View Post
    there must be no whitespaces. The exact syntax is e.g.

    Code:
    zmlocalconfig -e postfix_smtpd_recipient_restrictions="reject_unverified_recipient"
    thanks,
    this seems working like no errors. but it doesn't undo what I have done previously. Anyway this was my mistake and i hope nobody else ever done this before.
    when I reload postfix following error is appearing, (this is a result of my previous comment as I guess)

    [zimbra@testpc conf]$ postfix reload
    /opt/zimbra/bin/zmshutil: line 39: export: `=VALUES': not a valid identifier

    anyway I have re-installed zimbra in another server while looking a solution for this.
    thanks everyone who give their feedbacks.

  8. #8
    FritzBrause is offline Partner (VAR/HSP)
    Join Date
    Jan 2008
    Location
    Berlin, Germany
    Posts
    201
    Rep Power
    7

    Default

    you may do a

    Code:
    zmlocalconfig -n | grep postfix
    to review your actual settings that have been changed from the default values. If you want to delete something you do a

    Code:
    zmlocalconfig -u postfix_smtpd_recipient_restrictions=""
    since postfix_smtpd_recipient_restrictions is a compiled default an cannot be deleted but reset to its default value.
    Best regards

    Andreas Wolske

    managedhosting.de GmbH

    Zimbra Cloud Hosting, Consulting & Support
    VMware vCloud Powered Serviceprovider

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i made a mess 4.5.6 -> 4.5.10 to a future 5.0 FOSS
    By innercy in forum Installation
    Replies: 7
    Last Post: 01-09-2008, 07:05 PM
  2. Server platform change RH to Ubuntu issues
    By marke in forum Administrators
    Replies: 5
    Last Post: 11-07-2007, 12:27 PM
  3. Mysql error on install
    By tommygun in forum Installation
    Replies: 17
    Last Post: 05-29-2007, 09:29 PM
  4. ZIMBRA!!!!! Error zmcontrol status and others
    By orison in forum Installation
    Replies: 8
    Last Post: 02-03-2007, 07:52 PM
  5. Zimbra Upgrade FAILED Badly
    By kelley.ch in forum Installation
    Replies: 1
    Last Post: 09-04-2006, 04:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •