A late reply, but I finally upgraded Ubuntu and Zimbra. Everything went fine, except that I got a Perl error about Perl_Tstack_sp_ptr when answering yes to " verify message integrity". I found on the forum that this is because it runs this with the installed zimbra version, which no longer works properly after upgrading to Ubuntu 10.04. Answering no to that question was no problem.

I did find a post in advance about installing libltdl7, to prevent clamav errors. So, I installed that beforehand.