Results 1 to 4 of 4

Thread: Defining "use prefix" behaviour for composing messages

  1. #1
    pessoa is offline Junior Member
    Join Date
    Apr 2011
    Posts
    5
    Rep Power
    4

    Default Defining "use prefix" behaviour for composing messages

    Each user can go into their mail composing preferences and set "use prefix" when replying or forwarding email.

    Since the installation default seems to be not "user prefix", is there some way to change it globally to have it on?
    I've been looking into the CoS but couldn't find such configuration.

    Thanks!

  2. #2
    orsomannaro is offline Senior Member
    Join Date
    Feb 2012
    Posts
    68
    Rep Power
    3

    Default

    Bump! Anyone?

  3. #3
    federico.bertola's Avatar
    federico.bertola is offline Special Member
    Join Date
    Jul 2006
    Location
    Verona, Italy
    Posts
    153
    Rep Power
    9

    Default

    You can set the user preferences ofuser even in COS, but you must use the zmprv cli command:

    Code:
    zmprov mc default zimbraPrefForwardReplyPrefixChar ">"
    zmprov mc default zimbraPrefReplyIncludeOriginalText includeBodyAndHeadersWithPrefix
    As you can see in /opt/zimbra/conf/attrs/zimbra-attrs.xml:
    Code:
    <attr id="130" name="zimbraPrefForwardReplyPrefixChar" type="astring" max="1" cardinality="single" optionalIn="account,cos,identity" flags="accountInherited,domainAdmin
    Modifiable">
      <defaultCOSValue>&gt;</defaultCOSValue>
      <desc>prefix character to use during forward/reply (deprecatedSince 5.0 in identity)</desc>
    </attr>
    ...some preferences are usable (optionalIn) also in COS.
    Federico Bertola
    CTO @ StudioStorti

  4. #4
    orsomannaro is offline Senior Member
    Join Date
    Feb 2012
    Posts
    68
    Rep Power
    3

    Default

    Thank you for your help Federico.

    Executing then suggest zmprov commands the only property that change its value is "Use prefix" in reply.


    I try to manually change property value like this:


    <attr id="133" name="zimbraPrefReplyIncludeOriginalText"
    ...
    <defaultCOSValue>includeBodyAndHeadersWithPrefix </defaultCOSValue>
    ...


    <attr id="134" name="zimbraPrefForwardIncludeOriginalText"
    ...
    <defaultCOSValue>includeBodyAndHeadersWithPrefix </defaultCOSValue>
    ...


    Then I create a new user: "Use prefix" flag for forwarding messages is False..


    Thank you again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 07:34 AM
  2. A lot of deferred and bounced messages
    By Labsy in forum Administrators
    Replies: 5
    Last Post: 11-11-2010, 01:43 PM
  3. Replies: 2
    Last Post: 11-03-2010, 07:06 AM
  4. New messages not showing up in outlook
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 4
    Last Post: 01-16-2007, 08:17 AM
  5. Spam assassain not traiing properly!
    By Mike T in forum Administrators
    Replies: 1
    Last Post: 10-09-2006, 01:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •