Results 1 to 2 of 2

Thread: [SOLVED] Error in Adresbook search

  1. #1
    ochm's Avatar
    ochm is offline Intermediate Member
    Join Date
    Oct 2010
    Rep Power

    Default [SOLVED] Error in Adresbook search

    Hi there,

    as i posted Autocomplete error, i found other error after upgrade from 6.0.8 to 7.0.1.
    When i pres to To in compose of new mail, i see my contacts, but if i want to search in cotacts, after Press Search button, i received error
    A network sevice error has occured, and in detail is:

    method: [unknown]
    msg: system failure: Caught IOException opening index
    code: service.FAILURE
    detail: soap:Receiver
    trace: com.zimbra.common.service.ServiceException: system failure: Caught IOException opening index ExceptionId:btpool0-28:// Code:service.FAILURE at com.zimbra.common.service.ServiceException.FAILURE ( at com.zimbra.cs.index.LuceneIndex.expandWildcardToke n( at com.zimbra.cs.index.MailboxIndex.expandWildcardTok en( at com.zimbra.cs.index.query.TextQuery.(TextQuery.jav a:113) at com.zimbra.cs.index.query.TextQuery.(TextQuery.jav a:67) at com.zimbra.cs.index.query.parser.QueryParser.creat eContactQuery( at com.zimbra.cs.index.query.parser.QueryParser.creat eQuery( at com.zimbra.cs.index.query.parser.QueryParser.toDef aultClause( at com.zimbra.cs.index.query.parser.QueryParser.toCla use( at com.zimbra.cs.index.query.parser.QueryParser.toQue ry( at com.zimbra.cs.index.query.parser.QueryParser.parse ( at com.zimbra.cs.index.ZimbraQuery.( 439) at at at 3747) at com.zimbra.cs.service.mail.Search.doSearch(Search. java:134) at com.zimbra.cs.service.mail.Search.handle(Search.ja va:114) at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:281) at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:158) at com.zimbra.soap.SoapServlet.doWork(SoapServlet.jav a:294) at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:215) at javax.servlet.http.HttpServlet.service(HttpServlet .java:725) at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra at javax.servlet.http.HttpServlet.service(HttpServlet .java:814) at org.mortbay.jetty.servlet.ServletHolder.handle(Ser at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at com.zimbra.cs.servlet.SetHeaderFilter.doFilter(Set at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at org.mortbay.servlet.UserAgentFilter.doFilter(UserA at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132) at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter( at org.mortbay.jetty.servlet.ServletHandler.handle(Se at at org.mortbay.jetty.servlet.SessionHandler.handle(Se at org.mortbay.jetty.handler.ContextHandler.handle(Co at org.mortbay.jetty.webapp.WebAppContext.handle(WebA at org.mortbay.jetty.handler.ContextHandlerCollection .handle( at org.mortbay.jetty.handler.HandlerCollection.handle ( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle( at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.handler.DebugHandler.handle(Debu at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest(Htt at org.mortbay.jetty.HttpConnection$ ntent( at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:756) at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa at org.mortbay.jetty.HttpConnection.handle(HttpConnec at at org.mortbay.thread.BoundedThreadPool$ n( Caused by: /opt/zimbra/index/0/13/index/0/_33_6.del (No such file or directory) at Method) at 2) at$SimpleFS IndexInput$Descriptor.( at$SimpleFS IndexInput.( at$NIOFSIndexI nput.( at at at com.zimbra.cs.index.LuceneDirectory.openInput(Luce at org.apache.lucene.util.BitVector.( 19) at org.apache.lucene.index.SegmentReader.loadDeletedD ocs( at org.apache.lucene.index.SegmentReader.get(SegmentR at org.apache.lucene.index.SegmentReader.get(SegmentR at org.apache.lucene.index.DirectoryReader.(Directory at org.apache.lucene.index.ReadOnlyDirectoryReader.(R at org.apache.lucene.index.DirectoryReader$1.doBody(D at org.apache.lucene.index.SegmentInfos$FindSegmentsF at at at at com.zimbra.cs.index.LuceneIndex.openIndexReader(Lu at com.zimbra.cs.index.LuceneIndex.getIndexReaderRef( at com.zimbra.cs.index.LuceneIndex.getIndexSearcherRe f( at com.zimbra.cs.index.LuceneIndex.expandWildcardToke n( ... 50 more

    Body: {
    SearchRequest: {
    _jsns: "urn:zimbraMail",
    field: "contact",
    limit: 50,
    locale: {
    _content: "en"
    offset: 0,
    query: ""m" (is:local)",
    sortBy: "nameAsc",
    types: "contact",
    tz: {
    id: "Europe/Belgrade"
    Header: {
    context: {
    _jsns: "urn:zimbra",
    account: {
    _content: "",
    by: "name"
    authToken: "(removed)",
    notify: {
    seq: 1
    session: {
    _content: 122,
    id: 122
    userAgent: {
    name: "ZimbraWebClient - [unknown] (Win)",
    version: "7.0.1_GA_3105"

    Any idea what is bad? It looks like a problem with indexes?

    Thank You


  2. #2
    ochm's Avatar
    ochm is offline Intermediate Member
    Join Date
    Oct 2010
    Rep Power


    The only one thing what to do is REINDEX user mailbox in Admin console.
    After reindex everything works well...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 12-20-2010, 06:13 PM
  2. Enhance Zimbra search to search local files
    By krabina in forum Developers
    Replies: 0
    Last Post: 11-03-2010, 02:28 PM
  3. [SOLVED] Unable to save advanced search in ZCS5
    By turnbulm in forum Administrators
    Replies: 3
    Last Post: 01-07-2008, 04:48 AM
  4. Search within search
    By zocs in forum Users
    Replies: 0
    Last Post: 12-24-2007, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts