Results 1 to 8 of 8

Thread: How to promote LDAP replica in 7.0

  1. #1
    rayb2001 is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Silicon Valley, CA
    Posts
    32
    Rep Power
    6

    Default How to promote LDAP replica in 7.0

    I've gone through the steps for 6.0 on my 7.0 installation and it isn't working.

    The wiki has several typos but even when I figured that out and got the correct inputs, the ldapadd in step f. just hangs (never comes back).

    I see in the 7.0 documentation references to configuring Zimbra Servers to use the LDAP Replica. Does this mean that the concept of "master" no longer applies? E.g., that you can point all the servers at the replica?

    Here's my goal, we have a zimbra mail server that is all contained on a single machine. We want to split that machine into several other machines (to scale the number of users). We intend, later, to decommission the existing machine.

    If I follow the instructions to use the replica LDAP, can I decommission the original LDAP server (and the replica LDAP server becomes the 'master')?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    If you're now using a more recent version of Zimbra you should update your forum profile with the output of the following command:

    Code:
    zmcontrol -v
    Quote Originally Posted by rayb2001 View Post
    I've gone through the steps for 6.0 on my 7.0 installation and it isn't working.
    Why did you not follow the instructions in the Zimbra 7 Multi-Server Installation Guide?

    Quote Originally Posted by rayb2001 View Post
    I see in the 7.0 documentation references to configuring Zimbra Servers to use the LDAP Replica. Does this mean that the concept of "master" no longer applies? E.g., that you can point all the servers at the replica?
    There's been no such change, you still need a Master plus as many replicas as you need.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rayb2001 is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Silicon Valley, CA
    Posts
    32
    Rep Power
    6

    Default Thanks, but I still can't find what I'm looking for

    Yes, I've been to the documentation site you suggest. I find no information about how to promote an LDAP replica to be the master, only information about how to setup multiple replicas.

    As I said, I have an existing LDAP server that I want to decommission. That is the LDAP master.

    All the new documentation seems to assume you are starting from scratch with 7.0. Is there a better place to be looking?

  4. #4
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,366
    Rep Power
    10

    Default

    Quote Originally Posted by rayb2001 View Post
    I've gone through the steps for 6.0 on my 7.0 installation and it isn't working.

    The wiki has several typos but even when I figured that out and got the correct inputs, the ldapadd in step f. just hangs (never comes back).

    I see in the 7.0 documentation references to configuring Zimbra Servers to use the LDAP Replica. Does this mean that the concept of "master" no longer applies? E.g., that you can point all the servers at the replica?

    Here's my goal, we have a zimbra mail server that is all contained on a single machine. We want to split that machine into several other machines (to scale the number of users). We intend, later, to decommission the existing machine.

    If I follow the instructions to use the replica LDAP, can I decommission the original LDAP server (and the replica LDAP server becomes the 'master')?
    I can find no comparable ZCS7 document to Promoting Replica to LDAP Master 6.0 - Zimbra :: Wiki

    Since you are on NE, my suggestion would be to open a support ticket with Zimbra.

    Zimbra may not accommodate you, but if it were me I would also ask that this ticket not decrement your allowed number of support requests, since you are filing it because Zimbra have yet to produce the 7.0 version of the documentation, and the 6.0 version isn't working for you.

    Hope that helps,
    Mark

  5. #5
    rayb2001 is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Silicon Valley, CA
    Posts
    32
    Rep Power
    6

    Default Thanks. Entered the support ticket

    Hopefully, there will be an updated set of instructions soon.

  6. #6
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    I don't see any reason why that document won't still work for 7.0.

    You could always set up two small VM's and install 7.0 on both of them, and try to promote a replica and see if it works without issue first.
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  7. #7
    rayb2001 is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Silicon Valley, CA
    Posts
    32
    Rep Power
    6

    Default

    Thanks. I did try that but it kept hanging on the ldapadd instruction. Also there are typo's in the doc (which I added to the Discussion tab). So, I'm not 100% sure I did it right. But the steps all worked up to the ldapadd instruction which seemed to hang (waited 2 minutes, no disk acitivty etc.)

  8. #8
    Krishopper is offline Dedicated Member
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    775
    Rep Power
    9

    Default

    Quote Originally Posted by rayb2001 View Post
    Thanks. I did try that but it kept hanging on the ldapadd instruction. Also there are typo's in the doc (which I added to the Discussion tab). So, I'm not 100% sure I did it right. But the steps all worked up to the ldapadd instruction which seemed to hang (waited 2 minutes, no disk acitivty etc.)
    Did you hit ENTER again at the bottom, so that you submitted a blank line into ldapadd? My first guess is that it's not necessarily hanging, but is still waiting for input from you. I believe ldapadd takes a blank line as the end of your input.
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] LDAP replica not connecting to master
    By CSVantage in forum Installation
    Replies: 0
    Last Post: 03-02-2011, 02:17 PM
  2. LDAP Replicas 4.5.x > 5.0.x
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 01-28-2008, 04:05 PM
  3. Problem with Ldap Replica on Etch - Zimbra OSS 5.0 GA
    By Thanakorn in forum Installation
    Replies: 11
    Last Post: 01-03-2008, 10:09 AM
  4. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  5. Replies: 2
    Last Post: 05-24-2006, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •