Results 1 to 7 of 7

Thread: Database Errors

  1. #1
    BigBirdy is offline Banned
    Join Date
    Feb 2009
    Location
    Squamish, BC
    Posts
    54
    Rep Power
    0

    Default Database Errors

    I recently upgraded the open-source version of Zimbra to the latest and noticed some database errors. Is there a script which can be run to do the "repair table" on the database or is there something else possibly wrong?

    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password=TGZN.IVQeLBcyqjxM34Tl5Cp.2es
    mboxgroup1.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup1.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup1.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup1.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup1.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup10.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup10.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup10.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup10.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup10.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup11.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup11.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup11.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup11.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup11.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup12.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup12.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup12.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup12.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup12.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup2.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup2.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup2.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup2.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup2.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup3.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup3.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup3.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup3.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup3.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup4.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup4.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup4.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup4.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup4.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup5.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup5.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup5.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup5.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup5.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup6.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup6.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup6.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup6.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup6.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup7.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup7.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup7.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup7.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup7.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup8.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup8.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup8.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup8.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup8.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup9.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup9.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup9.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup9.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup9.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mysql.general_log
    Error : You can't use locks with log tables.
    mysql.slow_log
    Error : You can't use locks with log tables.
    zimbra.config
    error : Table upgrade required. Please do "REPAIR TABLE `config`" or dump/reload to fix it!
    zimbra.deleted_account
    error : Table upgrade required. Please do "REPAIR TABLE `deleted_account`" or dump/reload to fix it!
    zimbra.jiveUserProp
    warning : 1 client is using or hasn't closed the table properly
    zimbra.mailbox
    error : Table upgrade required. Please do "REPAIR TABLE `mailbox`" or dump/reload to fix it!
    zimbra.mailbox_metadata
    error : Table upgrade required. Please do "REPAIR TABLE `mailbox_metadata`" or dump/reload to fix it!
    zimbra.mobile_devices
    error : Table upgrade required. Please do "REPAIR TABLE `mobile_devices`" or dump/reload to fix it!
    zimbra.out_of_office
    error : Table upgrade required. Please do "REPAIR TABLE `out_of_office`" or dump/reload to fix it!
    zimbra.scheduled_task
    error : Table upgrade required. Please do "REPAIR TABLE `scheduled_task`" or dump/reload to fix it!
    zimbra.table_maintenance
    error : Table upgrade required. Please do "REPAIR TABLE `table_maintenance`" or dump/reload to fix it!
    zimbra.volume
    error : Table upgrade required. Please do "REPAIR TABLE `volume`" or dump/reload to fix it!

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Quote Originally Posted by BigBirdy View Post
    I recently upgraded the open-source version of Zimbra to the latest and noticed some database errors. Is there a script which can be run to do the "repair table" on the database or is there something else possibly wrong?
    Details are in the Release Notes or search the forums for the error.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    BigBirdy is offline Banned
    Join Date
    Feb 2009
    Location
    Squamish, BC
    Posts
    54
    Rep Power
    0

    Default

    Well that was no help at all. Nothing in the release notes for 7, not a search for "database errors" returned anything that would help. Ran zmdbintegrityreport again, same errors. Below is whats in the release notes

    The following may need to be done before you upgrade.
    Zimbra Database Integrity Check
    Some customers have had corrupted databases prior to upgrade, and the
    upgrade has in some of those cases exacerbated the problem. In order to
    detect any corrupted databases as early as possible, we have added an
    optional step to check the MySQL database with zmdbintegrityreport prior to
    making any system changes. You are prompted to decide if you would like to
    run the zmdbintegrityreport.
    The zmdbintegrityreport can take minutes to an hour to run, depending on
    your system size and disk bandwidth. .
    Note: The zmdbintegrityreport is run on a weekly basis from cron on all
    zimbra-store nodes. Large sites can opt to disable this by setting
    zmlocalconfig -e zmdbintegrityreport_disabled=TRUE. If customers choose to
    disable this, it is recommended that the integrity reports be run by hand during
    the customerís normal maintenance windows and prior to running any ZCS
    upgrades

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Quote Originally Posted by BigBirdy View Post
    Well that was no help at all. Nothing in the release notes for 7, not a search for "database errors" returned anything that would help.
    Really, you do surprise me. I guess you read the Release Notes (you should do that before every upgrade) about upgrading and specifically the section on: "After the Upgrade is Complete"

    Then there's these threads: site:zimbra.com +"error : Table upgrade required." - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    BigBirdy is offline Banned
    Join Date
    Feb 2009
    Location
    Squamish, BC
    Posts
    54
    Rep Power
    0

    Default

    Thanks, found it EVENTUALLY. Since this was such an important and potentially damaging issue, post-upgrade, it certainly could have been more prominent, and even mentioned or scripted into the end of the upgrade script. Also, although I and others are certainly grateful for any help we can get, one simple pragmatic suggestion. If someone can take the time to post "go read the docs", they can also cut/post the actual section of the docs which details the solutions. The "helper" is actually providing a solution and the "helpee" gets the solution right away. Far more efficient for everyone involved.

    But still, thanks for the help.

  6. #6
    wodanymir's Avatar
    wodanymir is offline Member
    Join Date
    Feb 2009
    Location
    somewhere in Italy...
    Posts
    10
    Rep Power
    6

  7. #7
    BigBirdy is offline Banned
    Join Date
    Feb 2009
    Location
    Squamish, BC
    Posts
    54
    Rep Power
    0

    Default

    Thank you and grateful for your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 03:44 PM
  2. Replies: 6
    Last Post: 03-14-2011, 04:21 AM
  3. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM
  4. 4.5.10 logger database errors
    By jescombe in forum Administrators
    Replies: 7
    Last Post: 03-16-2008, 12:31 AM
  5. Database Integrity check report: Errors found
    By mcevoys in forum Administrators
    Replies: 8
    Last Post: 12-07-2007, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •