Results 1 to 7 of 7

Thread: [SOLVED] Database errors found after migration to 7.0.0

  1. #1
    albgdy is offline Member
    Join Date
    Aug 2009
    Location
    Gdynia, Poland
    Posts
    10
    Rep Power
    5

    Exclamation [SOLVED] Database errors found after migration to 7.0.0

    Hi,

    Last saturday after making a backup I upgraded from 6.09 GA to 7.0.0, it appeared everything ok running properly and I had after that also another backup. Since yesterday in the administration account is appearing the ad that database has errors and I should repair it.
    Zmcontrol status shows everything running properly.
    No strange messages in Zimbra.log
    What should I do or do you recommend?
    Os is GA7.0.0 and Server is HP 1 Xeon with 6Gb Ram plus 5 hard disks in Raid 5 because they are only 26 users.
    Thanks in advance.
    Alberto

    I add the message
    Database errors found.
    /opt/zimbra/mysql/bin/mysqlcheck --defaults-file=/opt/zimbra/conf/my.cnf -S /opt/zimbra/db/mysql.sock -A -C -s -u root --password=**********************
    mboxgroup1.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup1.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup1.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup1.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup26.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup26.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup26.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup27.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup27.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup27.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup27.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup27.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup28.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup28.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup28.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup28.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup28.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup29.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup29.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup29.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup29.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup3.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup3.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup3.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup3.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup3.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup30.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup30.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup30.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup30.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup30.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup31.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup31.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup31.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup31.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup31.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup32.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup32.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup32.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup32.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup32.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup33.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup33.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup33.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup33.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup33.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup34.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup34.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup34.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup34.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup34.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup35.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup35.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup35.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup35.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup35.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup36.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup36.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup36.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup36.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup36.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup37.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup37.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup37.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup37.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup37.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup38.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup38.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup38.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup38.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup38.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup39.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup39.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup39.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup39.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup39.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup4.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup4.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup4.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup4.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup4.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup40.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup40.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup40.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup40.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup40.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup41.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup41.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup41.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup41.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup41.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup42.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup42.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup42.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup42.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup42.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup43.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup43.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup43.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup43.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup43.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup44.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup44.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup44.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup44.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup44.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup45.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup45.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup45.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup45.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup45.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup46.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup46.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup46.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup46.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup46.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup47.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup47.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup47.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup47.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup47.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup48.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup48.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup48.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup48.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup48.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup49.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup49.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup49.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup49.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup49.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup5.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup5.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup5.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup5.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup5.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup50.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup50.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup50.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup50.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup50.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup6.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup6.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup6.imap_folder
    error : Table upgrade required. Please do "REPAIR TABLE `imap_folder`" or dump/reload to fix it!
    mboxgroup6.mail_item
    error : Table upgrade required. Please do "REPAIR TABLE `mail_item`" or dump/reload to fix it!
    mboxgroup6.pop3_message
    error : Table upgrade required. Please do "REPAIR TABLE `pop3_message`" or dump/reload to fix it!
    mboxgroup7.appointment
    error : Table upgrade required. Please do "REPAIR TABLE `appointment`" or dump/reload to fix it!
    mboxgroup7.data_source_item
    error : Table upgrade required. Please do "REPAIR TABLE `data_source_item`" or dump/reload to fix it!
    mboxgroup7.imap_folder
    TABLE `volume`" or dump/reload to fix it!
    Alberto

    ===========
    Ubuntu
    ===========

  2. #2
    Richelieu is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    22
    Rep Power
    5

    Default

    These errors are supposed to go away if you run the table upgrade script mentionned in the Release Notes as part of the upgrade process. If you haven't done it, I'd suggest you try that first.

  3. #3
    albgdy is offline Member
    Join Date
    Aug 2009
    Location
    Gdynia, Poland
    Posts
    10
    Rep Power
    5

    Default upgrade

    No I didn't because that instructions where under Multi Server installation and we have a single one.

    I see the script file as said in the pdf release notes file.

    /opt/zimbra/libexec/scripts/migrate20100913-Mysql51.pl

    Can I run it in production basis? what should be the consequences?
    Will be lost the mails received between upgrade and time when it was run the script?
    Alberto

    ===========
    Ubuntu
    ===========

  4. #4
    Richelieu is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    22
    Rep Power
    5

    Default

    People have reported here that it can be run in a production server without negative effect.

  5. #5
    albgdy is offline Member
    Join Date
    Aug 2009
    Location
    Gdynia, Poland
    Posts
    10
    Rep Power
    5

    Default mysql upgrade

    I see
    But also I see in previous threads that somebody as zimbra user and others try as root, what should be done?, I understand that should be as root no?
    Alberto

    ===========
    Ubuntu
    ===========

  6. #6
    Richelieu is offline Intermediate Member
    Join Date
    Oct 2009
    Posts
    22
    Rep Power
    5

    Default

    I ran it as zimbra.

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by albgdy View Post
    No I didn't because that instructions where under Multi Server installation.....
    No, they're not - the instructions to run that script are after the Single Server & the Multi-Server instructions in a separate paragraph titled: "After the Upgrade is complete". That means you run it after either a single server or multi-server upgrade and scripts are always run as the Zimbra user unless it's stated otherwise.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Error while upgrading to 7.0.0
    By Yuukuari in forum Installation
    Replies: 13
    Last Post: 02-15-2011, 08:14 AM
  2. Database errors found. now?
    By maumar in forum Installation
    Replies: 5
    Last Post: 04-02-2008, 05:13 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. Replies: 2
    Last Post: 10-04-2007, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •