Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: using zmmailbox export, getting "chunked stream ended unexpectedly"

  1. #11
    terencelhl is offline Junior Member
    Join Date
    Jul 2008
    Posts
    7
    Rep Power
    6

    Default Not only v7.x.x but ...

    Hi everyone,

    My organization is currently using Zimbra CE (zcs-6.0.14_GA_2928.UBUNTU8_64.20110802123336) and is also experiencing the error message mentioned (very frequent) whenever exporting any mailbox out from it.

    Am trying out alternative and revert if it works. Cheers.

  2. #12
    groop is offline Junior Member
    Join Date
    Dec 2011
    Posts
    6
    Rep Power
    3

    Default

    Quote Originally Posted by fvettore View Post
    Try with //?fmt=zip .
    This solved the problem for me on ZCS 7.1.0 even for very large accounts (30/40 GB)
    I use this version:
    Release 7.1.3_GA_3346.UBUNTU10_64 UBUNTU10_64 FOSS edition.

    and I tested tgz and zip but doesn't work for me.
    I running my export script and worked with the users of 99% but some account send this error message:

    ################################################## #####################

    zimbra@mail:/root$ /opt/zimbra/bin/zmmailbox -z -m test@test.com -v getRestURL "//?fmt=tgz" > /home/asd/test.tgz
    ERROR: zclient.IO_ERROR (Unable to get ?fmt=tgz) (cause: java.net.SocketTimeoutException Read timed out)
    com.zimbra.common.zclient.ZClientException: Unable to get ?fmt=tgz
    ExceptionId:main:1324317182756:6d7b4b057cc21c48
    Code:zclient.IO_ERROR
    at com.zimbra.common.zclient.ZClientException.IO_ERRO R(ZClientException.java:45)
    at com.zimbra.cs.zclient.ZMailbox.getRESTResource(ZMa ilbox.java:2401)
    at com.zimbra.cs.zclient.ZMailboxUtil.doGetRestURL(ZM ailboxUtil.java:2787)
    at com.zimbra.cs.zclient.ZMailboxUtil.execute(ZMailbo xUtil.java:1051)
    at com.zimbra.cs.zclient.ZMailboxUtil.main(ZMailboxUt il.java:2679)
    Caused by: java.net.SocketTimeoutException: Read timed out
    at java.net.SocketInputStream.socketRead0(Native Method)
    at java.net.SocketInputStream.read(SocketInputStream. java:129)
    at com.sun.net.ssl.internal.ssl.InputRecord.readFully (InputRecord.java:293)
    at com.sun.net.ssl.internal.ssl.InputRecord.read(Inpu tRecord.java:331)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(SSLSocketImpl.java:798)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDat aRecord(SSLSocketImpl.java:755)
    at com.sun.net.ssl.internal.ssl.AppInputStream.read(A ppInputStream.java:75)
    at java.io.BufferedInputStream.fill(BufferedInputStre am.java:218)
    at java.io.BufferedInputStream.read(BufferedInputStre am.java:237)
    at org.apache.commons.httpclient.ChunkedInputStream.g etChunkSizeFromInputStream(ChunkedInputStream.java :249)
    at org.apache.commons.httpclient.ChunkedInputStream.n extChunk(ChunkedInputStream.java:220)
    at org.apache.commons.httpclient.ChunkedInputStream.r ead(ChunkedInputStream.java:175)
    at java.io.FilterInputStream.read(FilterInputStream.j ava:116)
    at org.apache.commons.httpclient.AutoCloseInputStream .read(AutoCloseInputStream.java:107)
    at com.zimbra.cs.zclient.GetMethodInputStream.read(Ge tMethodInputStream.java:65)
    at com.zimbra.common.util.ByteUtil.copy(ByteUtil.java :668)
    at com.zimbra.common.util.ByteUtil.copy(ByteUtil.java :642)
    at com.zimbra.cs.zclient.ZMailbox.getRESTResource(ZMa ilbox.java:2399)
    ... 3 more
    zimbra@mail:/root$

    ################################################## #####################

    I tried some idea, but none of them helped.
    If you have any ideas please share with me!
    Thank you.

  3. #13
    bseclier is offline Junior Member
    Join Date
    Jun 2010
    Location
    Nancy (France)
    Posts
    7
    Rep Power
    4

    Default

    I have the same problem as you had groop. Did you solve it ?

  4. #14
    groop is offline Junior Member
    Join Date
    Dec 2011
    Posts
    6
    Rep Power
    3

    Default

    I couldn't.

  5. #15
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by groop View Post
    I couldn't.
    I guess you filed a bug report for this so it can be investigated?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #16
    Marcet's Avatar
    Marcet is offline Starter Member
    Join Date
    Apr 2008
    Posts
    2
    Rep Power
    7

    Default

    This issue is now solved. I believe release 7.1.4 solved this.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  2. installation error during ldap setup
    By ljramos in forum Installation
    Replies: 23
    Last Post: 08-10-2007, 10:48 PM
  3. unable to restart zimbra after reboot
    By droefs in forum Administrators
    Replies: 28
    Last Post: 04-16-2006, 02:33 PM
  4. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  5. After Succesfull Install, Cannot Start mta
    By bsimzer in forum Installation
    Replies: 26
    Last Post: 12-16-2005, 05:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •