Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Change default milter server bind port

  1. #1
    liveaverage's Avatar
    liveaverage is offline Active Member
    Join Date
    Apr 2008
    Location
    Gainesville, FL
    Posts
    32
    Rep Power
    7

    Default [SOLVED] Change default milter server bind port

    Good morning,

    Just upgraded to version 7.0 from 6.0.8 and I was wondering how to change the default milter server bind port? I tried searching the forums and wiki but couldn't seem to find anything. I'm assuming this a zimbra-configured option since any manual settings to the postfix main.cf file get overwritten each time I attempt a reload on the MTA -- not a big deal, and I'm a bit excited I won't have to manually change the postfix configuration after each upgrade :-)

    I've temporarily changed the port on our MailArchiva server (from 8092 to 7026) so we can still archive, but I'd like to know how/if I can change that port setting.

    Everything else looks and performs great with the upgrade!

    >JR

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    How about comment #19 on the bug report: Bug 8791 – make support for postfix-policyd easier
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    liveaverage's Avatar
    liveaverage is offline Active Member
    Join Date
    Apr 2008
    Location
    Gainesville, FL
    Posts
    32
    Rep Power
    7

    Default

    Is that related to the milter server bind port, or just cluebringer bind port? I was just hoping to change the milter server bind port (if possible). Again, not high priority since I changed listener port on the archiving server, but it'd be nice to know how to change it if it's possible Is it possible with the zimbra CLI already, or does it relate to the reported cluebringer bug?

    Thanks for the quick reply!

  4. #4
    liveaverage's Avatar
    liveaverage is offline Active Member
    Join Date
    Apr 2008
    Location
    Gainesville, FL
    Posts
    32
    Rep Power
    7

    Default

    Well, of course I find the attribute after the fact, but....

    Verify the milter bind port:

    Code:
    zmprov gs mail.server.com zimbraMilterBindPort
    Should return the default 7026

    Modify the milter bind port for MailArchiva (8092):

    Code:
    zmprov ms mail.server.com zimbraMilterBindPort 8092
    Make other changes directly to the main.cf file and restart MTA:

    Code:
    zmmtactl restart

  5. #5
    lytledd is offline Elite Member
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    448
    Rep Power
    5

    Default

    Just to add to this, for those with MailArchiva on a different machine:

    zmprov ms mail.server.com zimbraMilterBindAddress ip.address

    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  6. #6
    leep75 is offline New Member
    Join Date
    Aug 2010
    Location
    Indiana
    Posts
    3
    Rep Power
    4

    Default

    Quote Originally Posted by lytledd View Post
    Just to add to this, for those with MailArchiva on a different machine:

    zmprov ms mail.server.com zimbraMilterBindAddress ip.address

    Doug
    Can you elaborate on this more? I'm trying to get mailarchiva working again after upgrading from ZCS 6.0.10 to 7.01 this morning. I can't get it to work. My mailarchiva is on a different box. I've tried all options in this thread (as well as several other things found on the Internet).

    Thanks
    AL

  7. #7
    lytledd is offline Elite Member
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    448
    Rep Power
    5

    Default

    Quote Originally Posted by leep75 View Post
    Can you elaborate on this more?
    Lets say my server is domain.com and MailArchiva is on 10.0.0.11, I did the following:

    Code:
    zmprov ms domain.com zimbraMilterBindAddress 10.0.0.11
    zmprov ms domain.com zimbraMilterBindPort 8092
    
    zmmtactl restart
    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  8. #8
    leep75 is offline New Member
    Join Date
    Aug 2010
    Location
    Indiana
    Posts
    3
    Rep Power
    4

    Default

    Quote Originally Posted by lytledd View Post
    Lets say my server is domain.com and MailArchiva is on 10.0.0.11, I did the following:

    Code:
    zmprov ms domain.com zimbraMilterBindAddress 10.0.0.11
    zmprov ms domain.com zimbraMilterBindPort 8092
    
    zmmtactl restart
    Doug
    That's what I thought. I tried that and I added the line:
    milter_default_action = tempfail

    above the smtpd_milters = line in /opt/zimbra/postfix/conf/main.cf

    However, now when I check the main.cf there is no mention of my mailarchiva server ip 192.168.0.13 or the port 8092.

    Before running those commands should I login to my admin console and check the box to enable milters?

  9. #9
    lytledd is offline Elite Member
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    448
    Rep Power
    5

    Default

    Yes,

    I had to do that as well. Also note, the web admin console will show the incorrect port, even after updating.

    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  10. #10
    leep75 is offline New Member
    Join Date
    Aug 2010
    Location
    Indiana
    Posts
    3
    Rep Power
    4

    Default

    Quote Originally Posted by lytledd View Post
    Yes,

    I had to do that as well. Also note, the web admin console will show the incorrect port, even after updating.

    Doug
    Thanks for the help. I think it's finally working. However, I do have one strange issue. When I enabled the milter service and ran zmmtactl restart
    on the admin console the "MTA" is displaying a red X, however, I am sending and receiving mail both inside and outside my network. Any ideas on this?


    ****UPDATE*****
    I did a zmcontrol stop && zmcontrol start and that seemed to fix the red x. All is well! Thanks for the help.
    Last edited by leep75; 03-21-2011 at 12:05 PM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Replies: 9
    Last Post: 05-28-2008, 11:40 AM
  3. Replies: 45
    Last Post: 11-28-2007, 06:39 PM
  4. Can't bind to zimbra's ldap, port seems to be closed
    By penguinknight in forum Installation
    Replies: 6
    Last Post: 05-28-2007, 03:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •