Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Problem after Zimbra Upgrade

  1. #1
    jpsinacola is offline Intermediate Member
    Join Date
    Nov 2010
    Location
    Michigan
    Posts
    19
    Rep Power
    4

    Default Problem after Zimbra Upgrade

    Starting convertd...Failed.
    Starting convertd.../opt/zimbra/httpd-2.2.17/bin/httpd: /lib64/libc.so.6: version `GLIBC_2.10' not found (required by /opt/zimbra/httpd-2.2.17/lib/libapr-1.so.0)
    failed.

    and

    Starting spell...Failed.
    Starting apache.../opt/zimbra/httpd-2.2.17/bin/httpd: /lib64/libc.so.6: version `GLIBC_2.10' not found (required by /opt/zimbra/httpd-2.2.17/lib/libapr-1.so.0)
    failed.


    Both are looking for version GLIBC_2.10. I am running on SUSE Enterprise Server 11. Has anyone else had this problem or have a solution? WHen I do:

    # rpm -q glibc
    glibc-2.9-13.2

    Does this mean I need to update my GLIBC to accomodate the latest version of Zimbra Network Edition, 6.10.6 (i believe this is correct). I am not sure how to update my GLIBC if that is what is required. Any hellp is appreciated.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by andy21 View Post
    It's ok I found a fix and the FAQ's
    You found a fix for what? You haven't even asked a question nor given any information when requested.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by jpsinacola View Post
    Does this mean I need to update my GLIBC to accomodate the latest version of Zimbra Network Edition, 6.10.6 (i believe this is correct). I am not sure how to update my GLIBC if that is what is required. Any hellp is appreciated.
    Do I understand from your post that this error has occurred during an upgrade of Zimbr to 6.0.10 (that's the most recent version)?
    Last edited by phoenix; 02-04-2011 at 03:41 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by andy21 View Post
    Hey Bill,

    Sorry didnt reply, new to the whole internet thing. I got it all sorted, I just needed to update. Thanks anyway.
    How about updating your forum profile with the output of the following command (do not post the output in this thread):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    jpsinacola is offline Intermediate Member
    Join Date
    Nov 2010
    Location
    Michigan
    Posts
    19
    Rep Power
    4

    Default

    Bill,

    Yes, this occured during an update to the latest version 6.0.10. I have since tried to update SuSE, but the highlest level of GLIBC was glibc-2.9-13.11.1, which is what I am on now. After that update, I completely removed Zimbra, and reinstalled. Same errors. I removed it again and reverted back to 6.0.6, which is up right now. I will probably just wait until 7 comes out to upgrade again (fool me once). There is a SP1 available for SuSE, which I do not have installed, but I did not see anything in the update to 6.0.10 that would say, "Hey, watch out, you need GLIBC 2.10!", so that led me to believe I was doing something wrong. I would update my profile, but as I said, I reverted back to 6.0.6. Look, I am a Windows Server guy, a cycle I am trying to break, so I am fairly new with Linux. I bought a 150 user license pack for Zimbra and I want to migrate my Exchange 2003 server to Zimbra. So, that is what I am working on. The latest current version would be great. Thanks for the help Bill.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by jpsinacola View Post
    There is a SP1 available for SuSE, which I do not have installed, but I did not see anything in the update to 6.0.10 that would say, "Hey, watch out, you need GLIBC 2.10!", so that led me to believe I was doing something wrong.
    SP1 is a requirement for 6.0.9 upwards: Bug 52031 – SLES11_64 Network build : services failed to start due to GLIBC_2.10 not found. - it's also mentioned on P2 of the Release Notes.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    jpsinacola is offline Intermediate Member
    Join Date
    Nov 2010
    Location
    Michigan
    Posts
    19
    Rep Power
    4

    Default

    Blast. As much as I thought I looked I didn't see it. I looked briefly in the "Before you upgrade" section. Thanks for pointing out the fact that I hate to read and failed to plan. I'll get on installing SP1. Your assistance is appreciated.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by jpsinacola View Post
    Blast. As much as I thought I looked I didn't see it. I looked briefly in the "Before you upgrade" section. Thanks for pointing out the fact that I hate to read and failed to plan.
    Don't worry, everyone misses the one thing they should read in the Release Notes.

    Quote Originally Posted by jpsinacola View Post
    I'll get on installing SP1. Your assistance is appreciated.
    You're welcome.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    LMStone's Avatar
    LMStone is offline Moderator
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,366
    Rep Power
    10

    Default

    There's a Novell post somewhere, but the trigger for all of this is Novell deciding to upgrade the kernel version in SLES11-SP1 from the version in SLES11-GA (SP0).

    SUSE has never done this before with SLES to my knowledge (and I don't think Red Hat has done so either), so the article had Novell explaining that they were under great pressure to upgrade the kernel to have access to the hardware support, virtualization capabilities and other improvements in the later kernel. Novell claims they spent months talking with hardware vendors and ISVs to make sure that upgrading the kernel like that would not break any existing certifications. Oracle, HP, IBM etc. all said OK, so Novell pulled the trigger.

    In the past, Novell back-ported security fixes and other features from later kernels into the SLES kernel, to give customers the benefits of later kernels but the stability of an ISV-certified system.

    The article had Novell claiming that things like KVM functionality, support for ext4, btrfs and other in-demand features of the later kernel were not capable of being backported to the version of the kernel in SLES11-SP0.

    Hope that helps!
    Mark

  10. #10
    ansori is offline Starter Member
    Join Date
    Apr 2010
    Posts
    1
    Rep Power
    4

    Default

    hello,
    some body help me please, i'm have a problem service zimbra "zmapachectl is not running". there is message like this :
    ---------------------------------------------------------
    Starting apache.../opt/zimbra/httpd-2.2.22/bin/httpd: /lib64/libc.so.6: version `GLIBC_2.10' not found (required by /opt/zimbra/httpd-2.2.22/lib/libapr-1.so.0)
    ----------------------------------------------------
    my zimbra is Release 7.2.0_GA_2669.SLES11_64_20120410001942 SLES11_64 FOSS edition.

    regards,
    aan

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fatal: parameter "smtpd_recipient_restrictions"
    By Robin in forum Administrators
    Replies: 8
    Last Post: 12-22-2010, 05:48 AM
  2. Zimbra 6 on Ubuntu 8.04 x64 reverting to IPv6
    By nimble7 in forum Installation
    Replies: 1
    Last Post: 11-30-2010, 12:03 AM
  3. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 07:40 AM
  4. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  5. Replies: 16
    Last Post: 09-07-2006, 06:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •