Results 1 to 5 of 5

Thread: [SOLVED] sender_bcc not working?

  1. #1
    rabettle is offline Intermediate Member
    Join Date
    Aug 2010
    Location
    Bellingham WA
    Posts
    23
    Rep Power
    4

    Default [SOLVED] sender_bcc not working?

    So, I can't figure this out I repeatedly get this error

    postmap: fatal: opendatabase /opt/zimbra/postfix-2.6.7.2z/sernder_bcc.db Permission denied.

    I am running 6.10.

    I edit main.cf and add this at the bottom

    sender_bcc_maps = hash:/opt/zimbra/postfix-2.6.7.2z/sender_bcc

    i edit /opt/zimbra/postfix-2.6.7.2z/sender_bcc to have this

    @domain.dom archive@target.server.com

    both files are rootostfix with 644 permissions ... idk I am at a total loss here.

    centos 5.5 fully updated. i dont know what else to try.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,495
    Rep Power
    56

    Default

    You should update your forum profile with the output of the following command (do not post the output in this thread):

    Code:
    zmcontrol -v
    Quote Originally Posted by rabettle View Post
    postmap: fatal: opendatabase /opt/zimbra/postfix-2.6.7.2z/sernder_bcc.db Permission denied.
    Did you actually run that command as the Zimbra user?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rabettle is offline Intermediate Member
    Join Date
    Aug 2010
    Location
    Bellingham WA
    Posts
    23
    Rep Power
    4

    Default

    yes run as zimbra user and i get that failure message.

    only thing i can think of is SELinux is active and set to enforcing.

    *update*

    disabled selinux, reboot, same error.

    /var/log/zimbra.log:
    zimfe6 postfix/postmap[8045]: fatal: open database /opt/zimbra/postfix-2.6.7.2z/sender_bcc.db: Permission denied

    so yeah idk. i can't find any other error info and web searches haven't given me a lot to go on.
    Last edited by rabettle; 01-29-2011 at 03:07 PM.

  4. #4
    rabettle is offline Intermediate Member
    Join Date
    Aug 2010
    Location
    Bellingham WA
    Posts
    23
    Rep Power
    4

    Default

    really need a hand resolving this one.

  5. #5
    rabettle is offline Intermediate Member
    Join Date
    Aug 2010
    Location
    Bellingham WA
    Posts
    23
    Rep Power
    4

    Default

    I still can't figure this out. Any suggestions?

    *edit*

    Found the problem. I had sender_bcc in /opt/zimbra/postfix/ as that is what was suggested in the doc i was working off. On a whim i tried moving that file into postifx/conf and received an authentication error. I then cd /conf and did a touch sender_bcc and that worked fine.

    copied the contents of the old sender_bcc and adjusted the path in ~/conf/main.cf then did a postmap sender_bcc and a postfix reload and all is well.

    from here i duplicated the previous process for recipient_bcc and i now have working sender and recipient bcc maps.

    now to setup rsync so other MTAs can access the same maps.
    Last edited by rabettle; 02-02-2011 at 02:25 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Forwarding not working correctly
    By cshabazian in forum Administrators
    Replies: 2
    Last Post: 12-07-2010, 05:56 PM
  2. Documents not working
    By scasperson in forum Installation
    Replies: 1
    Last Post: 11-04-2010, 12:06 AM
  3. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  4. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 07:25 PM
  5. Zimbra stoped working overnight
    By vlskip in forum Installation
    Replies: 32
    Last Post: 03-07-2006, 01:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •