Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: NOQUEUE: reject: RCPT from unknown[10.1.10.8]: 554 5.7.1

  1. #1
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Question NOQUEUE: reject: RCPT from unknown[10.1.10.8]: 554 5.7.1

    Hi all, Newbie to Zimbra, but love it.
    I did a new install and we can send and receive emails fine via the admin panels.
    I am in the process of setting up the girls desktop to use Outlook and can receive fine, but will not send. In the log files I am seeing this every time I try to send via Outlook.

    Code:
    Jan 12 23:43:45 mail postfix/smtpd[23453]: connect from unknown[10.1.10.8]
    Jan 12 23:43:45 mail postfix/smtpd[23453]: setting up TLS connection from unknown[10.1.10.8]
    Jan 12 23:43:45 mail postfix/smtpd[23453]: Anonymous TLS connection established from unknown[10.1.10.8]: TLSv1 with cipher RC4-MD5 (128/128 bits)
    Jan 12 23:43:45 mail postfix/smtpd[23453]: NOQUEUE: reject: RCPT from unknown[10.1.10.8]: 554 5.7.1 <unknown[10.1.10.8]>: Client host rejected: Access denied; from=<daniel@mysite.com> to=<dan@gmail.com> proto=ESMTP helo=<DANIEL>
    Jan 12 23:43:48 mail postfix/smtpd[23453]: disconnect from unknown[10.1.10.8]
    Jan 12 23:44:09 mail zmmailboxdmgr[26220]: status requested
    Jan 12 23:44:09 mail zmmailboxdmgr[26220]: status OK
    Jan 12 23:44:11 mail postfix/postfix-script[26325]: refreshing the Postfix mail system
    Jan 12 23:44:11 mail postfix/master[3550]: reload -- version 2.6.7, configuration /opt/zimbra/postfix-2.6.7.2z/conf
    Jan 12 23:44:11 mail postfix/anvil[23455]: statistics: max connection rate 1/60s for (submission:10.1.10.8) at Jan 12 23:42:07
    Jan 12 23:44:11 mail postfix/anvil[23455]: statistics: max connection count 1 for (submission:10.1.10.8) at Jan 12 23:42:07
    Jan 12 23:44:11 mail postfix/anvil[23455]: statistics: max cache size 1 at Jan 12 23:42:07
    I know it has something to so with a setting in the admin, but what would I need to do to allow all ip(s) from lets say 10.1.10.1 to 10.1.10.1.100? On the network where we have local machines that will be sending via Outlook and their ip(s) range let's say from 10.1.10.2 to 10.1.10.20? I would like to know where in the GUI admin I need to fix this problem (really not a problem, but a setting) to allow for sending out of Outlook.

    Forgot to mention that my MTA Trust networks in the Admin under server is currently set to 127.0.0.0/8 75.149.178.0/24

    Thanks in advance - Daniel
    Last edited by Danielc1234; 01-13-2011 at 07:36 AM. Reason: Added information

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by Danielc1234 View Post
    Forgot to mention that my MTA Trust networks in the Admin under server is currently set to 127.0.0.0/8 75.149.178.0/24
    If you're behind a NAT router then the 75.149.178.0 entry is incorrect and (I assume) it's your public IP address and shouldn't be in there - details here: ZimbraMtaMyNetworks - Zimbra :: Wiki

    I'll also move this to the correct forum as it's not specifically an Installation question.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Default

    Thanks for the reply!!

    Well if this is correct, then can you tell me why I am unable to send emails via Outloook? And those are the errors I am getting. That 10.1.10.08 ip address is a machine that we have within the local network that I tested the send from.

    Any advice would be greatly appreciated!

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    You need to modify the mynetworks setting to have the LAN in there and you also need to have a Split DNS set-up (do you) for your server to send email. Once those settings have been made and you set-up your Outlook clients to send via the correct Submission port 587 (and also authenticate) you should have no problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Default

    Bill, thanks so much for your speedy replies. This obviously is a great forum!

    We are not using a split DNS because we figured we would not need it cause we are just using our public ip as the mail server.

    Please bear with me, whereas this is all so new to me and I am trying to learn everything about zimbra, so a lot of the language I might not fully understand.

    Can all these settings be accomplished in the Admin GUI? And if not, could you point me to a wiki or something that describes how to do this? Cause you mention 'modify mynetworks settings', but not sure what manner to do this.

    Like I mentioned earlier, zimbra is working fine on its own, it is just with Outlook that I am having issues. And once again I apologize if my lack of knowledge is frustrating for you....trust me, I know what that feels like.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    OK, your description helps - leave the mynetworks setting for the moment. You need to set-up your Outlook client (I assume you're using IMAP?) to send mail via the Zimbra server using port 587 and that connection needs to be authenticated with the user details account and password - that should be sufficient for the client to send email.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Default

    Hey phoenix,

    Yes, I had set the setting to that port and connection, I had forgotten to set the authenticated and it is WORKING now!

    Thanks so much for your help.

    I do not know how to put {SOLVED} in the top header.

  8. #8
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Default

    Phoenix,

    Spoke too soon. Two of the machines inside the network are not sending. However the gateway on these two machines are different. They are using a separate isp. If I know the ip they are sending from (the public), how can I add it to the safe list of ip(s)?

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,586
    Rep Power
    57

    Default

    Quote Originally Posted by Danielc1234 View Post
    Spoke too soon. Two of the machines inside the network are not sending. However the gateway on these two machines are different. They are using a separate isp. If I know the ip they are sending from (the public), how can I add it to the safe list of ip(s)?
    That shouldn't make any difference, if they connect to the server and authenticate against it then they should be able to send email. You say they 'can't send' but do they receive email OK? Get them to try sending an email and have a look (or tail the log) in the log files and see what errors you get.

    You should not, under any circumstances, add a user IP to the Trusted Networks - if they get compromised you've just allowed them to relay mail through your server unhindered and you'll get the server blacklisted.

    You can mark a thread as 'solved' from the Thread Tools drop down at the top of this page..
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Danielc1234 is offline Member
    Join Date
    Jan 2011
    Posts
    14
    Rep Power
    4

    Default

    Phoenix,
    No they can not even receive emails as well. Let me describe the network more in detail, then I think you will see what I am talking about.

    The network guy made it so a section of computers can set their gateway and use one of our isp providers and if you set your gateway to the other gateway ip address, it allows you to use our other service provider.

    The public ip address to our mailserver is 75.149.178.250 with local machines using 10.1.10.3 to 10.1.10.20. However those machines within that range also have the ability to switch ips by changing their gateway settings, like I mentioned above.

    When I got on one of the machines that is not working and did a whatismyip I got back 99.140.23.104, which I know is the ip for that network.

    Right now in my Servers MTA I have this setting 127.0.0.0/8 75.149.178.0/24 10.1.10.0/24

    Is that the way it should be? I added the 10.1.10.0/24 to allow for local connection, but not sure if I needed it.

    Also, wouldn't I want to add that 99.140.23.104 ip so that mailserver would recognize them as well?

    I checked the log files and do not see any reference to my trying to connect on the machines that will NOT connect.

    Ideas?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Im Panicing. "Could not send message due to invalid address(es)"
    By Thomas.Curtis in forum Administrators
    Replies: 11
    Last Post: 06-09-2010, 05:32 AM
  2. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM
  3. Replies: 12
    Last Post: 03-14-2006, 12:02 PM
  4. Is my server being used to forward spam?
    By sgb in forum Administrators
    Replies: 11
    Last Post: 03-07-2006, 12:42 PM
  5. New Install
    By rshol in forum Administrators
    Replies: 12
    Last Post: 12-14-2005, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •