Our server's cert is expiring.

I have tried to import the new one, but I keep getting the following error:
Code:
	
Your certificate was not installed due to the error : system failure: XXXXX ERROR: Invalid Certificate Chain: /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp/current.crt:
I have tried the instructions from the 5.0 wiki here:
Installing a Verisign Secure Site Certificate - Zimbra :: Wiki

And I tried using the new Intermediate certs (both individual and a single bundle as the root cert.

All attempts have lead to the same error message. Anyone have any ideas? I'm guessing its the fun of intermediate certs and maybe the admin console (I know this was an issue at one point)...

Thanks!