Hello,

I face the following problem with our evaluation setup (Release
6.0.9_GA_2686.RHEL5_64_20101115224141 Network edition),
we use a separate account to create shared notebooks for
groups. Now if a user attaches a file to a page inside the shared
notebook the link generated is wrong and results in a 404 'no
such item' when retrieving the item from said page.

In detail (names changed) :

management account : group_manager
user account : user_a

shared notebook at

http://server.domain/home/group_manager@domain/NotebookGroup/NoteBook

If user_a creates a page it will be correctly inserted and stored at

http://server.domain/home/group_manager@domain/NotebookGroup/NoteBook/Page1

If user_a now tries to add and upload an attachment it will be
inserted and referenced (inside the page and when browsing the
notebook) as

http://server.domain/home/user_a@domain/NotebookGroup/NoteBook/Attachment1.xxx

but stored on the server as

http://server.domain/home/group_manager@domain/NotebookGroup/NoteBook/Attachment1.xxx

I can go in manually and change the link inside the page to the
correct

http://server.domain/home/group_manager@domain/NotebookGroup/NoteBook/Attachment1.xxx

so that the attachment is retrievable again but I'm not sure how to
fix the browse interface.

Is this something known which might have a workaround or am I
missing something essential ?
It's kind of painful to remember to fix the link after uploading.

I haven't tried shared briefcases yet.

thanks & kind regards
gerrit