Results 1 to 8 of 8

Thread: [SOLVED] Cannot reply to mails in shared Inbox with me - Permission denied

  1. #1
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default [SOLVED] Cannot reply to mails in shared Inbox with me - Permission denied

    And finally I have to open a thread for this. Tried my best to get this working but it just won't. I will try to make it as simple and clear as possible.

    We have an shared Inbox which we use to manage internal work. Its shared with two others besides me. So I have this share accepted and inbox is safe in web client. The problem is when I try to reply to a mail in it ('on behalf of') from my inbox, it fails with this error

    Permission denied.
    method: SendMsgRequest
    msg: permission denied: you do not have sufficient permissions
    code: service.PERM_DENIED
    detail: soap:Sender
    trace: com.zimbra.common.service.ServiceException: permission denied:

    I have no clue what's happening cause the other two accounts manage the share with no problems. They can reply mails. It is just me that doesn't have permissions on this Inbox. I've been given Admin privilege on it, so it should be plenty.

    Surprisingly I have another share accepted and safe in my inbox, I can reply to those mails 'on behalf of' with no issues at all! Bowled.

    I've confirmed the option 'Allow sending email from any address' is enabled for my account under sending mails section in zimbraAdmin. Why I can reply mails in some shared Inbox and not others .. So i guess there's a missing bit somewhere. Someone make me happy pls.

  2. #2
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    are you only "viewer" permission on the one you are getting the error in? if so maybe the error is because trying to send on behalf tries to save a copy in the other person's sent folder, but since you're viewer you don't have permissions?

  3. #3
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default

    Good to see that face there. Thanks Bdial for picking up the call. I have full permission on that Inbox, rwidxa. The role is Admin. So that shouldn't happen right.

  4. #4
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default

    Still no leads .. any thoughts?

  5. #5
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Do you and/or this shared account have any personas active? If so, try disabling them, reshare the folder, logout/login and try again.

    By the way: have you checked out the parent/child mailbox functionality? It may be better than sharing a folder in your case and actually works quite well since ZCS 6.0.6.

  6. #6
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default

    By the way: have you checked out the parent/child mailbox functionality?
    That works like charm. It's pretty sharp and should give all that I need from the child. This thread explains it, and other ways too. Thanks a bunch hivos .. classic.
    Do you and/or this shared account have any personas active? If so, try disabling them, reshare the folder, logout/login and try again.
    No personas with either of us. Its still broken and I wonder whats wrong. The upgrade to 6.0.9 from .7 didn't fix it either. So marking this thread 'solved' with a note.

  7. #7
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Glad it's been helpful We wrote a couple of scripts to administrate family mailboxes, may come in handy: Administrate primary / secondary mail accounts

  8. #8
    fyd
    fyd is offline Elite Member
    Join Date
    Oct 2010
    Posts
    373
    Rep Power
    4

    Default

    Hey hivos, looks good .. thanks again, tc ..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] rsync permision denied
    By get2guy in forum Administrators
    Replies: 4
    Last Post: 10-22-2010, 12:32 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. Backup issues
    By telescop in forum Administrators
    Replies: 3
    Last Post: 03-01-2007, 06:09 PM
  4. Ldap issues
    By mississippiman in forum Installation
    Replies: 11
    Last Post: 01-09-2007, 08:00 PM
  5. Move server to different OS
    By EriSan500 in forum Administrators
    Replies: 7
    Last Post: 03-05-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •