Results 1 to 4 of 4

Thread: Spam training has no cron job

  1. #1
    richard-hdd is offline Active Member
    Join Date
    Aug 2006
    Location
    Victoria, BC, Canada
    Posts
    28
    Rep Power
    8

    Default Spam training has no cron job

    Hi,

    I have problem with the spam/ham training and I am not exactly sure what to do.

    I see in the list of accounts that there are two Spam Training Accounts but I don't know which one is for training spam and which one is for training ham.

    After doing some searching on these forums, I saw that people talked about a cron job that runs to actually do the training and so I thought the cron script my give me a clue as to which account does what. Unfortunately I don't see any cron jobs relating to Zimbra in crontab, cron.d, cron.daily, cron.hourly or cron.monthly. Is the zmtrainsa script run in a different process?

    In the forums there was also mention of a trainspam.log but I cannot find that file anywhere on the server.

    Is my spam training broken? If so, what can I do to correct it? Thank you.

    Richard Morris
    richard@hddbroker.com

  2. #2
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    8

    Default

    are you looking in the zimbra user's crontab?
    su - zimbra
    crontab -l shows
    #
    # Spam training
    #
    0 23 * * * /opt/zimbra/bin/zmtrainsa >> /opt/zimbra/log/spamtrain.log 2>&1

    for me.

  3. #3
    richard-hdd is offline Active Member
    Join Date
    Aug 2006
    Location
    Victoria, BC, Canada
    Posts
    28
    Rep Power
    8

    Default

    Thank you for your help. My install was the same as yours and the log file does show activity so it looks like it is working fine.

    I did manage to find out which account does the spam training and which does the ham training. You can use the following commands to look up the e-mail address used for each training account:

    zmprov gcf zimbraSpamIsNotSpamAccount
    zmprov gcf zimbraSpamIsSpamAccount

    Thanks for the help.

    Richard Morris
    richard@hddbroker.com

  4. #4
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    8

    Default

    No problem, glad it helped.

    Kyle

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trying to understand Zimbra's anti-spam system
    By TaskMaster in forum Users
    Replies: 11
    Last Post: 01-25-2008, 09:59 AM
  2. Deleted spam training accounts by fault
    By karmek in forum Administrators
    Replies: 6
    Last Post: 07-13-2007, 05:05 AM
  3. How to check if spam training is working?
    By tbovingdon in forum Administrators
    Replies: 1
    Last Post: 03-13-2007, 05:57 AM
  4. Spam Training clarification
    By moniker in forum Administrators
    Replies: 2
    Last Post: 11-29-2006, 05:21 PM
  5. Training spam and ham
    By Justin in forum Developers
    Replies: 2
    Last Post: 10-31-2006, 03:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •