Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Can't print from Web UI

  1. #1
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    9

    Default Can't print from Web UI

    Running Zimbra 3.1.0 I get the following error in firefox when trying to print from the webUI :
    Proxy Error
    You don't have permission to access /zimbra/public/frameOpenerHelper.jsp on this server.
    I get this error in IE:
    You are not authorized to view this page
    You might not have permission to view this directory or page using the credentials you supplied.

    HTTP Error 403 - Forbidden
    Internet Explorer
    I can occasionally get it to work, but I'm not sure what makes the difference as it seems to randomly work (and I don't do anything to it between it working and not working). My catalina.out doesn't have anything in it and doesn't like it has been written to since tomcat was restarted at 4am.

    Thanks for any ideas.
    kyle

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Shouldn't really be any problem printing. Have you looked at the permissions of those directory/file?

    That version of Zimbra you're running is way old, you could try updating to the most recent release - it's lots better.
    Last edited by phoenix; 09-13-2006 at 07:37 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    9

    Default

    It's not me not wanting to upgrade, it's the boss. He doesn't want to upgrade for the sake of upgrading. So i'm looking for something to say HERE is something that makes it worth upgrading in and of itself! Any help in that dep't would be greatly appreciated.

    Just odd that I got printing to work from the Web UI once (with my personal account) but not an hour later, with no changes to the server, it wouldn't.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    OK, there are many bug fixes in the most recent release, it supports shared documents, it solves a memory problem etc. etc.......

    Did you look to see if the permissions on that directory/file were correct?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    9

    Default

    Yes, the server is backed up and permissions verified every morning at 4am. It kind of acts like the session data isn't being passed to it.

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    OK, lets try the obvious. I know I've asked this before but can you search for the file 'frameOpenerHelper.jsp' and see what the permissions/owner are (you should have two copies of that file).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    9

    Default

    -rw-r--r-- 1 zimbra zimbra 2419 Feb 16 2006 /opt/zimbra/jakarta-tomcat-5.5.7/webapps/zimbra/public/frameOpenerHelper.jsp

    -rw-r--r-- 1 zimbra zimbra 2419 Feb 16 2006 /opt/zimbra/jakarta-tomcat-5.5.7/webapps/zimbraAdmin/public/frameOpenerHelper.jsp

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Unfortunately I had a feeling that was going to be the answer. OK, last few questions. This problem you're getting is on a Windows/IE machine, correct? Have you tried this on the zimbra server with FF? Do you have any software on the Windows machine that may be causing this type of problem? Anything like a/v, firewal anti-spyware etc.?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    kechols is offline Senior Member
    Join Date
    Jun 2006
    Posts
    72
    Rep Power
    9

    Default

    It happens in firefox and ie, and is hit or miss. It was working one time yesterday, told the user to try again, and about 2hrs later it just quit working. I tried it then and it didn't work for me at that time. Since it worked on my machine earlier, I don't think it's related to specific software. But there's not anything installed, that should cause that specific problem.

    I have a linux box I'm testing zimbra 4.0.1 on but haven't checked on this particular problem.

  10. #10
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Unfortunately I'm just about out of ideas - I've searched everywhere I can think of without success.

    Two choices left, from my point of view, file a bug (that version is now not supported, except in the forums) or upgrade to the latest release. Try and bend your bosses arm, the current releas is so much better.

    Let me know how you get on with your test install of 4.0.1
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Get mailbox size (for create quota warning SMTP script)
    By inigoml in forum Administrators
    Replies: 28
    Last Post: 08-21-2007, 06:35 AM
  2. Issue with Print Size in Zimbra Web Client
    By soxfan in forum Administrators
    Replies: 0
    Last Post: 05-11-2007, 12:59 PM
  3. Using Ajax Web client on Windows 2000!
    By celeron in forum Administrators
    Replies: 1
    Last Post: 03-09-2007, 11:09 PM
  4. postfix crash. Where is the log?
    By partypooper in forum Administrators
    Replies: 3
    Last Post: 11-30-2006, 04:37 PM
  5. Web server and ZIMBRA
    By hector in forum Installation
    Replies: 1
    Last Post: 10-04-2006, 01:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •