Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: [SOLVED] Zimbra Cluster with drbd won't start

  1. #11
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    You've already been given the answer in this thread and you do not have a correct hosts file, it doesn't match the example in the links (and how-to articles) I gave you and it doesn't match the example given to you by vavai - you're missing the FQDN for one of the nodes.

    Compare your hosts file to the example in the post by vavai.
    So my problem is that I've missing a hostname for the virtual IP?
    Code:
    XXX.XXX.XXX.XX4 zimbrahost.mydomain.net zimbrahost
    Do I have to change this and reinstall Zimbra on both nodes, or It's just fine to modify the DNS, MX records and add this to the Hosts files, then zimbra should work?

    Thanks,
    Tibby

  2. #12
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,486
    Rep Power
    56

    Default

    What about the entry for 'XXX.XXX.XXX.XX2 Node02' in the hosts file?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    What about the entry for 'XXX.XXX.XXX.XX2 Node02' in the hosts file?
    I Think I'm getting what you saying by now...
    My hosts file configured wrong!? (As you've said)

    In the example post you and vavai saying:
    ------------------------------------------------------------
    5. Zimbra-01:
    Code:
    # nano /etc/hosts
    127.0.0.1       our-domain.com localhost.localdomain localhost
    192.168.100.101   zimbra-01 our-domain.com
    192.168.100.102   zimbra-02
    6. Zimbra-02:
    Code:
    # nano /etc/hosts
    127.0.0.1        our-domain.com localhost.localdomain  localhost
    192.168.100.102  zimbra-02 our-domain.com
    192.168.100.101   zimbra-01
    ------------------------------------------------------------

    In my hosts files I have:

    Node01:
    Code:
    127.0.0.1       mydomain.net localhost.localdomain localhost
    XXX.XXX.XXX.XX3 mydomain.net Node01
    XXX.XXX.XXX.XX2 Node02
    Node02:
    Code:
    127.0.0.1       mydomain.net localhost.localdomain localhost
    XXX.XXX.XXX.XX2 mydomain.net Node02
    XXX.XXX.XXX.XX3 Node01
    So I did it reversed?
    I should have to change it to:

    Node01:
    Code:
    127.0.0.1       mydomain.net localhost.localdomain localhost
    XXX.XXX.XXX.XX3 Node01 mydomain.net
    XXX.XXX.XXX.XX2 Node02
    Node02:
    Code:
    127.0.0.1       mydomain.net localhost.localdomain localhost
    XXX.XXX.XXX.XX2 Node02 mydomain.net
    XXX.XXX.XXX.XX3 Node01
    Is this right??
    Do I need to mention the virtual IP of Hearbeat as well?
    XXX.XXX.XXX.XX4 mydomain.net ?
    Should I set up a host for this IP as well or can I just leave it as is with the domain name? or I need to change it to something like:
    XXX.XXX.XXX.XX4 mail.mydomain.net ?

  4. #14
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    What about the entry for 'XXX.XXX.XXX.XX2 Node02' in the hosts file?
    Sorry... I can't Figure it out.
    Can you please tell me What am I doing wrong.
    How should the hosts file look like

    Please. I'm pulling my hair!

  5. #15
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Code:
      ERROR: Installation can not proceeed.  Please fix your /etc/hosts file
      to contain:
    
      127.0.0.1 localhost.localdomain localhost
    
      Zimbra install grants mysql permissions only to localhost and
      localhost.localdomain users.  But Fedora/RH installs leave lines such
      as these in /etc/hosts:
    
      127.0.0.1     myhost.mydomain.com myhost localhost.localdomain localhost
    
      This causes MySQL to reject users coming from 127.0.0.1 as users from
      myhost.mydomain.com.  You can read more details at:
    
      http://bugs.mysql.com/bug.php?id=11822
    Nice...
    So 127.0.0.1 should not contain mydomain.net
    Here is the point where the install guide fails

  6. #16
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    THANK YOU! for the help!

    I've DRBD+Heartbeat already installed. I'll have to configure a bit more. Keep you updated. Thanks again!
    The hosts file part should be clear now.
    Last edited by tibby; 10-14-2010 at 01:45 PM.
    Tibby

  7. #17
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Quote Originally Posted by vavai View Post
    Below are my /etc/hosts on SLES 11 SP1 64 bit, with Zimbra 6.0.8 and DRBD+Heartbeat :

    Code:
    # IP-Address  Full-Qualified-Hostname  Short-Hostname
    #
    
    127.0.0.1       localhost
    192.168.10.1   mail.mydomain.co.id mail
    192.168.10.2   zcspdc1.mydomain.co.id zcspdc1
    192.168.10.3   zcspdc2.mydomain.co.id zcspdc2
    Note :
    - Before applying DRBD+HA, Zimbra installed with the following configuration on each install :

    Code:
    127.0.0.1       localhost
    192.168.10.1   mail.mydomain.co.id mail
    192.168.10.1 is virtual IP (IP that managed by Hearbeat)

    - zcspdc1 is my 1st Zimbra server. It's primary node, an active server and has 2 IP on running (192.168.10.1 and 192.168.10.2)

    - zcspdc2 is my 2nd Zimbra server. It's secondary node and act as passive server. It has only 1 IP on passive running but will have 2 IP if promote as primary node/active server by HA

    - I have similar /etc/hosts on both node.

    - On production, I'll be accessing Zimbra with the following URL : mail.mydomain.co.id and IP 192.168.10.1 (or public IP designed with NAT). I could also accessing Zimbra by using the active node hostname and IP but it's not for public use, only for admin purpose because active node managed dan may interchangeable by Heartbeat.

    Back to your problem, the above /etc/hosts example should make a clear explanation why your Zimbra installation complaints about wrong /etc/hosts.
    Bad news...
    Still doesn't work!
    First host starts fine, second host starts localhost.

    Here is What I've done:
    -Stopped DRBD on both nodes
    -Stopped Heartbeat on both nodes
    -Changed IP on Node01 to be XXX.XXX.XXX.XX4
    -Changed hostname on Node01 to be mail
    -Added to the hosts file:
    127.0.0.1 localhost and
    XXX.XXX.XXX.XX4 mail.mydomain mail
    This two lines only in he hosts file.

    -Reboot
    -Installed zimbra fine to /opt/zimbra (DRBD was off)
    -Moved everything from /opt/zimbra to /root/zimbra
    -Added two more line to hosts file:
    XXX.XXX.XXX.XX3 node02.mydomain node01 and
    XXX.XXX.XXX.XX2 node01.mydomain node01
    -Changed the IP of back to XXX.XXX.XXX.XX2
    -Changed hostname from mail to Node01
    -Reboot
    -checked hostname --fqdn returned: node01.mydomain.net

    Did the same on node02

    -Restarted drbd
    -Copyed /root/zimbra/ back to /opt/zimbra/ on Primary drbd host Node01.
    -Started Zimbra fine for mail.myhost.net
    -Rebooted Node01
    -Node02 mounted DRBD as Primary
    -Started Zimbra on Node02 from /etc/init.d/zimbra start
    I'm getting:
    Code:
    /etc/init.d/zimbra start
    Host localhost
    Unable to determine enabled services from ldap.
    Still the same problem.
    Works on one node, doesn't on the other.

    Please Help me! I'm pulling my hair out.
    Tibby

  8. #18
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Quote Originally Posted by vavai View Post
    Back to your problem, it's came from your hostname incorrect setting, but I would like to see your detail steps on 2nd node to see what's wrong with your step.
    Take care, it's a simple steps anyway
    My Second node was installed like this:
    1.) Stopped DRBD, Stopped Heartbeat
    2.) I moved the drbd.conf and haresources file to anoteher location
    3.) Chanegd Hostname to mail
    4.) Changed hosts file to caontain:
    Code:
    127.0.0.1 localhost
    XXX.XXX.XXX.XX4 mail.mydomain.net mail
    5.) reboot
    6.) Installed zimbra. Config went straight, no errors, no problem with dns
    7.) Zimbra starts after installation complete.
    8.) Stopped Zimbra /etc/init.d/zimbra stop
    9.) Moved /opt/zimbra to /root/zimbra
    10.) Changed hostname to node02
    11.) Changed hosts file to contain:
    Code:
    127.0.0.1 localhost
    XXX.XXX.XXX.XX4 mail.mydomain.net mail
    XXX.XXX.XXX.XX3 node02.mydomain.net node02
    XXX.XXX.XXX.XX2 node01.mydomain.net node01
    12.) Copied drbd.conf and haresources to their location
    13.) Removed zimbra startup scripts:
    Code:
    update-rc.d -f zimbra remove
    14.) Reboot
    15.) Changed DRBD status for Primary on Node02
    16.) /etc/init.d/zimbra start
    -> Starts as localhost

    I think everything is done as you've described, it should work, but it doesn't.
    Tibby

  9. #19
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    Interesting!
    Something is wrong with the installation. Zimbra installs something outside of the /opt/zimbra folder that is specific to the installation on that host.

    Here is what's interesting:
    DRBD device is mounted to /opt/

    if I copy the install on Node01 to /opt/zimbra, it starts on Node01, Node02 wants to go localhost.

    If I copy the install on Node02 to /opt/zimbra, it starts on Node02, Node01 wants to go localhost.

    Is there something specific in the install besides the /etc/hosts file ?
    Something that notifies zimbra that is installed on Node01 or Node02 ??

    Thanks.
    Tibby

  10. #20
    tibby is offline Senior Member
    Join Date
    May 2010
    Location
    Budapest
    Posts
    56
    Rep Power
    5

    Default

    I HAVE FOUND IT!!!!

    I had to remove completly the postfix and zimbra users on both servers. install.sh -u didn't do this.
    Once they ware removed, reinstalled and the problem is gone.
    They ware not identical on both servers.
    Since that everything works fine on both machines.

    Thanks for the help for everyone!
    The problem was not with the hosts file.
    Zimba is working for me with the followings:
    XXX.XXX.XXX.XXX4 mydomain.net
    I don't have hostname definied for the virtual IP, just the domain.
    Tibby

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  4. [SOLVED] Error Installing Zimbra on RHEL 5
    By harris7139 in forum Installation
    Replies: 10
    Last Post: 09-25-2007, 11:39 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •