Results 1 to 3 of 3

Thread: [SOLVED] Full migration of a Zimbra 5.0.x Ldap to a standalone Ldap

  1. #1
    marcs is offline Starter Member
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    4

    Default [SOLVED] Full migration of a Zimbra 5.0.x Ldap to a standalone Ldap

    Hello,

    I try to migrate the internal Ldap of an Zimbra 5.0.x, and i don't see where i need to go for having fully fonctionnal external Ldap.

    1) I dump the Ldap from Zimbra and export schema on the new Ldap, and i configure Zimbra to delegate the GAL and the Ldap on the external ldap. At this point authentification work.

    2) After that, i stop the internal ldap (su - zimbra; ldap stop) and i can always log in on ZimbraAdmin, so the standalone ldap configuration is working for auth.

    3) When i'm loged, i receive a :

    - SOAP error on GUI :
    Code:
    Mail : system failure: ZimbraLdapContext Code d'erreur : service.FAILURE Method: SearchDirectoryRequest Détails :soap:Receiver
    - in the audit.log file :
    Code:
    WARN  [btpool0-15] [ip=192.168.1.77;ua=ZimbraWebClient - FF3.0 (Linux);] security - cmd=AdminAuth; account=MYUSER; error=system failure: ZimbraLdapContext;
    According to this wiki article i need to change the SOAP variables for having the good LdapContext environnement.



    My first question is :
    where can i find the file who hang these SOAP parameters ?
    The second one :
    If i modify these values, will i be able to achieve my goal of using only a standalone Ldap on an existing Zimbra ?
    The last one :
    If i'm running on bad direction, does i begin to search in the localconfig.xml to override the proxy:ldap:/opt/zimbra/conf/ldap-scm.cf for achieving this ?

    Thanks in advance.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by marcs View Post
    Hello,

    I try to migrate the internal Ldap of an Zimbra 5.0.x, and i don't see where i need to go for having fully fonctionnal external Ldap.

    1) I dump the Ldap from Zimbra and export schema on the new Ldap, and i configure Zimbra to delegate the GAL and the Ldap on the external ldap. At this point authentification work.

    2) After that, i stop the internal ldap (su - zimbra; ldap stop) and i can always log in on ZimbraAdmin, so the standalone ldap configuration is working for auth.

    3) When i'm loged, i receive a :

    - SOAP error on GUI :
    Code:
    Mail : system failure: ZimbraLdapContext Code d'erreur : service.FAILURE Method: SearchDirectoryRequest Détails :soap:Receiver
    - in the audit.log file :
    Code:
    WARN  [btpool0-15] [ip=192.168.1.77;ua=ZimbraWebClient - FF3.0 (Linux);] security - cmd=AdminAuth; account=MYUSER; error=system failure: ZimbraLdapContext;
    According to this wiki article i need to change the SOAP variables for having the good LdapContext environnement.



    My first question is :
    where can i find the file who hang these SOAP parameters ?
    The second one :
    If i modify these values, will i be able to achieve my goal of using only a standalone Ldap on an existing Zimbra ?
    The last one :
    If i'm running on bad direction, does i begin to search in the localconfig.xml to override the proxy:ldap:/opt/zimbra/conf/ldap-scm.cf for achieving this ?

    Thanks in advance.
    The simple answer to this problem (and covered many times in the forums) is that you can't do this. You need to have the Zimbra LDAP installed and running, it's an integrated part of the Configuration Suite and it's used for more than a user authentication store.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    marcs is offline Starter Member
    Join Date
    Sep 2010
    Posts
    2
    Rep Power
    4

    Default

    Thanks for answering Bill, i saw so many post on this topic without having a clear answer, and the concept of Bulk provisioning seems more clear for me now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 11:13 AM
  2. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •