Results 1 to 4 of 4

Thread: Zimbra MySql Error

  1. #1
    rohitsisaudia is offline Junior Member
    Join Date
    Sep 2010
    Posts
    6
    Rep Power
    4

    Default Zimbra MySql Error

    Hi,

    I am trying to create a local HA Zimbra cluster. I have installed zimbra on two servers. I have moved the Index folder, Store folder and /db/data folder to a different partition that is being replicated to the secondary server.

    Zimbra runs fine on one of the sevrers but when the failover happens to the other server, zimbra is unable to connect to the SQL DB.

    I have the following error when I try to connect :

    /opt/zimbra/mysql/bin/mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'

    On the first server as well, I am able to connect using the root account.


    Please help!!!

  2. #2
    rohitsisaudia is offline Junior Member
    Join Date
    Sep 2010
    Posts
    6
    Rep Power
    4

    Unhappy

    Dear all Hi,

    I have somehow een able to resolve the above stated problems by changing the passwords of SQL on both the servers by making changes in the /conf/localconfig.xml file.

    Now when I replicate MYSQL data to the standby server then I can login to my sql but when I access the admin mail account, the mailbox is empty. However on the primary server it still shows the same mail.

    It seems that new mboxgroups have been created for the admin accounts on both the servers. How to merge the mboxgroups so that the mails are accessible from standby server if the pruimary server goes down.

    Thanks in advance
    Rohit

  3. #3
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    If it is in Active/Passive mode then why would you need to merge anything if both MySQL and the physical data stores are being replicated ?

    Please be aware that this is a completely unsupported configuration, and yes I see you are on FOSS, but if anything goes wrong make sure you have good backups

  4. #4
    rohitsisaudia is offline Junior Member
    Join Date
    Sep 2010
    Posts
    6
    Rep Power
    4

    Default

    Dear Uboxd,

    Im not trying to merge. Im actually trying to access the same database from two servers.But it is not happening. im unable to access the database of the other server.

    I have also matched the passwords and they are exactly the same.

    Let me give u an example:

    In my admin account I have certain mails. The same database is replicated to the standby server. now, If I access the account from the standby server. I dont see any mails, however I am able to log in to the account.


    Thanks for HELP!!!!

    regards
    Rohit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 09-26-2011, 11:50 PM
  2. postfix relay=none status=bounced for local mails
    By vdd in forum Administrators
    Replies: 1
    Last Post: 08-06-2009, 08:05 AM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  4. Replies: 22
    Last Post: 12-02-2007, 05:05 PM
  5. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •