Results 1 to 4 of 4

Thread: LDAP/slapd logging does not work

  1. #1
    jsilence is offline Intermediate Member
    Join Date
    Jan 2008
    Posts
    16
    Rep Power
    7

    Default LDAP/slapd logging does not work

    We are running ZCS 6.0.5 OSS on Ubuntu 8.04LTS.

    In trying to have more detailed LDAP logging for debugging purposes we set ldap_common_loglevel to 256 via:
    zmlocalconfig -e ldap_common_loglevel=256

    We also set ldap_log_level to 256 even though this setting seems to be for ZCS 5.

    Just to make sure the setting is read we restarted Zimbra.

    Still, nothing in the logs.

    Any hint?

    -jsl

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Details in the wiki article for version 6.x (and the slapd manpage): OpenLDAP Tuning Keys - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    wiz561 is offline Junior Member
    Join Date
    Jul 2008
    Posts
    7
    Rep Power
    6

    Default

    Thanks for the response. I attempted to set this but it still doesn't populate /var/log/zimbra.log. Here's a snip of my zmlocalconfig...


    zimbra@csl-mail:~$ zmlocalconfig | grep -i log
    ldap_accesslog_cachefree = 1
    ldap_accesslog_cachesize = 10000
    ldap_accesslog_checkpoint = 64 5
    ldap_accesslog_dncachesize = 0
    ldap_accesslog_idlcachesize = 10000
    ldap_accesslog_shmkey = 0
    ldap_common_loglevel = 256
    ldap_log_level = 256
    ldap_overlay_accesslog_logpurge = 01+00:00 00+04:00
    ldap_overlay_syncprov_sessionlog = 500

    I've also tried to restart ldap and even /etc/init.d/zimbra restart, but nothing seems to work. I also changed the permissions on /var/log/zimbra.log to a+w, but that didn't help things either. Any other tricks where I can see the ldap operations and connections?

    Thanks!

  4. #4
    wiz561 is offline Junior Member
    Join Date
    Jul 2008
    Posts
    7
    Rep Power
    6

    Default

    D'oh... it's being dumped in /var/log/debug instead /var/log/zimbra.log.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Since v6 zimbra pst import wizard donīt work very well
    By kolomalo in forum Administrators
    Replies: 2
    Last Post: 01-25-2011, 09:30 AM
  2. Zdesktop beta 4 dont work in Windows
    By javierrios@cantv.net in forum General Questions
    Replies: 5
    Last Post: 09-13-2010, 11:03 AM
  3. Tired of trying over and over again to make it work..
    By itmltd in forum Installation Help
    Replies: 3
    Last Post: 05-04-2010, 12:59 PM
  4. 6.0.2 Notebook Links do not work
    By KiegKhan in forum Administrators
    Replies: 1
    Last Post: 12-25-2009, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •