Results 1 to 9 of 9

Thread: [SOLVED] iphone imap ssl connection - outgoing server not responding

  1. #1
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default [SOLVED] iphone imap ssl connection - outgoing server not responding

    Please help! I'm going crazy here. I've got zimbra 6.0.6 (community edition), running and I'm trying to sync up a new iphone4 using imap.

    The incoming mail is syncing fine but I can't seem to configure the outgoing mail server.

    I'm using ssl and have tried using ports 465, 443, 993, 7993, 7143 on the iphone. I've checked that these ports are all open on the firewall and using nmap on the local network.

    I've tried changing the authentication (from password to md5 challenge response or NTLM).

    I've also tried using a local email clients (Evolution on a linux box and Thunderbird on a Windows machine). It looks like there's a problem with the IMAP settings on the server. Outgoing mail isn't working, the connection times out.

    IMAP is enabled on the zimbra web admin interface (as is SSL for IMAP service). I have a working SSL certificate.

    Could really use some help as it's the directors iphone I'm trying configure and I've been bragging about getting all the zimbra stuff onto the iphone.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by aidanewen View Post
    Could really use some help as it's the directors iphone I'm trying configure and I've been bragging about getting all the zimbra stuff onto the iphone.
    Use port 587 as the (correct) Submission port, you'll need to authenticate to send mail via your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    Thanks Bill,

    I've tried using 587 as the Server Port on the iphone. It's still telling me that the server isn't responding. I've checked that 587 is forwarding from the router to the server and I've run nmap on the server to confirm that it's listening on 587.

    I can't see any mention of port 587 in the IMAP settings on the zimbra admin web GUI. The "IMAP SSL port number" is set to 7993. The incoming server settings seem to be working fine using port 993 which is listed in the zimbra admin web GUI as being the IMAP SSL proxy port number. (I didn't know I was using any proxy's - could this be causing my problems)

  4. #4
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    I've also tried using port 587 on the thunderbird mail client. Again it's not working. I think there must be a problem with my settings on the server.

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,585
    Rep Power
    57

    Default

    Quote Originally Posted by aidanewen View Post
    I've tried using 587 as the Server Port on the iphone. It's still telling me that the server isn't responding. I've checked that 587 is forwarding from the router to the server and I've run nmap on the server to confirm that it's listening on 587.

    I can't see any mention of port 587 in the IMAP settings on the zimbra admin web GUI. The "IMAP SSL port number" is set to 7993.
    You mentioned earlier that this is for 'Outbound mail not responding', Port 587 is the Submission port it's not your IMAP connection (that's the Incoming server) - the two settings are in different places (or should be but I don't have an iphone to confirm this).

    Quote Originally Posted by aidanewen View Post
    The incoming server settings seem to be working fine using port 993 which is listed in the zimbra admin web GUI as being the IMAP SSL proxy port number. (I didn't know I was using any proxy's - could this be causing my problems)
    Do you have the proxy enabled on this server and is it a Single Server installation?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    It's a single server installation. I don't know if I do have the proxy enabled. I'll try and find out.

    It doesn't seem to be possible to alter the submission port on the iphone, unless this is the only port associated with the outgoing mail server, in which case this is the port I've set to 587 - I have 993 for incoming mail and 587 for outgoing mail.

  7. #7
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    It looks like I do have the proxy enabled (I can certainly see references to zmprov in the process list):

    Code:
    user@mailserver:/home/user# ps -ef | grep 'zmprov'
    zimbra   26855 27822  0 09:00 ?        00:00:00 sh -c /opt/zimbra/bin/zmprov -l gacf | grep -v InheritedAttr
    zimbra   27053 26954  0 09:00 ?        00:00:00 sh -c /opt/zimbra/bin/zmprov -l gs mailserver.host.com 2>/dev/null
    root     27139 26808  0 09:00 pts/0    00:00:00 grep zmprov

  8. #8
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    Thanks Bill - I think you've cleared things up for me. I've been looking at the IMAP settings on the zimbra web gui. I should have been looking at the MTA settings. I managed to get outlook working (using port 25 and no encryption) on the local network and have just noticed that there's a trusted networks option on the MTA settings. I've got the loopback address and the private network entered in there, which explains why I can't send mail from the iphone on a public network.

    I guess I need to set up some sort of security then include the internet in my trusted networks. Think I'm nearly there.....

  9. #9
    aidanewen is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    The iphone I've been setting up is now working. The only thing I changed was to untick TSL authentication only (the iphone seems to use ssl). I haven't changed the trusted networks - which is a relief - it's got to be a mistake describing the internet as a 'trusted network'. I've checked the iphone both on and off the office network. And as I say, It's all working now.

    Thanks again for your help Bill - It was the MTA settings I needed to look at not IMAP.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmmailboxdctl is not running !!!!!!
    By olibite in forum Administrators
    Replies: 14
    Last Post: 04-28-2011, 05:50 AM
  2. Server stops responding every Monday morning
    By cpalsgrove in forum Administrators
    Replies: 1
    Last Post: 08-24-2009, 08:37 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. [SOLVED] Commercial SSL Certificate - Web Host's Server Software
    By jremshik@pgprint.com in forum Administrators
    Replies: 2
    Last Post: 09-18-2008, 12:45 PM
  5. Replies: 15
    Last Post: 02-28-2008, 05:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •