Results 1 to 4 of 4

Thread: Force LDAP Upgrade?

  1. #1
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default Force LDAP Upgrade?

    Hi-
    I"m working with someone with a couple problems, and I think they stem from a failed LDAP upgrade, but you decide.

    LDAP isn't binding to loopback address, but is binding to the fqdn and ip address. (Checked DNS and hosts file. Both are fine)
    >How? telnet localhost 389 failed; however, telnet x.x.x.x succeeds

    zmprov Failes because it can't contact localhost
    >zmprov returns i/o exception, conneciton failed.

    zmsetup.pl, this error is in the zmsetup log:
    ERROR: service.INVALID_REQUEST (invalid request: LDAP schema violation: [LDAP: error code 65 - attribute 'zimbraCertAuthorityKeySelfSigned' not allowed]) (cause: javax.naming.directory.SchemaViolationException [LDAP: error code 65 - attribute 'zimbraCertAuthorityKeySelfSigned' not allowed])
    (many others too)

    I'm thinking that the cn for zimbraCertAuthority,etc isn't installed becase perhaps LDAP didn't get upgraded??
    I tried running zmetup.pl, zmldapdif, and ldapinit with null results

    My question: Do you agree, or not? If you do, how do I force an ldap upgrade?

    john

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    Sounds like the schema file is missing. We bind to the name in ldap_url, so the ldap server should be accessible on that interface
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    The ldap url seems okay ldap://<fqdn>:389

    How would I fix a schema file problem?

  4. #4
    rvissers's Avatar
    rvissers is offline Active Member
    Join Date
    Aug 2006
    Location
    Michigan
    Posts
    44
    Rep Power
    8

    Default

    This thread ended up being from my failed upgrade. I just wanted to say that both Wanabetenor & Phoenix went way above and beyond the call of duty to help me out with the problem (and taught me quite a few things about Zimbra during the whole process) and they deserve much public kudos for helping out a junior admin like myself.

    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 09:23 PM
  2. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  3. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •