Results 1 to 7 of 7

Thread: [SOLVED] How to send all e-mails to an external smtp-server?

  1. #1
    t.i.m is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    20
    Rep Power
    4

    Question [SOLVED] How to send all e-mails to an external smtp-server?

    Hi all!

    Is it possible to send all the e-mails written in zimbra to an external smtp-account as the default? An if yes, what I ve to do?

    background infos: I run my zimbra server on a locale maschine with a dynamic ip. If I send an email to one of the big emailprovider, the mail was rejected, cause it was send from a mail-server with a dynamic ip. If I can send the mail to my external mail-server (with a static ip), so the mail will be accepted.

    The external mail-server is NOT a zimbra server!

    Any hints to solve?

    kind regards
    Tim

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    I guess what you mean is use an external relay? If you do you can add one in the Admin UI and if it needs Authentication the search the wiki (or the forums) for the words 'smtp authentication'.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    t.i.m is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    20
    Rep Power
    4

    Default

    yes, youre right! Thanks for the keywords to search! I found an interresting wiki site about outgoing smtp authentication. I tried the commands i found there. But until now I wasnt successfull.

    The main problem the last two hours is, that I cant find any loglines about the SMTP connection and some possible failures. The logfile in /var/log/zimbra.log is empty! And in /opt/zimbra/log/*.log I didnt found any about a smtp failure, too!

    Only on my relay server I discovered a line that says like: rejected from IP <my.dynamic.isp.ip>

    Now I increase the log level in /opt/zimbra/conf/log4j.properties.in with the line

    log4j.logger.zimbra.soap=DEBUG

    but, until now I ve no output concerning the smtp connection.

    Any idea/hint, what I can do?

    kind regards
    Tim

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Without any error information from the log files it's difficult to say. Does your relay server actually require Authentication?

    Quote Originally Posted by t.i.m View Post
    Only on my relay server I discovered a line that says like: rejected from IP <my.dynamic.isp.ip>
    What was the reason for the rejection i.e. the exact error message?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    t.i.m is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    20
    Rep Power
    4

    Default

    Right, no entries in the logfile is a bit strangely and not really helpfull! What could I do to activate the /var/log/zimbra.log? If I understand it right, this is the place where the MTA will write its output.

    The errormessage from my relayserver in the internet is very simple:
    Code:
     /var/qmail/bin/relaylock[22513]: /var/qmail/bin/relaylock: mail from 12.34.56.78:34003 
    (j21603.my.isp.com)
    Oh, and I ve an other information from the mailer-deamon on my zimbra-server, who send an email to my zimbra account:

    Code:
    <name@big-isp.com>: host my.relay-server.com[11.22.33.44] said: 553 sorry,  that domain 
    isn't in my list of allowed rcpthosts; no valid cert for gatewaying (#5.7.1) (in
     reply to RCPT TO command)
    maybe this is a little hint ...

    Kind regards
    Tim

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Looks like your ISP is not allowing you to relay.

  7. #7
    t.i.m is offline Intermediate Member
    Join Date
    Jun 2010
    Posts
    20
    Rep Power
    4

    Default

    Hi all! I ve solved my problem! Here is my solution:

    To activate the output in /var/log/zimbra.log
    Code:
    postconf -e debug_peer_list=mail.host.com
    postconf -e debug_peer_level=3
    postfix reload
    and then I restart the whole server. I guess normaly it should not be neccessary, but in my case it was.

    The best site was the wiki site to the Outgoing SMTP Authentication. I used the most options/commands.

    The message "553 sorry, that domain isn't in my list of allowed rcpthosts; no valid cert for gatewaying" seems to be like the call of a baby "wäääh" and its up to you to figure out what its missing

    In my case it was a lot:
    - misspelled the username for the smtp-auth
    - the SMTP Port should not be 25 but 587
    - then set smtp_sasl_auth_enable=yes
    - I ve to remove the noplaintextoption (smtp_sasl_security_options=noanonymous)

    And now I can send emails via my relayserver
    Tim

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Replies: 3
    Last Post: 05-25-2009, 09:05 AM
  3. use internal mail server to send email in external net
    By abisello in forum Administrators
    Replies: 5
    Last Post: 03-18-2008, 08:29 AM
  4. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  5. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •