Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: SMTP-AUTH configuration

  1. #1
    sridharsagi is offline Intermediate Member
    Join Date
    May 2010
    Posts
    23
    Rep Power
    5

    Default SMTP-AUTH configuration

    Hi All,

    I recently installed zimbra community edition.

    I want to use (SMTP-AUTH feature) instead allowed network.

    when i give the comand:

    zmprov getServer zimbra.domain.com | grep Auth

    it shows all the True, that means enable.

    How do i configure my mail server to authenticate using username and passwd instead allowed network before sending mail.

    Regards,
    Sridhar

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Please update your forum profile with the output of the following command (do not post the output in this thread):

    Code:
    zmcontrol -v
    Quote Originally Posted by sridharsagi View Post
    How do i configure my mail server to authenticate using username and passwd instead allowed network before sending mail.
    Use Port 587 as the Submission port for the email clients.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    sridharsagi is offline Intermediate Member
    Join Date
    May 2010
    Posts
    23
    Rep Power
    5

    Default

    Release 6.0.6_GA_2330.F7_20100505191736 F7 FOSS edition.

    Is the version of our zimbra

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by sridharsagi View Post
    Release 6.0.6_GA_2330.F7_20100505191736 F7 FOSS edition.

    Is the version of our zimbra
    As I mentioned above, that's no use in this thread and needs to go in your forum profile.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    sridharsagi is offline Intermediate Member
    Join Date
    May 2010
    Posts
    23
    Rep Power
    5

    Default

    Hi Bill

    I tired, i loged in to my account and tried,
    but i dont have a clue where in my profile i have to update this info

    can you help me in this regard

    Regards,
    Sridhar

  6. #6
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    User CP > Edit Profile > Additional Information > Zimbra/OS Version

    Now, what you're asking...basically I'm unsure whether Zimbra supports SMTP AUTH over port 25.

    It's not really worth investigating, though, because Zimbra does things in a much better and more modern fashion.

    Email clients should connect to Zimbra on port 587, which is the RFC-standard SUBMISSION port. When configuring this, you may also have to tell the client to use TLS or SSL...although by standard, 587 is assumed to be TLS.

    The client should still be configured to authenticate outbound SMTP connections with username/password.

    On my Zimbra, port 465 (with SSL and username/password) is also allowed, although this is nonstandard. It used to be the default in ZCS 5; not sure if it was grandfathered in on upgrade, or if it's still a default in ZCS 6.

    The reason that Submission (587) and SMTP over SSL (465) are preferred to port 25 is that many ISPs block outbound traffic over port 25 as an anti-spam measure (e.g., against spam servers residing on botnets). Since 587 and 465 require authentication, they're relatively immune to spamming.

  7. #7
    dhuber is offline Beginner Member
    Join Date
    Aug 2010
    Posts
    1
    Rep Power
    5

    Default

    Hi all,

    I have the same issue like Sridhar and I'm working already for the fix for hours...

    Here the current situation:
    - Authentication is enabled in the Administrationconsole
    - zmprov returns following output:

    $ zmprov getServer zimbra01.mit-konkret.de | grep Auth
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: zimbra01.mit-konkret.de
    zimbraMtaAuthTarget: TRUE
    zimbraMtaAuthURL: http://zimbra01.mit-konkret.de:80/service/soap/
    zimbraMtaSaslAuthEnable: TRUE
    zimbraMtaTlsAuthOnly: TRUE

    So far everything looks good! But if I connect with telnet to port 25 I got the same errormessage like connecting to port 587:

    $ telnet 10.164.65.17 587
    Trying 10.164.65.17...
    Connected to 10.164.65.17.
    Escape character is '^]'.
    ehlo localhost
    220 zimbra01.mit-konkret.de ESMTP Postfix
    250-zimbra01.mit-konkret.de
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    AUTH LOGIN
    503 5.5.1 Error: authentication not enabled


    Why is the MTA authentication enabled in the configuration and not applied to the server?

    How can I fix this issue?

    Thanks
    Dieter

  8. #8
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    zimbraMtaTlsAuthOnly: TRUE
    I doubt you can have this true and then authenticate via telnet.

    Perhaps if in the admin console you turn off "TLS authentication only". I would expect that turn that property to FALSE, and then you might be able to authenticate in plaintext via telnet connection to port 25.

  9. #9
    sridharsagi is offline Intermediate Member
    Join Date
    May 2010
    Posts
    23
    Rep Power
    5

    Default

    Hi

    I have disabled the "TLS only" in admin console located as below

    Domain > MTA Tab

    ####################
    Authentication
    Enable authentication
    TLS authentication only
    ####################

    Then by enabling the client to authenticate with username and passwd it worked.

    With correct credentials: Worked
    With wrong Credentilas: Rejected

    Then by reverting the client setting to not to authenticate with username and passwd.

    Its working.

    On a over all if you enable or Check the authentication required in mail client,
    its works only if you give correct credentials, it will not work if username and passwd is wrong (mena it will not send mail if username and passwd is woring)

    But more worring is if you dont enable the client to authentication, still its send the mail with out authentication.

    I Tired above senarion by allowing the whole network and only the mail server ip in allowed network.

    I am struck with only one solution. that i.e

    zimbra should not allow if we uncheck the authentication required option

    Can any body can help how to achieve this.
    Last edited by sridharsagi; 08-11-2010 at 04:01 AM.

  10. #10
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    I have the same problem.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZIMBRA SMTP AUTH problem
    By syedbilalmasaud in forum Administrators
    Replies: 75
    Last Post: 11-21-2012, 09:39 AM
  2. Disable SMTP AUTH
    By arvind510 in forum Administrators
    Replies: 1
    Last Post: 09-29-2008, 07:49 AM
  3. [SOLVED] Force AUTH SMTP For Local/External Networks
    By the_griz in forum Administrators
    Replies: 1
    Last Post: 09-19-2008, 01:40 PM
  4. [SOLVED] NE Migration: SMTP AUTH Failure
    By markpr in forum Installation
    Replies: 14
    Last Post: 10-03-2007, 12:51 PM
  5. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •