Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: SMTP-AUTH configuration

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by leandropazc View Post
    I have the same problem.
    A 'me too' post isn't really very useful. What are you trying to achieve and why?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    When I said "I have the same problem" I meant I did exactly what the user sridharsagi did .

    I can send mail through my server without a user account ...

    What would you recommend to prevent this from happening?

    regards

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by leandropazc View Post
    When I said "I have the same problem" I meant I did exactly what the user sridharsagi did .

    I can send mail through my server without a user account ...
    Through your server to an external address? Are you on the same LAN as the server when you try this?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    Yes, I am in the same LAN.

    The IP address of my Zimbra server is 10.24.0.21 and I sent emails from the address 10.24.0.7 to an account in Gmail or Yahoo mail for example.

  5. #15
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by leandropazc View Post
    Yes, I am in the same LAN.
    Of course you can send email without being asked for authentication, that's perfectly normal when you're in the "Trusted Networks" and there's nothing sinister about it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #16
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    In my trusted networks I have only the IP address of my server. Using the command
    zmprov ms MY-SERVER.COM zimbraMtaMyNetworks '127.0.0.0/8 10.24.0.21/32 192.168.250.4/32'

    I only need that on my trusted network are the IP address of my server and the IP address of another server. The rest should authenticate itself before sending email.
    Last edited by leandropazc; 08-18-2011 at 09:07 AM.

  7. #17
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,504
    Rep Power
    57

    Default

    Quote Originally Posted by leandropazc View Post
    The rest should authenticate itself before sending email.
    If they are using a mail client then the users should use the correct Submission port which is port 587 - that requires Authentication.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #18
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    The mail client that is used by users on my network is Microsoft Outlook. It has an option called "My outgoing server (SMTP) requires authentication" if the user does not select this option, the mail is sent without problems.

    What I'm trying to achieve is that users are forced to select this option to send an email.

  9. #19
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Is your server 10.24.0.20 or 10.24.0.21? You say one in one post, and the other in another post.

    I wouldn't entirely trust Outlook. At minimum, I would be sure to exit and restart Outlook after making the config change, just to be (more) certain that Outlook is actually adjusting its behavior.

    But the best test would be to use telnet from e.g. 10.24.0.7. Just drop into a command shell and do

    telnet 10.24.0.20 25

    You'll get an SMTP banner. Follow that up with

    HELO [10.24.0.7]
    MAIL FROM:<youraddress@yourcompany.com>
    RCPT TO:<someaddress@somewhere.com>


    At this point, if you're right about mail being relayed from arbitrary addresses without authentication, you'll get a result code 250. If not, you'll get a result code 554 5.7.1 <someaddress@somewhere.com>: Relay access denied. Either way, type QUIT to exit the SMTP session.

  10. #20
    leandropazc is offline Intermediate Member
    Join Date
    May 2011
    Posts
    20
    Rep Power
    4

    Default

    I connect to my server via telnet as you said, I get the message "Relay access denied"

    Now when I try to send a mail using SMTP authentication, in this case using the Thunderbird mail client, will not let me send any mail. These are the server logs when I try to send an email.

    /var/log/zimbra.log

    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: connect from severus.mydomain.mycompany.com[10.24.0.7]
    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: setting up TLS connection from severus.mydomain.mycompany.com[10.24.0.7]
    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: Anonymous TLS connection established from severus.mydomain.mycompany.com[10.24.0.7]: TLSv1 with cipher DHE-RSA-CAMELLIA256-SHA (256/256 bits)
    Aug 17 16:39:46 zimbra saslauthd[7305]: zmauth: authenticating against elected url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' ...
    Aug 17 16:39:46 zimbra saslauthd[7305]: authentication against url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' caused error 'curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT'
    Aug 17 16:39:46 zimbra saslauthd[7305]: url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' will not be used for (at least) 600 seconds
    Aug 17 16:39:46 zimbra saslauthd[7305]: Authentication cycle re-elected url https://zimbra.mydomain.mycompany.co...ce/admin/soap/, giving up ...
    Aug 17 16:39:46 zimbra saslauthd[7305]: auth_zimbra: leandro auth failed: curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT
    Aug 17 16:39:46 zimbra saslauthd[7305]: do_auth : auth failure: [user=leandro] [service=smtp] [realm=] [mech=zimbra] [reason=Unknown]
    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: warning: SASL authentication failure: Password verification failed
    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: warning: severus.mydomain.mycompany.com[10.24.0.7]: SASL PLAIN authentication failed: authentication failure
    Aug 17 16:39:46 zimbra saslauthd[7306]: zmauth: authenticating against elected url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' ...
    Aug 17 16:39:46 zimbra saslauthd[7306]: authentication against url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' caused error 'curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT'
    Aug 17 16:39:46 zimbra saslauthd[7306]: url 'https://zimbra.mydomain.mycompany.com:7071/service/admin/soap/' will not be used for (at least) 600 seconds
    Aug 17 16:39:46 zimbra saslauthd[7306]: Authentication cycle re-elected url https://zimbra.mydomain.mycompany.co...ce/admin/soap/, giving up ...
    Aug 17 16:39:46 zimbra saslauthd[7306]: auth_zimbra: leandro auth failed: curl_easy_perform: error(56): Received HTTP code 403 from proxy after CONNECT
    Aug 17 16:39:46 zimbra saslauthd[7306]: do_auth : auth failure: [user=leandro] [service=smtp] [realm=] [mech=zimbra] [reason=Unknown]
    Aug 17 16:39:46 zimbra postfix/smtpd[29977]: warning: severus.mydomain.mycompany.com[10.24.0.7]: SASL LOGIN authentication failed: authentication failure

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZIMBRA SMTP AUTH problem
    By syedbilalmasaud in forum Administrators
    Replies: 75
    Last Post: 11-21-2012, 09:39 AM
  2. Disable SMTP AUTH
    By arvind510 in forum Administrators
    Replies: 1
    Last Post: 09-29-2008, 07:49 AM
  3. [SOLVED] Force AUTH SMTP For Local/External Networks
    By the_griz in forum Administrators
    Replies: 1
    Last Post: 09-19-2008, 01:40 PM
  4. [SOLVED] NE Migration: SMTP AUTH Failure
    By markpr in forum Installation
    Replies: 14
    Last Post: 10-03-2007, 12:51 PM
  5. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •