Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ZMSetServername and various problems

  1. #1
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default ZMSetServername and various problems

    Hi all,

    I will start with a brief synopsis of my setup:

    1. I use zimbra 5.0.12 (ubuntu 32bit) as our main mail server
    2. We are looking at going 64bit and faster procs and zimbra 6
    3. So I started out by creating a mail server called with hostname as "mail2.*".
    4. Then I created all accounts using a script and zmprov.
    5. Then copied "all" mail over using imapsync

    Now that I have a current snapshot of mail I want to use zmsetservername to change the servername from "mail" to "mail2" I turn off(power down) mail and then I run the command 'zmsetservername -n mail.chinooksd.ca' and wait.

    The errors I get complain about

    "Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn’t exist."

    I then set my hosts file to:
    rcaudill@mail2:~$ cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    *.*.*.* mail2.chinooksd.ca mail2

    I also change "/etc/hostname" to mail.chinooksd.ca and then I update my networking to reflect the new ip.

    Dig shows:

    ; <<>> DiG 9.7.0-P1 <<>> chinooksd.ca mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57892
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 4

    ;; QUESTION SECTION:
    ;chinooksd.ca. IN MX

    ;; ANSWER SECTION:
    chinooksd.ca. 600 IN MX 10 mail2.chinooksd.ca.
    chinooksd.ca. 600 IN MX 5 mail.chinooksd.ca.

    ;; AUTHORITY SECTION:
    chinooksd.ca. 600 IN NS fulcrum.sasknet.sk.ca.
    chinooksd.ca. 600 IN NS stuka.sasknet.sk.ca.

    ;; ADDITIONAL SECTION:
    mail.chinooksd.ca. 600 IN A 207.195.80.254
    mail2.chinooksd.ca. 600 IN A 207.195.80.209
    stuka.sasknet.sk.ca. 2762 IN A 142.165.200.10
    fulcrum.sasknet.sk.ca. 3061 IN A 142.165.21.10

    ;; Query time: 137 msec
    ;; SERVER: 172.16.1.254#53(172.16.1.254)
    ;; WHEN: Wed Jul 14 07:00:50 2010
    ;; MSG SIZE rcvd: 190


    When I reboot the server I still get the previous messages above. I then read various docs and think it could be the certs.
    So then I run:

    "zmcertmgr createca -new"
    "zmcertmgr createcrt self -new"
    "zmcertmgr deploycrt self"


    And yet I still get the same problems. I then run "zmsetservername -n mail2.chinooksd.ca" and update hosts,hostname, and networking and restart and mail2 works again. Does anyone have any ideas what could be the problem?

    Thanks,
    Rick Caudill

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    I presume you followed these instructions from the wiki? Can you confirm, by running the commands in step 6, that everything has changed correctly?

    I notice from your dig commands that you are using a LAN DNS server when your Zimbra servers are on a public IP, is that correct? You should run the commands from the Zimbra server itself and for confirmation run these:

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    You should also make sure that you DNS isn't being blocked by a firewall or SElinux on the Zimbra server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    I presume you followed these instructions from the wiki? Can you confirm, by running the commands in step 6, that everything has changed correctly?
    I couldn't run the commands. I would get authentication errors.

    Quote Originally Posted by phoenix View Post
    I notice from your dig commands that you are using a LAN DNS server when your Zimbra servers are on a public IP, is that correct?
    I have tried with using a lan dns server and a public dns server

    Quote Originally Posted by phoenix View Post
    You should run the commands from the Zimbra server itself and for confirmation run these:

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    You should also make sure that you DNS isn't being blocked by a firewall or SElinux on the Zimbra server.
    Do you want from the old mailserver, the new mailserver, or both?

    Thanks,
    Rick Caudill

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by rcaudill View Post
    Do you want from the old mailserver, the new mailserver, or both?
    You might as well do both, just for confirmation.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    You might as well do both, just for confirmation.
    Code:
    Mail:
    
    hosts:
    
    root@mail:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    
    resolv.conf
    
    search chinooksd.ca
    #nameserver 10.175.253.254
    nameserver 10.244.0.66
    nameserver 10.244.0.67
    
    
    dig chinooksd.ca mx:
    
    ; <<>> DiG 9.4.2-P2 <<>> chinooksd.ca mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45522
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;chinooksd.ca.			IN	MX
    
    ;; ANSWER SECTION:
    chinooksd.ca.		86400	IN	MX	5 mail.chinooksd.ca.
    chinooksd.ca.		86400	IN	MX	10 mail2.chinooksd.ca.
    
    ;; AUTHORITY SECTION:
    chinooksd.ca.		86400	IN	NS	cnet-dns1.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns3.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns2.cnetdmz.ca.
    
    ;; ADDITIONAL SECTION:
    mail.chinooksd.ca.	86400	IN	A	10.175.253.18
    mail2.chinooksd.ca.	86400	IN	A	10.175.253.17
    cnet-dns1.cnetdmz.ca.	86400	IN	A	10.244.1.11
    cnet-dns2.cnetdmz.ca.	86400	IN	A	10.244.1.12
    cnet-dns3.cnetdmz.ca.	86400	IN	A	10.244.2.11
    
    ;; Query time: 10 msec
    ;; SERVER: 10.244.0.66#53(10.244.0.66)
    ;; WHEN: Wed Jul 14 08:25:38 2010
    ;; MSG SIZE  rcvd: 233
    
    
    
    dig chinooksd.ca any:
    
    root@mail:~# dig chinooksd.ca any
    
    ; <<>> DiG 9.4.2-P2 <<>> chinooksd.ca any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58712
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;chinooksd.ca.			IN	ANY
    
    ;; ANSWER SECTION:
    chinooksd.ca.		86400	IN	SOA	cns-regn-edu-dd-01.sedu.ca. sasknetadmin.sasktel.sk.ca. 2010033101 10800 3600 604800 600
    chinooksd.ca.		86400	IN	A	10.175.253.62
    chinooksd.ca.		86400	IN	MX	5 mail.chinooksd.ca.
    chinooksd.ca.		86400	IN	MX	10 mail2.chinooksd.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns1.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns3.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns2.cnetdmz.ca.
    
    ;; ADDITIONAL SECTION:
    mail.chinooksd.ca.	86400	IN	A	10.175.253.18
    mail2.chinooksd.ca.	86400	IN	A	10.175.253.17
    cnet-dns1.cnetdmz.ca.	86400	IN	A	10.244.1.11
    cnet-dns2.cnetdmz.ca.	86400	IN	A	10.244.1.12
    cnet-dns3.cnetdmz.ca.	86400	IN	A	10.244.2.11
    
    ;; Query time: 10 msec
    ;; SERVER: 10.244.0.66#53(10.244.0.66)
    ;; WHEN: Wed Jul 14 08:26:22 2010
    ;; MSG SIZE  rcvd: 333
    
    
    host `hostname`
    mail.chinooksd.ca has address 10.175.253.18
    Code:
    Mail2:
    
    hosts:
    
    rcaudill@mail2:~$ cat /etc/hosts
    127.0.0.1	localhost.localdomain	localhost
    10.175.253.17	mail2.chinooksd.ca	mail2 (changed to mail.chinooksd.ca/mail)
    
    # The follo2wing lines are desirable for IPv6 capable hosts
    #::1     ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts
    
    
    
    resolv.conf:
    
    rcaudill@mail2:~$ cat /etc/resolv.conf 
    search chinooksd.ca
    nameserver 10.175.253.254
    nameserver 10.244.0.66
    nameserver 10.244.0.67
    
    
    dig chinooksd.ca mx
    
    ; <<>> DiG 9.4.2-P2.1 <<>> chinooksd.ca mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10307
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 3, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;chinooksd.ca.			IN	MX
    
    ;; ANSWER SECTION:
    chinooksd.ca.		86400	IN	MX	10 mail2.chinooksd.ca.
    chinooksd.ca.		86400	IN	MX	5 mail.chinooksd.ca.
    
    ;; AUTHORITY SECTION:
    chinooksd.ca.		86400	IN	NS	cnet-dns1.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns3.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns2.cnetdmz.ca.
    
    ;; ADDITIONAL SECTION:
    mail.chinooksd.ca.	86400	IN	A	10.175.253.18
    mail2.chinooksd.ca.	86400	IN	A	10.175.253.17
    cnet-dns1.cnetdmz.ca.	86400	IN	A	10.244.1.11
    cnet-dns2.cnetdmz.ca.	86400	IN	A	10.244.1.12
    cnet-dns3.cnetdmz.ca.	86400	IN	A	10.244.2.11
    
    ;; Query time: 8 msec
    ;; SERVER: 10.175.253.254#53(10.175.253.254)
    ;; WHEN: Wed Jul 14 08:29:03 2010
    ;; MSG SIZE  rcvd: 233
    
    
    dig chinooksd.ca any:
    
    dig chinooksd.ca any
    
    ; <<>> DiG 9.4.2-P2.1 <<>> chinooksd.ca any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25653
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 7, AUTHORITY: 0, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;chinooksd.ca.			IN	ANY
    
    ;; ANSWER SECTION:
    chinooksd.ca.		86400	IN	SOA	cns-regn-edu-dd-01.sedu.ca. sasknetadmin.sasktel.sk.ca. 2010033101 10800 3600 604800 600
    chinooksd.ca.		86400	IN	NS	cnet-dns3.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns2.cnetdmz.ca.
    chinooksd.ca.		86400	IN	NS	cnet-dns1.cnetdmz.ca.
    chinooksd.ca.		86400	IN	A	10.175.253.62
    chinooksd.ca.		86400	IN	MX	5 mail.chinooksd.ca.
    chinooksd.ca.		86400	IN	MX	10 mail2.chinooksd.ca.
    
    ;; ADDITIONAL SECTION:
    cnet-dns1.cnetdmz.ca.	86400	IN	A	10.244.1.11
    cnet-dns2.cnetdmz.ca.	86400	IN	A	10.244.1.12
    cnet-dns3.cnetdmz.ca.	86400	IN	A	10.244.2.11
    mail.chinooksd.ca.	86400	IN	A	10.175.253.18
    mail2.chinooksd.ca.	86400	IN	A	10.175.253.17
    
    ;; Query time: 8 msec
    ;; SERVER: 10.175.253.254#53(10.175.253.254)
    ;; WHEN: Wed Jul 14 08:29:45 2010
    ;; MSG SIZE  rcvd: 333
    
    
    
    mail2.chinooksd.ca has address 10.175.253.17 (was mail.chinooksd.ca has address 10.175.253.18)

    Thanks,
    Rick Caudill
    Last edited by phoenix; 07-14-2010 at 09:01 AM.

  6. #6
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default

    Everytime I post my mail server configs they get erased. I have posted this to see if this gets erased

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by rcaudill View Post
    Everytime I post my mail server configs they get erased. I have posted this to see if this gets erased
    They were in moderation because you're a new user.

    OK, so have I understood this correctly? When you've migrated the mail from your original server (mail) to your new mail2 server you power-off the original server (mail) and run the zmsetservername on mail2 and rename it to mail.chinooksd.ca, is that correct? If that's what you've done it should be OK but you haven't mentioned whether you've changed the IP address for mail.chinooksd.ca to the IP address of your new server, did you do that?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    They were in moderation because you're a new user.
    Ah, okay


    Quote Originally Posted by phoenix View Post
    OK, so have I understood this correctly? When you've migrated the mail from your original server (mail) to your new mail2 server you power-off the original server (mail) and run the zmsetservername on mail2 and rename it to mail.chinooksd.ca, is that correct? If that's what you've done it should be OK but you haven't mentioned whether you've changed the IP address for mail.chinooksd.ca to the IP address of your new server, did you do that?
    I transferred all the mail from mail.chinooksd.ca to mail2.chinooksd.ca using imapsync. I then power off mail.chinooksd.ca and ran zmsetservername on mail2 and changed /etc/hosts and /etc/hostname appropriately. I then changed /etc/network/interfaces from: address 10.175.253.17 to address 10.175.253.18 and then reboot the server

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    What state are you in at the moment, are both servers up. You need to check the DNS settings again after you've changed /etc/hostname, /etc/hosts and the IP address in /etc/network/interfaces to the one you want and rebooted - at this point your DNS (you should run the commands I gave you earlier) should resolve to the correct server. The error you're seeing indicates there's a DNS problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    rcaudill is offline Junior Member
    Join Date
    Jul 2010
    Posts
    9
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    What state are you in at the moment, are both servers up. You need to check the DNS settings again after you've changed /etc/hostname, /etc/hosts and the IP address in /etc/network/interfaces to the one you want and rebooted - at this point your DNS (you should run the commands I gave you earlier) should resolve to the correct server. The error you're seeing indicates there's a DNS problem.
    Both servers are up but they are set as mail and mail2.
    Is there just a possibility Zimbra's zmsetservename is not working??? Also is there a possibility that I have to run /etc/init.d/hostname.sh

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •