Results 1 to 5 of 5

Thread: Disk statistics not being logged

  1. #1
    jstrat is offline Active Member
    Join Date
    Feb 2006
    Posts
    33
    Rep Power
    9

    Default Disk statistics not being logged

    Hi

    I can see in the crontab that disk statistics are supposed to be logged every 10 minutes, along with server status every 2 minutes.

    #
    # Status logging
    #
    */2 * * * * /opt/zimbra/libexec/zmstatuslog
    */10 * * * * /opt/zimbra/libexec/zmdisklog
    The server status is being logged to the log file, but the disk statistics are only being logged if I manually run the zmdisklog!

    This is a persistant problem on all versions that I have tried on Mac OS X. The current version I am running is 4.0RC1 Network and OSS on either PPC Mac OS X or Intel Mac OS X.

    Any help appreciated
    Jason

  2. #2
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    Is the other process (zmstatuslog) correctly launched each 2 minutes ?

  3. #3
    jstrat is offline Active Member
    Join Date
    Feb 2006
    Posts
    33
    Rep Power
    9

    Default

    Yes and I can see the entries it makes in the /var/log/zimbra.log file.

    Jason

  4. #4
    jstrat is offline Active Member
    Join Date
    Feb 2006
    Posts
    33
    Rep Power
    9

    Default

    It would appear that the zmdisklog program assumes that /sbin is in the path, which it is not when using cron. Editing the program to call /sbin/mount fixed the problem.

    Thanks
    Jason

  5. #5
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,292
    Rep Power
    13

    Default

    Was about to suggest the path issue 8)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Zimbra Disk Statistics, non-EXT3 Volumes
    By ccmacmil in forum Administrators
    Replies: 6
    Last Post: 04-07-2008, 09:59 AM
  3. Disk info not getting logged
    By jwhbud in forum Administrators
    Replies: 8
    Last Post: 03-30-2007, 05:53 AM
  4. Possible bug in disk statistics page generation
    By gentoo_matt in forum Developers
    Replies: 4
    Last Post: 05-08-2006, 02:41 PM
  5. Disk: Statistics not produced
    By phoenix in forum Administrators
    Replies: 6
    Last Post: 11-29-2005, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •