Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Helo command rejected: need fully-qualified hostname

  1. #1
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default [SOLVED] Helo command rejected: need fully-qualified hostname

    Hi all

    New Zimbra install; receiving mail works fine, as does sending to most places. However, some recipient hosts are bouncing our mail with:

    Helo command rejected: need fully-qualified hostname

    There's no split DNS configured; I've got the following in /etc/hosts (Ubuntu):

    127.0.0.1 localhost
    192.168.1.220 zimbra.company.com zimbra

    "hostname" returns zimbra.company.com too. Where can I set the FQHN for Zimbra to use?

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Quote Originally Posted by fabwhack View Post
    New Zimbra install; receiving mail works fine, as does sending to most places. However, some recipient hosts are bouncing our mail with:

    Helo command rejected: need fully-qualified hostname

    There's no split DNS configured;
    You need a Split DNS for Zimbra to work correctly.

    Quote Originally Posted by fabwhack View Post
    I've got the following in /etc/hosts (Ubuntu):

    127.0.0.1 localhost
    192.168.1.220 zimbra.company.com zimbra
    The hosts file is incorrect.

    Go to the Zimbra :: Wiki and search for the word 'ubuntu' and follow the set-up instructions in there for the split dns & hosts file.

    You should also update your forum profile with the output of the following command (do not post it in this thread):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default

    Profile updated, thanks

    I've set up Split DNS according to the instructions, and all seems to be working fine. However, sending mail to certain hosts is still bounced: what do I need to do next? The server is still announcing itself as "zimbra", rather than "zimbra.company.com".

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Quote Originally Posted by fabwhack View Post
    I've set up Split DNS according to the instructions, and all seems to be working fine.
    Did you also update your hosts file to correct the problem with the format of the 127.0.0.1 line?

    Quote Originally Posted by fabwhack View Post
    However, sending mail to certain hosts is still bounced: what do I need to do next? The server is still announcing itself as "zimbra", rather than "zimbra.company.com".
    That doesn't really make sense as it should have got the FQDN from the hosts file for the server name, it should announce itself as "zimbra.company.com" - did you make any other changes during the initial install other than the change for the domain name and create the admin password?

    Telnet to your server on port 25, what does it actually show you as the greeting? What are the actual errors that you are seeing in the log files (post some of the lines)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default

    Hosts now shows:

    127.0.0.1 localhost.localdomain localhost
    192.168.1.220 zimbra.company.com zimbra
    I didn't make any other changes during install that I can remember - we have our own internal DNS server that I'd configured with A records, MX etc, which I'm sure is why the installer didn't complain about DNS.

    If I telnet to port 25, I get:

    220 zimbra ESMTP Postfix
    Zimbra.log shows this when sending a mail to a problem recipient:

    Jun 27 17:18:40 zimbra postfix/smtp[25712]: 72FB711F61F7: to=<problem@problem.com>, relay=127.0.0.1[127.0.0.1]:10024
    , delay=0.77, delays=0.46/0/0/0.3, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=19943-05, from MTA([127.0.0.1]:10025): 250 2.0.0 O
    k: queued as 2AF3111F61FA)
    Jun 27 17:18:40 zimbra postfix/qmgr[21287]: 72FB711F61F7: removed
    Jun 27 17:18:40 zimbra postfix/smtp[25716]: 2AF3111F61FA: to=<problem@problem.com>, relay=mx-cluster-a2.one.com[195.
    47.247.193]:25, delay=0.34, delays=0.01/0/0.33/0, dsn=5.5.2, status=bounced (host mx-cluster-a2.one.com[195.47.247.193] refuse
    d to talk to me: 504 5.5.2 <zimbra>: Helo command rejected: need fully-qualified hostname)

  6. #6
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default

    Oops, meant to add (dunno if it's relevant): postconf |grep myhostname shows:

    myhostname = zimbra

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Quote Originally Posted by fabwhack View Post
    Oops, meant to add (dunno if it's relevant): postconf |grep myhostname shows:
    Erm, yes that's most likely what's causing your problem. Did you change it? Change it back to the default FQDN of your sever and the problem should go away. The hosts file is also now correct.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default

    The thing is, I can't change it If it try

    postconf -e myhostname=zimbra.company.com
    ... it doesn't "stick" when I restart Zimbra. As soon as Zimbra starts up, it's reverted back to "myhostname=zimbra". How can I stop Zimbra overwriting the setting, or where do I tell Zimbra about the new FQDN?

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,469
    Rep Power
    56

    Default

    Run the following command and see if they all show your old hostname 'zimbra':

    Code:
    zmprov gacf | grep oldhostname
    zmprov gs `zmhostname` | grep oldhostname
    zmlocalconfig | grep oldhostname
    If they do then follow these instructions to change the server name to the one you want. Make sure that you stop mail coming into the system and that you also take a backup before you make the change to the host name.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    fabwhack is offline Junior Member
    Join Date
    Jun 2010
    Posts
    7
    Rep Power
    5

    Default

    Hooray! That seems to have done the trick. I'd seen reference to the zmsetservername command, but I thought it was only for setting the hostname rather than the complete FQDN. Telnet to 25 shows zimbra.company.com and mail now goes to problem domains OK. There may be other latent problems I don't about yet, but so far so good!

    Thanks *very* much for your help!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. HELO hostname
    By tkramis in forum Administrators
    Replies: 5
    Last Post: 03-04-2013, 09:48 AM
  2. Zimbra Server very slow - Too many SMTP connections
    By pc-nico in forum Administrators
    Replies: 23
    Last Post: 06-05-2008, 05:12 AM
  3. Installation Cancelled - Zimbra-spell !
    By Ledg in forum Installation
    Replies: 4
    Last Post: 10-19-2006, 02:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •