Results 1 to 7 of 7

Thread: MTA external domain

  1. #1
    maximepm is offline New Member
    Join Date
    May 2010
    Posts
    4
    Rep Power
    4

    Default MTA external domain

    I have a problem, it's impossible to send email from outlook express to an external domain of zimbra server. But it's possible to send email from OE to an internal domain.

    The error :
    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '...dest'. Subject 'test', Account: 'mondomaine', Server: 'monserveur', Protocol: SMTP, Server Response: '554 5.7.1 <...dest>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

    OE is configure with smtp auth like imap auth without ssl.

    LOGS :
    May 16 10:39:32 ks355*** postfix/smtpd[28204]: connect from ****.***.net[**.233.48.121]
    May 16 10:39:32 ks355*** postfix/smtpd[28204]: NOQUEUE: reject: RCPT from ******.****.net[**.233.48.121]: 554 5.7.1 <***@externe.fr>: Relay access denied; from=<***@interne.eu> to=<***@externe.fr> proto=ESMTP helo=<CNU01101V2>
    May 16 10:39:32 ks355*** postfix/smtpd[28204]: disconnect from ****.****.net[***.233.48.121]
    Mon master.cf
    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the Postfix master(5) manual page.
    #
    # ================================================== ========================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ================================================== ========================
    smtp inet n - n - - smtpd
    587 inet n - n - - smtpd


    #submission inet n - n - - smtpd
    # -o smtpd_etrn_restrictions=reject
    465 inet n - n - - smtpd
    # -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
    #submission inet n - n - - smtpd
    # -o smtpd_etrn_restrictions=reject
    #628 inet n - n - - qmqpd
    pickup fifo n - n 60 1 pickup
    cleanup unix n - n - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - n 300 1 oqmgr
    tlsmgr unix - - n 1000? 1 tlsmgr
    rewrite unix - - n - - trivial-rewrite
    bounce unix - - n - 0 bounce
    defer unix - - n - 0 bounce
    trace unix - - n - 0 bounce
    verify unix - - n - 1 verify
    flush unix n - n 1000? 0 flush
    proxymap unix - - n - - proxymap
    smtp unix - - n - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - n - - smtp
    -o fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - n - - showq
    error unix - - n - - error
    discard unix - - n - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - n - - lmtp
    anvil unix - - n - 1 anvil
    scache unix - - n - 1 scache
    #
    # ================================================== ==================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ================================================== ==================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
    #
    # The Cyrus deliver program has changed incompatibly, multiple times.
    #
    old-cyrus unix - n n - - pipe
    flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    cyrus unix - n n - - pipe
    user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
    #
    # AMAVISD-NEW
    #
    smtp-amavis unix - - n - 10 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o disable_dns_lookups=yes
    -o max_use=20
    127.0.0.1:10025 inet n - n - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o virtual_mailbox_maps=
    -o virtual_alias_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_delay_reject=no
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,rej ect
    -o mynetworks_style=host
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o smtpd_error_sleep_time=0
    -o smtpd_soft_error_limit=1001
    -o smtpd_hard_error_limit=1000
    -o smtpd_client_connection_count_limit=0
    -o smtpd_client_connection_rate_limit=0
    -o receive_override_options=no_header_body_checks,no_ unknown_recipient_checks,no_address_mappings
    Mon main.cf
    sender_canonical_maps = proxy:ldap:/opt/zimbra/conf/ldap-scm.cf
    virtual_alias_domains = proxy:ldap:/opt/zimbra/conf/ldap-vad.cf
    lmtp_connection_cache_time_limit = 4s
    recipient_delimiter =
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_auth_only = no
    myhostname = ks355***.kimsufi.com
    virtual_mailbox_domains = proxy:ldap:/opt/zimbra/conf/ldap-vmd.cf
    mydestination = localhost
    mailbox_size_limit = 0
    setgid_group = postdrop
    smtpd_client_restrictions = reject_unauth_pipelining
    queue_run_delay = 300s
    minimal_backoff_time = 300s
    virtual_alias_maps = proxy:ldap:/opt/zimbra/conf/ldap-vam.cf
    transport_maps = proxy:ldap:/opt/zimbra/conf/ldap-transport.cf
    message_size_limit = 20480000
    sendmail_path = /opt/zimbra/postfix/sbin/sendmail
    broken_sasl_auth_clients = yes
    lmtp_connection_cache_destinations =
    alias_maps = hash:/etc/aliases
    manpage_directory = /opt/zimbra/postfix/man
    smtpd_helo_required = yes
    in_flow_delay = 1s
    daemon_directory = /opt/zimbra/postfix/libexec
    maximal_backoff_time = 4000s
    virtual_transport = error
    mynetworks = 127.0.0.0/8 91.121.137.0/24
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination, permit
    lmtp_host_lookup = dns
    smtpd_tls_loglevel = 1
    relayhost =
    disable_dns_lookups = no
    mail_owner = postfix
    virtual_mailbox_maps = proxy:ldap:/opt/zimbra/conf/ldap-vmm.cf
    content_filter = smtp-amavis:[127.0.0.1]:10024
    version = 2.4.7.5z
    mailq_path = /opt/zimbra/postfix/sbin/mailq
    header_checks = pcre:/opt/zimbra/conf/postfix_header_checks
    queue_directory = /opt/zimbra/data/postfix/spool
    newaliases_path = /opt/zimbra/postfix/sbin/newaliases
    smtpd_reject_unlisted_recipient = no
    smtpd_data_restrictions = reject_unauth_pipelining
    local_header_rewrite_clients = permit_mynetworks
    command_directory = /opt/zimbra/postfix/sbin
    smtp_sasl_auth_enable = no
    smtp_use_tls = no

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Change your client to use an authenticated connection via the correct submission port which is Port 587. You can also find details of the OE error code here: +"outlook express" +"0x800CCC79" - Yahoo! Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    maximepm is offline New Member
    Join Date
    May 2010
    Posts
    4
    Rep Power
    4

    Default

    If I use the port 587

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'maxime@***.fr'. Subject 'test', Account: '***.eu', Server: '***.eu', Protocol: SMTP, Server Response: '554 5.7.1 <maxime@***.fr>: Relay access denied', Port: 587, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79

    It's the same for outlook, thunderbird...

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Check the details of the error code in the link I posted earlier. Have you actually modified anything in Zimbra (such as the Trusted Networks setting) that would cause this error?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    maximepm is offline New Member
    Join Date
    May 2010
    Posts
    4
    Rep Power
    4

    Default

    I just change yesterday main.cf and master.cf. to connect the apache mail function and zimbra MTA.


    postconf mynetworks
    mynetworks = 127.0.0.0/8 91.121.137.0/24

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by maximepm View Post
    I just change yesterday main.cf and master.cf. to connect the apache mail function and zimbra MTA.
    I don't understand what you mean by that statement.


    Quote Originally Posted by maximepm View Post
    postconf mynetworks
    mynetworks = 127.0.0.0/8 91.121.137.0/24
    Is your Zimbra server on a public IP or behind a NAT router on a private LAN IP? What was your mynetworks setting before you made the change?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    maximepm is offline New Member
    Join Date
    May 2010
    Posts
    4
    Rep Power
    4

    Default

    Sorry, I'm french and my english is a bit poor...

    I mean that i had modify (yesterday) the two files (main and master). Because my apache mail function didn't work correctly.

    My server isn't behind a NAT. His IP is a public IP.

    Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Per Domain external MTA relay
    By briandquinn in forum Administrators
    Replies: 11
    Last Post: 04-06-2011, 02:45 AM
  3. Replies: 6
    Last Post: 09-22-2008, 06:46 PM
  4. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  5. External domain
    By jackb in forum Administrators
    Replies: 2
    Last Post: 11-13-2007, 03:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •