Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Mail sent locally being caughty on RDNS_NONE?

  1. #1
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default Mail sent locally being caughty on RDNS_NONE?

    Hey there,

    If i send a mail to myself, locally, it seems to fire the RDNS_NONE filter, however i can dig/dig -x perfectly from the server itself.... Not idea why its getting this result? :/

    Return-Path: mail.to.me@domain.com
    Received: from my.mail.server.domain.com (LHLO my.mail.server.domain.com)
    (94.23.154.152) by my.mail.server.domain.com with LMTP; Wed, 21 Apr 2010 13:53:26
    +0100 (BST)
    Received: from localhost (localhost [127.0.0.1])
    by my.mail.server.domain.com (Postfix) with ESMTP id 275C3100495
    for <mail.to.me@domain.com>; Wed, 21 Apr 2010 13:53:26 +0100 (BST)
    X-Virus-Scanned: amavisd-new at my.mail.server.domain.com
    X-Spam-Flag: NO
    X-Spam-Score: -2.589
    X-Spam-Level:
    X-Spam-Status: No, score=-2.589 tagged_above=-10 required=3.4
    tests=[BAYES_00=-2.599, RDNS_NONE=0.01] autolearn=ham
    Received: from my.mail.server.domain.com ([127.0.0.1])
    by localhost (my.mail.server.domain.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id IwQdspYw4HFm for <mail.to.me@domain.com>;
    Wed, 21 Apr 2010 13:53:25 +0100 (BST)
    Received: from my.mail.server.domain.com (my.mail.server.domain.com [94.23.154.152])
    by my.mail.server.domain.com (Postfix) with ESMTP id 390BA100494
    for <mail.to.me@domain.com>; Wed, 21 Apr 2010 13:53:25 +0100 (BST)
    Note, i did a find replace on my mail address and server name.

    Any ideas?! Running Zimbra FOSS 6.0.6 on Kiddie OS (Ubuntu).

    Thanks,

    iMx

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    What have you set for trusted MTA networks ?

  3. #3
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default

    Thanks for the reply, all set correctly i believe under the server MTA options in the Admin GUI:

    127.0.0.0/8 94.23.154.152/32

    /8 local host and /32 for single IP of my mail server.

    iMx

  4. #4
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Does /opt/zimbra/conf/salocal.cf contain the correct trusted_networks entries ?

  5. #5
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default

    trusted_networks 127.0.0.0/8 94.23.154.152/32

    All present and correct

  6. #6
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Do you have a rDNS for 127.0.0.1 ?

  7. #7
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default

    Yup:


    ; <<>> DiG 9.4.2-P2.1 <<>> -x 127.0.0.1
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 44674
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;1.0.0.127.in-addr.arpa. IN PTR

    ;; ANSWER SECTION:
    1.0.0.127.in-addr.arpa. 604800 IN PTR localhost.

    ;; AUTHORITY SECTION:
    127.in-addr.arpa. 604800 IN NS localhost.

    ;; ADDITIONAL SECTION:
    localhost. 604800 IN A 127.0.0.1
    localhost. 604800 IN AAAA ::1

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Wed Apr 21 15:21:09 2010
    ;; MSG SIZE rcvd: 121

  8. #8
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Grrr Do you receive any errors or warnings from
    Code:
    /opt/zimbra/zimbramon/bin/spamassassin -D --lint -C /opt/zimbra/conf/spamassassin -p /opt/zimbra/conf/salocal.cf
    Would you be able post the output ?

  9. #9
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default

    Cool, ill take a look through this - the weird thing is, botnet doesnt fire - and im pretty sure that checks RDNS?

  10. #10
    imx
    imx is offline Special Member
    Join Date
    Jun 2009
    Posts
    131
    Rep Power
    5

    Default

    Says DNS is available...attached log.
    Attached Files Attached Files

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Messages not being delivered
    By buee in forum Administrators
    Replies: 53
    Last Post: 10-23-2009, 10:28 AM
  2. [SOLVED] Fed 11 zcs install with existing apache
    By Lantzvillian in forum Installation
    Replies: 2
    Last Post: 10-05-2009, 11:11 AM
  3. Replies: 30
    Last Post: 01-13-2009, 08:00 AM
  4. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  5. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 06:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •