Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 54

Thread: ClamAV 0.94 EOL on ZCS 5.0.16 prior (discussion)

  1. #11
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Looking at that error it would appear you are running Clam 0.94
    Code:
    0.94.1
    Which is now EOL for which have you read ClamAV 0.94 EOL on ZCS 5.0.16 prior

  2. #12
    snake_eyes's Avatar
    snake_eyes is offline Advanced Member
    Join Date
    Nov 2008
    Posts
    237
    Rep Power
    6

    Default

    yes yes I'm reading it now... and updating the clam...
    - In a world without walls and fences who needs windows and gates?
    - I am Running Linux.. Finally, my PC is valid & Reliable Hereafter.

  3. #13
    Join Date
    Feb 2009
    Location
    Milan
    Posts
    13
    Rep Power
    6

    Default

    thanks.

    check this: ClamAV 0.94 EOL on ZCS 5.0.16 prior

    I'm updating.
    Dave

  4. #14
    rocket15 is offline New Member
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    6

    Default Same problem

    Same here.. No mail receiving today

    LibClamAV Warning: ************************************************** *********
    LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
    LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
    LibClamAV Warning: ************************************************** *********
    LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
    LibClamAV Error: Problem parsing database at line 742
    LibClamAV Error: Can't load daily.ndb: Malformed database
    LibClamAV Error: cli_tgzload: Can't load daily.ndb
    LibClamAV Error: Can't load /opt/zimbra/data/clamav/db/daily.cld: Malformed database
    Fri Apr 16 10:43:53 2010 -> ERROR: Malformed database
    ERROR: Malformed database


    What is the fix?

  5. #15
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Read the big green status message at the top of the forums ? The clue is in the message you posted from ClamAV.

  6. #16
    snake_eyes's Avatar
    snake_eyes is offline Advanced Member
    Join Date
    Nov 2008
    Posts
    237
    Rep Power
    6

    Default

    it took less than 2 minutes to fix it thank you for your effort:

    Code:
    zimbra@mail:~$ zmcontrol start
    Host mail.mydomain.com
        Starting ldap...Done.
        Starting logger...Done.
        Starting mailbox...Done.
        Starting antispam...Done.
        Starting antivirus...Done.
        Starting snmp...Done.
        Starting spell...Done.
        Starting mta...Done.
        Starting stats...Done.
    zimbra@mail:~$ zmcontrol status
    Host mail.mydomain.com
        antispam                Running
        antivirus               Running
        ldap                    Running
        logger                  Running
        mailbox                 Running
        mta                     Running
        snmp                    Running
        spell                   Running
        stats                   Running
    zimbra@mail:~$
    - In a world without walls and fences who needs windows and gates?
    - I am Running Linux.. Finally, my PC is valid & Reliable Hereafter.

  7. #17
    rocket15 is offline New Member
    Join Date
    Jun 2008
    Posts
    3
    Rep Power
    6

    Default

    An upgrade of zimbra in less than two minutes? I would like to upgrade zimbra but not now.

    How do i fix this fast, external email is blocked at the moment. Can i disable clamav?

  8. #18
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Yes you can disable it from the Admin GUI. What version of ZCS are you running
    Code:
    su - zimbra
    zmcontrol -v

  9. #19
    Join Date
    May 2008
    Posts
    14
    Rep Power
    6

    Default

    Same thing happened to us here this morning (and, I imagine, many others). The problem is that ClamAV has reached it's end of life (causing malformed database errors when clamav starts) and will not function any more on older versions of Zimbra.

    ClamAV - Updating clamd for releases earlier than ZCS 5.0.16 - Zimbra :: Wiki

    For those using ZCS 5.0.16 and prior, come 15 April 2010 anti-virus definitions will no longer update AND your ClamAV instance will stop working entirely.
    EOL Source: http://www.clamav.net/2009/10/05/eol-clamav-094 "Starting from 15 April 2010 our CVD will contain a special signature which disables all clamd installations older than 0.95 – that is to say older than 1 year. We plan to start releasing signatures which exceed the 980 bytes limit on May 2010."


    As far as I can tell, there are only 3 options:

    1. Disable antivirus

    2. Install a more recent version of Zimbra (ie. ZCS 5.0.18+) on a seperate machine and copy the clamav folder over to your older instance of Zimbra

    3. Upgrade Zimbra

    The information on that wiki page should give you all the info you need.
    Last edited by hans@toplanguagejobs.com; 04-16-2010 at 02:54 AM.

  10. #20
    Join Date
    May 2008
    Posts
    14
    Rep Power
    6

    Default

    To disable antivirus via the command line:

    1. Login to the server and in as Zimbra. ie run: "su - zimbra"

    2. Stop zimbra: "zmcontrol stop"

    3. Run: "zmprov ms `zmhostname` -zimbraServiceEnabled Antivirus"

    4. Start zimbra again: "zmcontrol start"

Page 2 of 6 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ClamAV 0.94 EOL on ZCS 5.0.16 prior
    By mmorse in forum Announcements
    Replies: 1
    Last Post: 04-15-2010, 02:52 PM
  2. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  3. Mail is being queued, not delivered!
    By icepick94 in forum Administrators
    Replies: 12
    Last Post: 01-22-2009, 07:03 AM
  4. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •