Results 1 to 8 of 8

Thread: Drag-and-Drop: Back to the future

  1. #1
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Angry Drag-and-Drop: Back to the future

    Okay, this version I was promised by programmers to be the end all fix for DnD. I hope so but now there is an additional server-side zimlet, com_zimbra_dndext.zip, without any documentation as to what it is for! Nothing in Forums, Wiki, Bugs or Blog or even in the ZIP itself.

    Please folks, I know you are going through a major and great transition but, really, don't drop the ball like this. Some of us have jobs to keep here.

    Which zimlet are we to be using? Or, both? What is the exact fix on this bug?

    Thanx in advance.

  2. #2
    bdial's Avatar
    bdial is offline Moderator
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    i believe com_zimbra_dndext is for firefox 3.6 and doesn't require an addin for firefxo, it uses some native functionality built in to firefox 3.6

    i think you're meant to run both, the old zimlet is for 3.5 support.

    i don't think it's 100% fixed though still , see this thread

    http://www.zimbra.com/forums/install...n-6-0-6-a.html

  3. #3
    bmw
    bmw is offline Special Member
    Join Date
    Dec 2008
    Location
    San Rafael, CA
    Posts
    113
    Rep Power
    6

    Red face

    Okay, we're getting closer.

    On com_zimlet_dndext.zip, but there is no documentation or announcement anywhere what this is for, how it works, whether it needed to be deploy along side the standard DnD zimlet or by itself.

    So, maybe I should uninstall the DnD XPI in 3.6.3 and see what happens? Is this true of the new zimlet server-side.

    I've tried it all ways and here are the results using various Firefox versions

    *Linux Ubuntu 9.10
    FF 3.6.7 - embedded composer - fails
    - separate window composer - fails
    FF3.6.4pre - embedded composer - fails
    - separate window composer - fails

    *Mac - Leopard and Snow Leopard
    FF 3.6.3 - embedded composer - WORKS!
    - separate window composer - fails

    *Windows XP Pro
    FF 3.5.7 - embedded composer - fails
    - separate window composer - fails
    FF 3.5.9 - embedded composer - fails
    - separate window composer - fails
    FF 3.6.3 - embedded composer - WORKS!
    - separate window composer - fails

  4. #4
    ewilen's Avatar
    ewilen is offline Moderator
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

  5. #5
    miguel is offline Special Member
    Join Date
    Jun 2006
    Location
    Viseu
    Posts
    105
    Rep Power
    9

    Default

    Now dnd doesn't work in any firefox version (it was user to work for firefox 3.0.x) for briefcase component.. Thanks a lot..

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by miguel View Post
    Now dnd doesn't work in any firefox version (it was user to work for firefox 3.0.x) for briefcase component.. Thanks a lot..
    Did you look at, and vote on, the bugs mentioned in the post above yours?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    miguel is offline Special Member
    Join Date
    Jun 2006
    Location
    Viseu
    Posts
    105
    Rep Power
    9

    Default

    6.0.6 Notable Fixes:
    44828 - Drag 'n drop upload Zimlet support for Firefox 3.6

    I don't get why you say it's fixed, and then people upgrade needing this and is still broken. Worst, now it's broken for all previous Firefox versions for briefcase use. Should it be opened a new bug? This is Briefcase Dnd which was used to work with Firefox 3.0.X versions

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by miguel View Post
    6.0.6 Notable Fixes:
    44828 - Drag 'n drop upload Zimlet support for Firefox 3.6

    I don't get why you say it's fixed, and then people upgrade needing this and is still broken. Worst, now it's broken for all previous Firefox versions for briefcase use. Should it be opened a new bug? This is Briefcase Dnd which was used to work with Firefox 3.0.X versions
    I didn't say it was fixed, I asked if you'd seen and voted on the bug reposts in the post above yours. I know it says it's fixed in the release notes but the bug report doesn't mention it being fixed, I think you can conclude that it's not fixed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Drag n' Drop File Attachments Issue
    By jmainwaring in forum General Questions
    Replies: 0
    Last Post: 02-17-2010, 07:18 AM
  2. Zimbra drag and drop
    By jayel in forum Administrators
    Replies: 10
    Last Post: 10-06-2009, 09:01 AM
  3. Drag 'n' Drop zimlet on Linux
    By iain in forum Zimlets
    Replies: 2
    Last Post: 02-15-2008, 06:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •