Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] service stats stopped

  1. #1
    hartleib is offline Junior Member
    Join Date
    Apr 2010
    Posts
    9
    Rep Power
    5

    Default [SOLVED] service stats stopped

    Hello,

    I installed the Zimbra server yesterday. Everything worked fine. All services are running.

    Today I set the web server mode to mixed with the command zmtlsctl mixed.

    After that, I stopped and started the server again with zmcontrol.

    The service stats was started, but stopped a minute after every restart.

    Any ideas what to do?

    btw: I already checked the /opt/zimbra/zmstats/ folder, it is completly owned by the user zimbra. Just because I found this hint in another thread for this issue.

    Release 6.0.5_GA_2213.UBUNTU8_64 UBUNTU8_64 NETWORK edition.

  2. #2
    hartleib is offline Junior Member
    Join Date
    Apr 2010
    Posts
    9
    Rep Power
    5

    Default

    some more info..

    $ zmstatctl status
    Running: zmstat-allprocs
    Running: zmstat-cpu
    process 9345 in /opt/zimbra/zmstat/pid/zmstat-mysql.pid not running
    Running: zmstat-mtaqueue
    Running: zmstat-proc

  3. #3
    veronica is offline Outstanding Member
    Join Date
    Jun 2008
    Posts
    594
    Rep Power
    8

    Default

    Is your mysql running ?

  4. #4
    farrukhndm is offline Special Member
    Join Date
    Aug 2008
    Location
    Pakistan
    Posts
    100
    Rep Power
    6

    Default if Apache server running plz change its Listen Port

    Hi hartleib,


    Please check is there Apache server running ??If Yes then it should not be use port 80.So now you need to change apache port 80 to any port not in used in your system
    vi /etc/httpd/conf/httpd.conf
    Listen 80 -> 81

    #service httpd stop
    #service httpd start
    #su - zimbra
    $zmcontrol stop
    $zmcontrol start

  5. #5
    hartleib is offline Junior Member
    Join Date
    Apr 2010
    Posts
    9
    Rep Power
    5

    Default

    I stopped the apache service before installing the zimbra server

    /etc/init.d/apache2 stop
    and removed it from autostart
    update-rc.d -f apache2 remove
    there is no other apache server running the moment
    the zimbra webmailer (http-mode) is reachable at port 80
    The mysql server is running.


    where can i see more detailed info on the stop of the stats service? which log file?
    Last edited by hartleib; 04-07-2010 at 12:54 PM.

  6. #6
    hartleib is offline Junior Member
    Join Date
    Apr 2010
    Posts
    9
    Rep Power
    5

    Default

    I found so more info in the file /opt/zimbra/zmstat/zmstat.out

    sh: line 1: Could: command not found
    sh: line 2: Could: command not found
    Error while running '/opt/zimbra/bin/mysql --user=Error occurred during initialization of VM
    Could not reserve enough space for code cache --password=Error occurred during initialization of VM
    Could not reserve enough space for code cache --database=zimbra --batch --skip-column-names'. at /opt/zimbra/zimbramon/lib/Zimbra/DB/DB.pm line 73.
    But I still don't know how to solve the problem. I would be lucky if anybody could help.

    Thanks,
    Christoph

    The Server is a VPS with 4 GB RAM, 120GB HDD.

  7. #7
    hartleib is offline Junior Member
    Join Date
    Apr 2010
    Posts
    9
    Rep Power
    5

    Default

    The problem was that the commercial certificate was not imported in the cert-store

    That fixed it:

    /opt/zimbra/java/bin/keytool -import -alias new -keystore /opt/zimbra/java/jre/lib/security/cacerts -storepass changeit -file commercial.crt

  8. #8
    zibra is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    85
    Rep Power
    8

    Default

    Hi Hartleib,
    I have the same problem. I only change webserver mode from "redirect" to "http" and now I have stats service is stopped. My Zimbra is FOSS 6.0.6. I have tried your solution but not successful. Please help me.

    Thanks,

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by zibra View Post
    Hi Hartleib,
    I have the same problem. I only change webserver mode from "redirect" to "http" and now I have stats service is stopped.
    You realise that doing that means your external users will have a security exposure don't you? Have you tried some of the other solutions in the forums for fixing the 'stats problem'? Have you looked in the log files for any errors? What happens when you restart Zimbra, any errors?
    Last edited by phoenix; 05-07-2010 at 02:22 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    zibra is offline Loyal Member
    Join Date
    Mar 2007
    Posts
    85
    Rep Power
    8

    Default

    I know that but I only want to use http mode. Please help me.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. stats service stopped
    By hoangnam8484 in forum Administrators
    Replies: 23
    Last Post: 05-04-2012, 10:10 AM
  2. Service stats stopped on xxx.xxx.net
    By rwcanary in forum Administrators
    Replies: 12
    Last Post: 01-10-2010, 10:48 AM
  3. Replies: 5
    Last Post: 05-28-2009, 12:53 AM
  4. stats service stopped
    By tiger2000 in forum Administrators
    Replies: 0
    Last Post: 07-31-2008, 07:06 PM
  5. Replies: 20
    Last Post: 03-18-2008, 05:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •