Results 1 to 2 of 2

Thread: [SOLVED] ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)

  1. #1
    sujithmk is offline Active Member
    Join Date
    Mar 2008
    Posts
    28
    Rep Power
    7

    Default [SOLVED] ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)

    Hi folks,

    Need some urgent help. I am running a Master/Slave Zimbra LDAP server. My Zimbra version is : Release 5.0.11_GA_2695.RHEL5_20081117051306 CentOS5 FOSS edition

    I had the Master/Slave setting working perfectly fine. It broke when I tried to upgrade the ClamAV version on the slave server as it was showing warnings in the logs.

    I installed the same version of master on slave with LDAP Master as master.hostname.com.

    But, while installing it gives error as

    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)

    Creating LDAP config in /opt/zimbra/conf/slapd.conf...succeeded
    Enabling LDAP service on slave.hostname.com...ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    ...ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    succeeded

    Sat Apr 3 05:23:33 2010 Starting ldap...
    Sat Apr 3 05:23:33 2010 *** Running as zimbra user: /opt/zimbra/sleepycat/bin/db_recover -h /opt/zimbra/openldap-data
    Sat Apr 3 05:23:33 2010 *** Running as zimbra user: /opt/zimbra/libexec/zmldapapplyldif
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)

    Sat Apr 3 05:24:09 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms slave.hostname.com zimbraSpellCheckURL http://slave.hostname.com:7780/aspell.php
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    Sat Apr 3 05:24:10 2010 done.
    Sat Apr 3 05:24:10 2010 Setting service ports on slave.hostname.com...
    Sat Apr 3 05:24:10 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms slave.hostname.com zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraImapProxyBindPort 7143 zimbraImapSSLProxyBindPort 7993
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    Sat Apr 3 05:24:12 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms slave.hostname.com zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995 zimbraPop3ProxyBindPort 7110 zimbraPop3SSLProxyBindPort 7995
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    Sat Apr 3 05:24:13 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -l ms slave.hostname.com zimbraMailPort 80 zimbraMailSSLPort 443 zimbraMailProxyPort 8080 zimbraMailSSLProxyPort 8443 zimbraMailMode http
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    Sat Apr 3 05:24:14 2010 done.
    Sat Apr 3 05:24:14 2010 Adding slave.hostname.com to zimbraMailHostPool in default COS...
    Sat Apr 3 05:24:17 2010 *** Running as zimbra user: /opt/zimbra/bin/zmprov -l mc default zimbraMailHostPool e9ab18bd-9f19-407a-a47e-9ed1c2ad81a0 zimbraMailHostPool

    Sat Apr 3 05:29:27 2010 *** Running as zimbra user: /opt/zimbra/bin/zmsshkeygen
    Generating public/private dsa key pair.
    Your identification has been saved in /opt/zimbra/.ssh/zimbra_identity.
    Your public key has been saved in /opt/zimbra/.ssh/zimbra_identity.pub.
    The key fingerprint is:
    87:a8:c0:01:4e:f2:79:d4:19:45:15:6d:19:98:b1:6f slave.hostname.com
    ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)
    Sat Apr 3 05:29:29 2010 *** Running as zimbra user: /opt/zimbra/bin/zmupdateauthkeys
    Updating /opt/zimbra/.ssh/authorized_keys

    [zimbra@slave ~]$ zmcontrol status
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    [zimbra@slave ~]$

    [zimbra@slave ~]$ zmcontrol start
    Host slave.hostname.com
    [zimbra@slave ~]$

    In /var/log/zimbra.log
    Apr 3 05:32:04 slave zimbramon[4111]: 4111:info: 2010-04-03 05:32:01, STATUS: : Cannot: determine services - exiting
    When I check the list of servers in Master server it says it exists. I even deleted the slave server and tried new installation but still shows the same error.

    [zimbra@mx ~]$ zmprov gas
    mx.master.com
    slave.hostname.com
    [zimbra@mx ~]$
    I tried many threads mentioned in the forum :

    [SOLVED] Zimbra down !!! ERROR: account.NO_SUCH_SERVER
    Exporting and Importing Zimbra LDAP Data » Zimbra :: Blog
    Recreating a Self-Signed SSL Certificate in ZCS 4.5 & 5.0 - Zimbra :: Wiki

    But these didn't help. All ends in same error. I disabled all firewall and crossed checked the LDAP passwords and its all same.

    Please help as its very critical for our mail service.

    Regards
    Sujith

  2. #2
    sujithmk is offline Active Member
    Join Date
    Mar 2008
    Posts
    28
    Rep Power
    7

    Default [SOLVED] ERROR: account.NO_SUCH_SERVER (no such server: slave.hostname.com)

    I solved it .

    I had a backup of old installation. I restored it, and run ./install.sh and upgraded the installation.

    Then fixed the Self signed SSL by reinstalling as per threads in forum

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to: cold standby server (no cluster)
    By fisch09 in forum Installation
    Replies: 50
    Last Post: 02-18-2014, 10:51 AM
  2. Keeping a backup server synced with live server
    By Q-Mike in forum Administrators
    Replies: 5
    Last Post: 04-11-2008, 01:40 PM
  3. [SOLVED] Server migration/move for OS steps I used
    By newmember in forum Migration
    Replies: 0
    Last Post: 09-06-2007, 10:57 PM
  4. Replies: 1
    Last Post: 09-16-2006, 11:02 PM
  5. Replies: 18
    Last Post: 03-20-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •