Results 1 to 2 of 2

Thread: pop3 server performance and "I/O error while processing connection" ?

  1. #1
    tiger2000 is offline Elite Member
    Join Date
    May 2008
    Location
    Taiwan
    Posts
    296
    Rep Power
    6

    Default pop3 server performance and "I/O error while processing connection" ?

    Dear all,

    on a ZCS 6.0.2 OSS system (64-bit), one of internal users send an email with 5 MB attachment to the distribution list for all interal staff(~ 1000 users).

    after then, users found they have problem to download email via pop3 , their outlook express show the process of email downloading, but can not complete. obviously, it's stuck in that email with 5MB attachment, they have to login web interface and remove that email, then everything goes fine.

    the other users (like admin and some system accounts) don't have this problem, cause they didn't belong to that distribution list.



    Checking the mailbox.log for that period of time, i didn't find anything obvious, just found this I/O error message below. Does anyone see this before and how to solve ( or avoid) this kind of issue? Thanks.

    Code:
    2010-03-31 14:37:22,688 INFO  [Pop3Server-4267631] [ip=xxx.xxx.xxx.xxx;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Broken pipe
    
    2010-03-31 14:37:22,688 INFO  [Pop3Server-4267631] [] ProtocolHandler - Handler exiting normally
    
    2010-03-31 14:37:22,697 INFO  [Pop3Server-4267636] [ip=xxx.xxx.xxx.xxx;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Broken pipe
    
    2010-03-31 14:37:22,697 INFO  [Pop3Server-4267636] [] ProtocolHandler - Handler exiting normally
    
    2010-03-31 14:37:22,707 INFO  [Pop3Server-4267626] [ip=xxx.xxx.xxx.xxx;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Broken pipe
    
    2010-03-31 14:37:22,707 INFO  [Pop3Server-4267626] [] ProtocolHandler - Handler exiting normally
    
    2010-03-31 14:37:22,710 INFO  [Pop3Server-4267641] [ip=xxx.xxx.xxx.xxx;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Broken pipe

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Hmmm, is your underlying disk subsystem showing any errors ? What is your disk subsystem ? It may be a lot of users tried to download and it could not keep up with the IO.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •