Results 1 to 8 of 8

Thread: I can't disable X-Originating-IP

  1. #1
    gnoul is offline Active Member
    Join Date
    Jul 2009
    Location
    Vietnam
    Posts
    25
    Rep Power
    5

    Arrow I can't disable X-Originating-IP

    Because of the spam reason, I have to disable it. I go to Admin UI, uncheck "Add X-Originating-IP to mail header". I review the result by sending email to Yahoo/Gmail and view the full header. I still see the X-Originating-IP there.

    I use Zimbra 5.0.18.

    I appreciate for any help.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Did you restart Zimbra after the change ?

  3. #3
    gnoul is offline Active Member
    Join Date
    Jul 2009
    Location
    Vietnam
    Posts
    25
    Rep Power
    5

    Default

    Yes. I restarted. But it still in the full mail header. Is it bug?

  4. #4
    gnoul is offline Active Member
    Join Date
    Jul 2009
    Location
    Vietnam
    Posts
    25
    Rep Power
    5

    Default

    Anyone has trouble like this?. Help me please.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by z1mbra View Post
    Anyone has trouble like this?.
    I guess not.

    You really need to show some evidence that what you're saying is actually what is happening. You should check the following setting:

    Code:
    zmprov gcf grep zimbraSmtpSendAddOriginatingIP
    Run two tests, go to the admin UI and see if it's also the same setting (checked or unchecked) and send a test email and post the headers here (including the output of that command above). When you've done that, go to the admin UI and change the setting (either check it or uncheck it - set it to the opposite of the last test) and again post the output of the command above and send a test email and post the headers from that.

    BTW, you don't need to restart Zimbra after the change is made, it takes effect immediately.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    gnoul is offline Active Member
    Join Date
    Jul 2009
    Location
    Vietnam
    Posts
    25
    Rep Power
    5

    Post

    Phoenix,
    Assume that, my email is luong.t@abc.com, receiver email is luong@gmail.com, my server mail.abc.com (ip is hidden).
    Below is the header when un-checked Add X-Originating-IP:

    Delivered-To: luong@gmail.com
    Received: by 10.231.174.134 with SMTP id t6cs43510ibz;
    Sun, 28 Mar 2010 11:35:44 -0700 (PDT)
    Received: by 10.229.192.10 with SMTP id do10mr2241201qcb.48.1269801343405;
    Sun, 28 Mar 2010 11:35:43 -0700 (PDT)
    Return-Path: <luong.t@abc.com>
    Received: from mail.abc.com (mail.abc.com [xxx.xxx.xxx.xxx])
    by mx.google.com with ESMTP id 31si6397599qyk.58.2010.03.28.11.35.41;
    Sun, 28 Mar 2010 11:35:42 -0700 (PDT)
    Received-SPF: pass (google.com: best guess record for domain of luong.t@abc.com designates xxx.xxx.xxx.xxx as permitted sender) client-ip=xxx.xxx.xxx.xxx;
    Authentication-Results: mx.google.com; spf=pass (google.com: best guess record for domain of luong.t@abc.com designates xxx.xxx.xxx.xxx as permitted sender) smtp.mail=luong.t@abc.com
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by mail.abc.com (Postfix) with ESMTP id 08EC821F7F4;
    Mon, 29 Mar 2010 01:35:39 +0700 (ICT)
    X-Virus-Scanned: amavisd-new at abc.com
    Received: from mail.abc.com ([127.0.0.1])
    by localhost (mail.abc.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id Jtgdb7idPy4G; Mon, 29 Mar 2010 01:35:36 +0700 (ICT)
    Received: from luong (unknown [123.24.24.192])
    by mail.abc.com (Postfix) with ESMTPSA id 3C9BF21F7F2;
    Mon, 29 Mar 2010 01:35:30 +0700 (ICT)
    And, when checked Add X-Originating-IP:
    Delivered-To: luong@gmail.com
    Received: by 10.231.174.134 with SMTP id t6cs43596ibz;
    Sun, 28 Mar 2010 11:41:34 -0700 (PDT)
    Received: by 10.143.24.11 with SMTP id b11mr1583279wfj.347.1269801693724;
    Sun, 28 Mar 2010 11:41:33 -0700 (PDT)
    Return-Path: <luong.t@abc.com>
    Received: from mail.abc.com (mail.abc.com [xxx.xxx.xxx.xxx])
    by mx.google.com with ESMTP id 32si10516448pzk.58.2010.03.28.11.41.32;
    Sun, 28 Mar 2010 11:41:33 -0700 (PDT)
    Received-SPF: pass (google.com: best guess record for domain of luong.t@abc.com designates xxx.xxx.xxx.xxx as permitted sender) client-ip=xxx.xxx.xxx.xxx;
    Authentication-Results: mx.google.com; spf=pass (google.com: best guess record for domain of luong.t@abc.com designates xxx.xxx.xxx.xxx as permitted sender) smtp.mail=luong.t@abc.com
    Received: from localhost (localhost.localdomain [127.0.0.1])
    by mail.abc.com (Postfix) with ESMTP id 77F7021F7FE
    for <luong@gmail.com>; Mon, 29 Mar 2010 01:41:31 +0700 (ICT)
    X-Virus-Scanned: amavisd-new at abc.com
    Received: from mail.abc.com ([127.0.0.1])
    by localhost (mail.abc.com [127.0.0.1]) (amavisd-new, port 10024)
    with ESMTP id sgZOcajRz3xZ for <luong@gmail.com>;
    Mon, 29 Mar 2010 01:41:31 +0700 (ICT)
    Received: from luong (unknown [123.24.24.192])
    by mail.abc.com (Postfix) with ESMTPSA id 10B3021F7FD
    for <luong@gmail.com>; Mon, 29 Mar 2010 01:41:31 +0700 (ICT)
    The output is not different. Do you/anyone know why?

  7. #7
    gnoul is offline Active Member
    Join Date
    Jul 2009
    Location
    Vietnam
    Posts
    25
    Rep Power
    5

    Default

    Anyone can help me about this issue? I appriciate any kind of help.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by z1mbra View Post
    Anyone can help me about this issue? I appriciate any kind of help.
    I've already given you the command to check whether the x-originating-ip is set, or not, and you haven't said anything about that. I've also told you that you need to run the command I gave you before each test to see if the X-Originating-IP is set or not, you haven't done that (or at least you haven't posted any output from the command).

    The title of this thread is "I can't disable X-Originating-IP ", neither of those headers you've posted have an X-Originating-IP in there. So, what exactly is the problem and what is it you want changing? I'm somewhat confused by what you're telling me.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 32
    Last Post: 03-18-2011, 11:03 AM
  2. [SOLVED] Barracuda and Originating ip
    By mickier in forum Administrators
    Replies: 1
    Last Post: 01-26-2010, 06:35 AM
  3. [SOLVED] Adding XP PCs to a samba domain...
    By NoDoze in forum Administrators
    Replies: 43
    Last Post: 08-13-2009, 04:22 PM
  4. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  5. [SOLVED] How to change originating IP
    By epikos in forum Administrators
    Replies: 0
    Last Post: 03-31-2008, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •