Results 1 to 7 of 7

Thread: unable to start stats in zcs 6.0.5

  1. #1
    jet
    jet is offline Junior Member
    Join Date
    Dec 2008
    Posts
    9
    Rep Power
    6

    Default unable to start stats in zcs 6.0.5

    i have been using 6.0.5 for a couple of weeks already and just this morning i noticed that stats was stopped. i tried doing several restarts already hoping stats could start normally but unfortunately it didn't. could anyone please guide me how to find what is causing this.

  2. #2
    uxbod's Avatar
    uxbod is offline Moderator
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,016
    Rep Power
    24

    Default

    Please update your profile with the following information
    Code:
    su - zimbra
    zmcontrol -v
    and also post the following
    Code:
    su - zimbra
    zmcontrol status

  3. #3
    jet
    jet is offline Junior Member
    Join Date
    Dec 2008
    Posts
    9
    Rep Power
    6

    Default

    i noticed in the mailbox.log that there are permission denied messages in /opt/zimbra/zmstat/2010-02-20 folders so i tried browsing over /opt/zimbra/zmstat/ folder and noticed that two folders 2010-02-20 and 2010-02-21 have both root:root ownership where the rest of the folders are owned by zimbra:zimbra. i also noticed both folders have drwxr-xr-x folder permissions while the rest of the folders have drwxr-x--- folder permission.

    so i tried doing a chown zimbra:zimbra -R on both folders and did a server restart and luckily stat finally started okay.

    what troubles me right now is how this thing happened. could it be a bug on zimbra.

  4. #4
    joho's Avatar
    joho is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Default

    Our stats service shuts down a few hours after we enable it, every time. It has been like this since 6 GA .. don't know what to do about it really, I guess just sucking it up and moving on is our current strategy.

  5. #5
    joho's Avatar
    joho is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Default

    Having thousands of lines of this may be a clue:

    Use of uninitialized value in subtraction (-) at /opt/zimbra/libexec/zmstat-allprocs line 118

  6. #6
    jet
    jet is offline Junior Member
    Join Date
    Dec 2008
    Posts
    9
    Rep Power
    6

    Default

    strangely, the problem recurred again and noticed this morning. this time arount it's the 2010-02-28 and 2010-03-01 folders. did the same chown command and everything works fine again. i wonder what is causing this and how to correct it permanently. does anyone in the forum having similar problem?

  7. #7
    tonyawbrey Guest

    Default

    We are having same issue, I found some folders with authority problems like you list and fixed them and now our stats is running again. I suspect it will be short lived until another folder get the wrong ownership again so I opened bug Bug 45010 – Stats service failing due to folder permissions getting set wrong to have zimbra hopefully fix what is causing the folders to get the wrong ownership.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. FOSS zcs 6.0.5 upgrade, Notification Failed
    By TheCowStir in forum Installation
    Replies: 3
    Last Post: 03-22-2010, 06:00 PM
  3. Unable to start Postfix & Mailbox + trouble on upgrade
    By tamilnandhu in forum Installation
    Replies: 8
    Last Post: 11-01-2007, 09:40 AM
  4. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •