Results 1 to 8 of 8

Thread: zimbra server error

  1. #1
    handsprice is offline Active Member
    Join Date
    Feb 2010
    Posts
    32
    Rep Power
    5

    Default zimbra server error

    i received this error recently

    "Message: system failure: exception during auth {RemoteManager: zimbra.test.my->zimbra@zimbra.test.my:22} Error code: service.FAILURE Details:soap:Receiver "

    my server os is fedora 11. i had tried the solution provided by the link "http://www.zimbra.com/forums/administrators/24544-still-cannot-resolve-system-failure-exception-during-auth.html" but the problem still remain...pls advice

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Please update your forum profile with the output of the following command (do not post it in this thread):

    Code:
    zmcontrol -v
    You haven't given many details on this problem. Is this a new install or an upgrade? Has it just started happening? Are you saying that you've actually regenerated the Self Signed Certificates on the server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    handsprice is offline Active Member
    Join Date
    Feb 2010
    Posts
    32
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    Please update your forum profile with the output of the following command (do not post it in this thread):

    Code:
    zmcontrol -v
    You haven't given many details on this problem. Is this a new install or an upgrade? Has it just started happening? Are you saying that you've actually regenerated the Self Signed Certificates on the server?
    my zimbra version is open source 6.0.5 GA for fedora 11 32bit, my server is a new install server. The error prompt when i try to view the server status & statistic.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by handsprice View Post
    my zimbra version is open source 6.0.5 GA for fedora 11 32bit,
    I asked you to put that information in your forum profile not in the thread, please follow the link I gave you and update the profile.

    Quote Originally Posted by handsprice View Post
    The error prompt when i try to view the server status & statistic.
    The thread you linked to has a solution of regenerating the certificates, I asked if you'd done that - did you?

    If this server is behind a NAT router (or firewall) did you set-up a Split DNS? If not then you should have done. Please also post the output of the following command (run on the Zimbra server):

    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain.com mx
    dig yourdomain.com any
    host `hostname` <- use that exact command with backticks not single quotes
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    handsprice is offline Active Member
    Join Date
    Feb 2010
    Posts
    32
    Rep Power
    5

    Default

    Quote Originally Posted by phoenix View Post
    I asked you to put that information in your forum profile not in the thread, please follow the link I gave you and update the profile.
    i had updated my profile
    Quote Originally Posted by phoenix View Post
    The thread you linked to has a solution of regenerating the certificates, I asked if you'd done that - did you?
    i had regenerated the cert by follow the instruction provice by the thread

    Quote Originally Posted by phoenix View Post
    If this server is behind a NAT router (or firewall) did you set-up a Split DNS? If not then you should have done. Please also post the output of the following command (run on the Zimbra server):
    quotes
    the server is just a test server, is not yet in production.

    below is the output you need

    /etc/hosts
    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain
    4
    192.168.1.233 zimbra.test.my test.my

    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

    /etc/resolv.conf

    # Generated by NetworkManager

    nameserver 202.160.1.22

    nameserver 202.160.7.50

    dig test.my mx

    ; <<>> DiG 9.6.1b1-RedHat-9.6.1-0.3.b1.fc11 <<>> test.my mx

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 32388

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0


    ;; QUESTION SECTION
    :
    ;test.my. IN MX


    ;; Query time: 782 msec

    ;; SERVER: 202.160.1.22#53(202.160.1.22)

    ;; WHEN: Mon Feb 22 08:25:27 2010

    ;; MSG SIZE rcvd: 32


    dig test.my any

    ; <<>> DiG 9.6.1b1-RedHat-9.6.1-0.3.b1.fc11 <<>> test.my any

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 14434

    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0


    ;; QUESTION SECTION
    :
    ;test.my. IN ANY


    ;; Query time: 752 msec

    ;; SERVER: 202.160.1.22#53(202.160.1.22)

    ;; WHEN: Mon Feb 22 08:26:22 2010

    ;; MSG SIZE rcvd: 32



    host `hostname`

    Host zimbra.test.my not found: 2(SERVFAIL)

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Your hosts file is incorrect, the following line:

    Code:
    192.168.1.233 zimbra.test.my test.my
    should look like this:
    Code:
    192.168.1.233 zimbra.test.my test.my zimbra
    The results of the commands you posted show that you have no valid DNS A & MX records for your domain, you need them. Please follow the Split DNS instructions and set them correctly.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    gimecoffee is offline Intermediate Member
    Join Date
    Apr 2010
    Location
    Bend, Or
    Posts
    18
    Rep Power
    5

    Default

    I'm having the same issue. I think I have the split dns setup correctly. This is behind a firewall but it's not in production and I'm using a test domain. My host is Fedora 11 x64.

    Code:
    cat /etc/hosts
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    192.168.1.238   zimbra.cardinal-services.com cardinal-services.com zimbra
    ::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
    
    cat /etc/resolv.conf
    # Generated by NetworkManager
    nameserver 127.0.0.1
    
    dig zimbra.cardinal-services.com mx
    
    ; <<>> DiG 9.6.2-P1-RedHat-9.6.2-3.P1.fc11 <<>> zimbra.cardinal-services.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51560
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;zimbra.cardinal-services.com.  IN      MX
    
    ;; ANSWER SECTION:
    zimbra.cardinal-services.com. 86400 IN  MX      10 zimbra.cardinal-services.com.
    
    ;; AUTHORITY SECTION:
    zimbra.cardinal-services.com. 86400 IN  NS      ns.zimbra.cardinal-services.com.
    
    ;; ADDITIONAL SECTION:
    zimbra.cardinal-services.com. 86400 IN  A       192.168.1.238
    ns.zimbra.cardinal-services.com. 86400 IN A     192.168.1.238
    
    ;; Query time: 6 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 15 16:50:26 2010
    ;; MSG SIZE  rcvd: 111
    
    dig zimbra.cardinal-services.com any
    
    ; <<>> DiG 9.6.2-P1-RedHat-9.6.2-3.P1.fc11 <<>> zimbra.cardinal-services.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32361
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;zimbra.cardinal-services.com.  IN      ANY
    
    ;; ANSWER SECTION:
    zimbra.cardinal-services.com. 86400 IN  SOA     zimbra.cardinal-services.com. hostmaster.zimbra.cardinal-services.com. 2010041506 28800 14400 2419200 86400
    zimbra.cardinal-services.com. 86400 IN  NS      ns.zimbra.cardinal-services.com.
    zimbra.cardinal-services.com. 86400 IN  A       192.168.1.238
    zimbra.cardinal-services.com. 86400 IN  MX      10 zimbra.cardinal-services.com.
    
    ;; ADDITIONAL SECTION:
    ns.zimbra.cardinal-services.com. 86400 IN A     192.168.1.238
    
    ;; Query time: 4 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Apr 15 16:51:19 2010
    ;; MSG SIZE  rcvd: 158
    
    host `hostname`
    zimbra.cardinal-services.com has address 192.168.1.238
    zimbra.cardinal-services.com mail is handled by 10 zimbra.cardinal-services.com.
    I think this has something to do with SSH. Here is a copy of my fedora 11 audit.log when I get the error in the interface:
    Code:
    type=AVC msg=audit(1271373191.708:768): avc:  denied  { read } for  pid=20567 comm="sshd" name="authorized_keys" dev=dm-0 ino=5359465 scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:usr_t:s0 tclass=file
    type=SYSCALL msg=audit(1271373191.708:768): arch=c000003e syscall=2 success=no exit=-13 a0=7fea0ffc7ff0 a1=800 a2=1 a3=7fea0fc627b0 items=0 ppid=1649 pid=20567 auid=4294967295 uid=0 gid=0 euid=502 suid=0 fsuid=502 egid=502 sgid=0 fsgid=502 tty=(none) ses=4294967295 comm="sshd" exe="/usr/sbin/sshd" subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 key=(null)
    type=USER_LOGIN msg=audit(1271373191.708:769): user pid=20567 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 msg='acct="zimbra": exe="/usr/sbin/sshd" (hostname=?, addr=192.168.1.238, terminal=sshd res=failed)'
    type=USER_ERR msg=audit(1271373196.542:770): user pid=20567 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:sshd_t:s0-s0:c0.c1023 msg='op=PAM:bad_ident acct="?" exe="/usr/sbin/sshd" (hostname=zimbra, addr=192.168.1.238, terminal=ssh res=failed)'
    I can ssh for the user zimbra if I put in a password but the empty passphrase seems to not be working. I tried an empty passphrase on my own login account and it works fine so it appears to be just the zimbra user.

    Thoughts?
    Rois Cannon

  8. #8
    gimecoffee is offline Intermediate Member
    Join Date
    Apr 2010
    Location
    Bend, Or
    Posts
    18
    Rep Power
    5

    Default

    Problem Solved. I skipped over the instructions that read "SELinux should be disabled." Once I did that and rebooted I stopped getting those messages.

    Rois Cannon

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. [SOLVED] Important Mta Issue!!!!!!!!
    By borngunners in forum Migration
    Replies: 2
    Last Post: 01-05-2010, 06:44 AM
  2. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •