Results 1 to 4 of 4

Thread: Upgrading 5.0.21 -> 6.0.5 SSL Server Certs Changed

  1. #1
    sqb
    sqb is offline Intermediate Member
    Join Date
    Jun 2007
    Location
    Alice Springs, NT, 0870, Australia
    Posts
    16
    Rep Power
    8

    Default Upgrading 5.0.21 -> 6.0.5 SSL Server Certs Changed

    I just upgraded our ubuntu6 zimbra server and the pre-existing https server certs are no longer being used.

    This caused mayhem as all staff browsers encountered had security exceptions accessing zimbra.

    Worse, the new cert created by the upgrade expires in only 9 months 14/11/2010!

    This has not occurred on previous upgrades.

    What is the story here Zimbra?

    How do we prevent this in future?
    Stewart Baillie

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    I presume you meant 6.0.5 not 6.0.6 as stated in your title? I've changed to to reflect the correct version.

    If you're talking about Self Signed Certificates, they are always regenerated during an upgrade.

    Please update your forum profile with the output of the following (do not post it in this thread):

    Code:
    zmcontrol -v
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    sqb
    sqb is offline Intermediate Member
    Join Date
    Jun 2007
    Location
    Alice Springs, NT, 0870, Australia
    Posts
    16
    Rep Power
    8

    Default

    Oops, yep, 6.0.5 GA, close to our server distro Ubuntu 6.06 ;-)

    I understand that the internal certs used between zimbra component are regenerated.

    But, I've been upgrading since 4.5.5 and this is the first time I recall our web client https certificate has been blown away... or does this occur only on major release number upgrades such as 5.0.x -> 6.0.x? Nothing like this happened on my previous upgrades 5.0.8 -> 5.0.15 and 5.0.15 -> 5.0.21
    Stewart Baillie

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,491
    Rep Power
    56

    Default

    Quote Originally Posted by sqb View Post
    But, I've been upgrading since 4.5.5 and this is the first time I recall our web client https certificate has been blown away... or does this occur only on major release number upgrades such as 5.0.x -> 6.0.x? Nothing like this happened on my previous upgrades 5.0.8 -> 5.0.15 and 5.0.15 -> 5.0.21
    Yes destroying the Commercial Certificate was a minor hiccup (English humour ) in 6.0.5, it's been fixed in the next release. I believe there's also some recent forum threads that discussed this problem.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cant install any SSL Certs
    By baradeithel in forum Administrators
    Replies: 3
    Last Post: 12-04-2009, 02:39 PM
  2. Invalid or untrusted server SSL certificate
    By GaryParr in forum General Questions
    Replies: 34
    Last Post: 02-13-2009, 11:39 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. Replies: 1
    Last Post: 04-13-2006, 04:47 PM
  5. SSL and multiple mail server aliases
    By altimage in forum Installation
    Replies: 3
    Last Post: 12-11-2005, 04:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •